summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 02:52:53 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2008-11-13 02:52:53 +0000
commitb5143ff2bde63cf46dc194a2d1c496b50bf97330 (patch)
tree5c691969409d4c904cda54416508ead919846649 /app-cdr
parentMarking culmus-0.101-r2 ~ppc64 for bug 168331 (diff)
downloadgentoo-2-b5143ff2bde63cf46dc194a2d1c496b50bf97330.tar.gz
gentoo-2-b5143ff2bde63cf46dc194a2d1c496b50bf97330.tar.bz2
gentoo-2-b5143ff2bde63cf46dc194a2d1c496b50bf97330.zip
Version bump, the new version does not require OpenSSL, but I had to write a makefile for it since the one provided by upstream is not flexible enough for our needs.
(Portage version: 2.2_rc14/cvs/Linux 2.6.27-gentoo-r2 x86_64)
Diffstat (limited to 'app-cdr')
-rw-r--r--app-cdr/uif2iso/ChangeLog10
-rw-r--r--app-cdr/uif2iso/files/0.1.7-Makefile9
-rw-r--r--app-cdr/uif2iso/uif2iso-0.1.7.ebuild32
3 files changed, 50 insertions, 1 deletions
diff --git a/app-cdr/uif2iso/ChangeLog b/app-cdr/uif2iso/ChangeLog
index 10f4cbf6ebe0..8372c85ffda5 100644
--- a/app-cdr/uif2iso/ChangeLog
+++ b/app-cdr/uif2iso/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-cdr/uif2iso
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/uif2iso/ChangeLog,v 1.2 2008/06/17 20:49:13 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/uif2iso/ChangeLog,v 1.3 2008/11/13 02:52:53 flameeyes Exp $
+
+*uif2iso-0.1.7 (13 Nov 2008)
+
+ 13 Nov 2008; Diego Pettenò <flameeyes@gentoo.org> +files/0.1.7-Makefile,
+ +uif2iso-0.1.7.ebuild:
+ Version bump, the new version does not require OpenSSL, but I had to write
+ a makefile for it since the one provided by upstream is not flexible
+ enough for our needs.
17 Jun 2008; Christian Faulhammer <opfer@gentoo.org> uif2iso-0.1.4.ebuild:
keyworded ~arch for x86, bug 226165
diff --git a/app-cdr/uif2iso/files/0.1.7-Makefile b/app-cdr/uif2iso/files/0.1.7-Makefile
new file mode 100644
index 000000000000..fbee3affa3a3
--- /dev/null
+++ b/app-cdr/uif2iso/files/0.1.7-Makefile
@@ -0,0 +1,9 @@
+# We replace the makefile since the upstream one is not suitable for
+# us :(
+
+OBJS := $(patsubst %.c,%.o,$(wildcard *.c))
+
+CFLAGS += -DMAGICISO_IS_SHIT
+
+uif2iso: $(OBJS)
+ $(CC) $(LDFLAGS) $^ -o $@ -lz
diff --git a/app-cdr/uif2iso/uif2iso-0.1.7.ebuild b/app-cdr/uif2iso/uif2iso-0.1.7.ebuild
new file mode 100644
index 000000000000..c57cf3b0df38
--- /dev/null
+++ b/app-cdr/uif2iso/uif2iso-0.1.7.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/uif2iso/uif2iso-0.1.7.ebuild,v 1.1 2008/11/13 02:52:53 flameeyes Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Converts MagicISO CD-images to iso"
+HOMEPAGE="http://aluigi.org/mytoolz.htm#uif2iso"
+SRC_URI="mirror://gentoo/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ app-arch/unzip"
+
+S="${WORKDIR}/src"
+
+src_compile() {
+ # Yes we use our own makefile, I'll try to explain this to
+ # upstream _again_.
+ emake CC="$(tc-getCC)" -f "${FILESDIR}/${PV}-Makefile" || die "emake failed"
+}
+
+src_install() {
+ dobin ${PN} || die "failed to install"
+
+ dodoc "${WORKDIR}"/${PN}.txt "${WORKDIR}"/README
+}