summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2009-03-12 07:49:14 +0000
committerTiziano Müller <dev-zero@gentoo.org>2009-03-12 07:49:14 +0000
commited2995a4568b0eacdab2683da8683fb0900d74bd (patch)
tree56938a0153230620c370e3cc6e3d177d1b78678b /app-cdr/cdemu
parentremove cgraph USE-flag as it is not ready yet according to upstream, bug #261... (diff)
downloadgentoo-2-ed2995a4568b0eacdab2683da8683fb0900d74bd.tar.gz
gentoo-2-ed2995a4568b0eacdab2683da8683fb0900d74bd.tar.bz2
gentoo-2-ed2995a4568b0eacdab2683da8683fb0900d74bd.zip
Cleanup of the ebuild (including EAPI=2 usage, adding usage of python eclass)
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'app-cdr/cdemu')
-rw-r--r--app-cdr/cdemu/ChangeLog10
-rw-r--r--app-cdr/cdemu/cdemu-1.1.0-r1.ebuild44
2 files changed, 52 insertions, 2 deletions
diff --git a/app-cdr/cdemu/ChangeLog b/app-cdr/cdemu/ChangeLog
index 12b6476c6d19..608dcbd4362f 100644
--- a/app-cdr/cdemu/ChangeLog
+++ b/app-cdr/cdemu/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-cdr/cdemu
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/ChangeLog,v 1.16 2008/08/22 22:11:22 maekke Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/ChangeLog,v 1.17 2009/03/12 07:49:14 dev-zero Exp $
+
+*cdemu-1.1.0-r1 (12 Mar 2009)
+
+ 12 Mar 2009; Tiziano Müller <dev-zero@gentoo.org> +cdemu-1.1.0-r1.ebuild:
+ Cleanup of the ebuild (including EAPI=2 usage, adding usage of python
+ eclass)
22 Aug 2008; Markus Meier <maekke@gentoo.org> cdemu-1.0.0.ebuild:
amd64 stable, bug #232566
diff --git a/app-cdr/cdemu/cdemu-1.1.0-r1.ebuild b/app-cdr/cdemu/cdemu-1.1.0-r1.ebuild
new file mode 100644
index 000000000000..59e25635e3c8
--- /dev/null
+++ b/app-cdr/cdemu/cdemu-1.1.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-cdr/cdemu/cdemu-1.1.0-r1.ebuild,v 1.1 2009/03/12 07:49:14 dev-zero Exp $
+
+EAPI="2"
+
+inherit multilib python
+
+DESCRIPTION="Client of cdemu suite, which mounts all kinds of cd images"
+HOMEPAGE="http://cdemu.org"
+SRC_URI="mirror://sourceforge/cdemu/cdemu-client-${PV}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-lang/python-2.4
+ dev-python/dbus-python
+ app-cdr/cdemud"
+DEPEND="${RDEPEND}
+ dev-util/intltool"
+
+S="${WORKDIR}/cdemu-client-${PV}"
+
+src_prepare() {
+ # disable compilation of python modules
+ rm py-compile || die
+ ln -s "$(type -P true)" py-compile || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "install failed"
+ dodoc AUTHORS ChangeLog README
+}
+
+pkg_postinst() {
+ python_version
+ python_mod_optimize /usr/$(get_libdir)/${PYVER}/site-packages/cdemu
+ python_need_rebuild
+}
+
+pkg_postrm() {
+ python_mod_cleanup
+}