summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-01-07 08:07:37 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-01-07 08:07:37 +0000
commit9a5081dcde8f442d7f038f2a959c0ca359f460b5 (patch)
tree06446b979077e925ec6a4e3b2a1a630413ff7558 /app-benchmarks
parentlang.desc -> desc/linguas.desc, aka no need for this bugger anymore (diff)
downloadgentoo-2-9a5081dcde8f442d7f038f2a959c0ca359f460b5.tar.gz
gentoo-2-9a5081dcde8f442d7f038f2a959c0ca359f460b5.tar.bz2
gentoo-2-9a5081dcde8f442d7f038f2a959c0ca359f460b5.zip
Version bump, fixes some segfaults on 64-bit.
(Portage version: 2.1.2_rc4-r6)
Diffstat (limited to 'app-benchmarks')
-rw-r--r--app-benchmarks/siege/ChangeLog9
-rw-r--r--app-benchmarks/siege/files/digest-siege-2.64-r12
-rw-r--r--app-benchmarks/siege/files/digest-siege-2.653
-rw-r--r--app-benchmarks/siege/siege-2.65.ebuild64
4 files changed, 76 insertions, 2 deletions
diff --git a/app-benchmarks/siege/ChangeLog b/app-benchmarks/siege/ChangeLog
index b2fd3850f5d3..10a79abe3ced 100644
--- a/app-benchmarks/siege/ChangeLog
+++ b/app-benchmarks/siege/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-benchmarks/siege
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.36 2006/12/13 23:45:52 masterdriverz Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/ChangeLog,v 1.37 2007/01/07 08:07:37 robbat2 Exp $
+
+*siege-2.65 (07 Jan 2007)
+
+ 07 Jan 2007; Robin H. Johnson <robbat2@gentoo.org> +siege-2.65.ebuild:
+ Version bump, fixes some segfaults on 64-bit.
13 Dec 2006; Charlie Shepherd <masterdriverz@gentoo.org>
siege-2.60.ebuild, siege-2.61-r1.ebuild, siege-2.64-r1.ebuild:
diff --git a/app-benchmarks/siege/files/digest-siege-2.64-r1 b/app-benchmarks/siege/files/digest-siege-2.64-r1
index fa00d3607b78..5256be1cdb5b 100644
--- a/app-benchmarks/siege/files/digest-siege-2.64-r1
+++ b/app-benchmarks/siege/files/digest-siege-2.64-r1
@@ -1 +1,3 @@
MD5 9ee08da6e242a96945732af231074793 siege-2.64.tar.gz 480612
+RMD160 6447871f20c04cb3ef39930569071a67d1bfe985 siege-2.64.tar.gz 480612
+SHA256 063888555b2fbf362440496397da6e0ccf724fed9b990135231dec5b8bb5f47e siege-2.64.tar.gz 480612
diff --git a/app-benchmarks/siege/files/digest-siege-2.65 b/app-benchmarks/siege/files/digest-siege-2.65
new file mode 100644
index 000000000000..e5a61c503036
--- /dev/null
+++ b/app-benchmarks/siege/files/digest-siege-2.65
@@ -0,0 +1,3 @@
+MD5 90c6c1519cc65b081efcdf3a7207a93f siege-2.65.tar.gz 472720
+RMD160 6e42262b02983caff84feada3e833082a479b1bc siege-2.65.tar.gz 472720
+SHA256 5595ee6789c7fc603a5cac326922de1a4bd0d09a79c7e44ddc927cc5ea382e9e siege-2.65.tar.gz 472720
diff --git a/app-benchmarks/siege/siege-2.65.ebuild b/app-benchmarks/siege/siege-2.65.ebuild
new file mode 100644
index 000000000000..1bd1258bcc44
--- /dev/null
+++ b/app-benchmarks/siege/siege-2.65.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/siege/siege-2.65.ebuild,v 1.1 2007/01/07 08:07:37 robbat2 Exp $
+
+inherit eutils bash-completion
+
+DESCRIPTION="A HTTP regression testing and benchmarking utility"
+HOMEPAGE="http://www.joedog.org/JoeDog/Siege"
+SRC_URI="ftp://sid.joedog.org/pub/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="debug ssl"
+
+DEPEND="ssl? ( >=dev-libs/openssl-0.9.6d )"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch ${FILESDIR}/${PN}-2.60-gentoo.diff
+
+ # use of \b causes the T in "Transactions" to be displayed
+ # on the last column of the previous line.
+ sed -i 's/\\b\(Transactions:\)/\1/' src/main.c || \
+ die "sed src/main.c failed"
+
+ automake || die "automake failed"
+}
+
+src_compile() {
+ local myconf
+ use ssl && myconf="--with-ssl=/usr" || myconf="--without-ssl"
+
+ econf ${myconf} \
+ $(use_with debug debugging) \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+
+ # bug 111057 - siege.config utility uses ${} which gets
+ # interpreted by bash sending the contents to stderr
+ # instead of ${HOME}/.siegerc
+ sed -i -e 's|\${}|\\${}|' -e 's|\$(HOME)|\\$(HOME)|' \
+ ${D}/usr/bin/siege.config
+
+ dodoc AUTHORS ChangeLog INSTALL MACHINES README* KNOWNBUGS \
+ siegerc-example urls.txt || die "dodoc failed"
+ dobashcompletion ${FILESDIR}/${PN}.bash-completion
+
+ for x in $(find ${D}/usr/bin -name '*.pl') ; do mv "${x}" "${x%.*}" ; done
+}
+
+pkg_postinst() {
+ echo
+ einfo "An example ~/.siegerc file has been installed as"
+ einfo "/usr/share/doc/${PF}/siegerc-example.gz"
+ bash-completion_pkg_postinst
+}