summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-12-14 12:43:34 +0000
committerJeroen Roovers <jer@gentoo.org>2009-12-14 12:43:34 +0000
commit1492f22fce338643c95119224ae62c5fe9c5659c (patch)
tree53be0d92ab9219df126e75d6e30a9710eab42568 /app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
parentBumping to 1.9.6 and fixing bug #270252 (diff)
downloadgentoo-2-1492f22fce338643c95119224ae62c5fe9c5659c.tar.gz
gentoo-2-1492f22fce338643c95119224ae62c5fe9c5659c.tar.bz2
gentoo-2-1492f22fce338643c95119224ae62c5fe9c5659c.zip
Bump to hopefully fix missing pointer.h (bug #296860).
(Portage version: 2.2_rc59/cvs/Linux i686)
Diffstat (limited to 'app-benchmarks/nbench/nbench-2.2.3-r1.ebuild')
-rw-r--r--app-benchmarks/nbench/nbench-2.2.3-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild b/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
new file mode 100644
index 000000000000..3529b9624de9
--- /dev/null
+++ b/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/nbench/nbench-2.2.3-r1.ebuild,v 1.1 2009/12/14 12:43:34 jer Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-byte-${PV}"
+DESCRIPTION="Linux/Unix of release 2 of BYTE Magazine's BYTEmark benchmark"
+HOMEPAGE="http://www.tux.org/~mayer/linux/bmark.html"
+SRC_URI="http://www.tux.org/~mayer/linux/${MY_P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~ppc64 ~sh ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ cp -va Makefile{,.org}
+ epatch "${FILESDIR}/${P}-Makefile.patch"
+ sed \
+ -e 's:$compiler -v\( 2>&1 | sed -e "/version/!d"\|\):$compiler -dumpversion:' \
+ -i sysinfo.sh || die "patching sysinfo.sh failed"
+ sed -e 's:inpath="NNET.DAT":inpath="/usr/share/nbench/NNET.DAT":' \
+ -i nbench1.h || die "patching nbench1.h failed"
+ #sed \
+ # -e 's|./sysinfo.sh|sh sysinfo.sh|g' \
+ # -i Makefile || die "patching Makefile failed"
+}
+
+src_compile() {
+
+ emake LINKFLAGS="${LDFLAGS}" CC=$(tc-getCC) CFLAGS="${CFLAGS}" || die "make failed"
+}
+
+src_install() {
+ dobin nbench
+ insinto /usr/share/nbench
+ doins NNET.DAT
+
+ dodoc Changes README* bdoc.txt
+}