summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Black <dragonheart@gentoo.org>2004-05-13 04:56:41 +0000
committerDaniel Black <dragonheart@gentoo.org>2004-05-13 04:56:41 +0000
commit6cc21525885c8f74a726705ec8d08dc875baf66e (patch)
tree1f3cda6670509bd4858c3a1e9b852001e441c93f /app-benchmarks/iozone
parentInitial import thanks Sven Wegener <sven.wegener@stealer.net> for the ebuild ... (diff)
downloadgentoo-2-6cc21525885c8f74a726705ec8d08dc875baf66e.tar.gz
gentoo-2-6cc21525885c8f74a726705ec8d08dc875baf66e.tar.bz2
gentoo-2-6cc21525885c8f74a726705ec8d08dc875baf66e.zip
Inital import by Jesse Becker <jbecker@speakeasy.net> in bug #50804
Diffstat (limited to 'app-benchmarks/iozone')
-rw-r--r--app-benchmarks/iozone/ChangeLog10
-rw-r--r--app-benchmarks/iozone/Manifest2
-rw-r--r--app-benchmarks/iozone/files/digest-iozone-3.2171
-rw-r--r--app-benchmarks/iozone/iozone-3.217.ebuild50
-rw-r--r--app-benchmarks/iozone/metadata.xml12
5 files changed, 75 insertions, 0 deletions
diff --git a/app-benchmarks/iozone/ChangeLog b/app-benchmarks/iozone/ChangeLog
new file mode 100644
index 000000000000..b816405cf79d
--- /dev/null
+++ b/app-benchmarks/iozone/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for app-benchmarks/iozone
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/ChangeLog,v 1.1 2004/05/13 04:56:40 dragonheart Exp $
+
+*iozone-3.217 (13 May 2004)
+
+ 13 May 2004; Daniel Black <dragonheart@gentoo.org> +metadata.xml,
+ +iozone-3.217.ebuild:
+ Inital import by Jesse Becker <jbecker@speakeasy.net> in bug #50804
+
diff --git a/app-benchmarks/iozone/Manifest b/app-benchmarks/iozone/Manifest
new file mode 100644
index 000000000000..403966c8c965
--- /dev/null
+++ b/app-benchmarks/iozone/Manifest
@@ -0,0 +1,2 @@
+MD5 918230f155e4d57851e17fe8f45f6808 iozone-3.217.ebuild 794
+MD5 e656883c1b06fd737e3f145ee18fb5b5 files/digest-iozone-3.217 61
diff --git a/app-benchmarks/iozone/files/digest-iozone-3.217 b/app-benchmarks/iozone/files/digest-iozone-3.217
new file mode 100644
index 000000000000..c8c2856bb849
--- /dev/null
+++ b/app-benchmarks/iozone/files/digest-iozone-3.217
@@ -0,0 +1 @@
+MD5 5b9eb860857f3a92873edc9e681a964b iozone3_217.tar 1413120
diff --git a/app-benchmarks/iozone/iozone-3.217.ebuild b/app-benchmarks/iozone/iozone-3.217.ebuild
new file mode 100644
index 000000000000..154311f037f0
--- /dev/null
+++ b/app-benchmarks/iozone/iozone-3.217.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/iozone/iozone-3.217.ebuild,v 1.1 2004/05/13 04:56:41 dragonheart Exp $
+
+inherit eutils
+
+DESCRIPTION="Filesystem benchmarking program."
+HOMEPAGE="http://www.iozone.org/"
+SRC_URI="http://www.iozone.org/src/current/${PN}${PV/./_}.tar"
+LICENSE="freedist"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+DEPEND="sys-devel/gcc"
+
+S=${WORKDIR}
+
+src_compile() {
+
+ case ${ARCH} in
+ x86|alpha)
+ PLATFORM="linux"
+ ;;
+ ppc)
+ PLATFORM="linux-powerpc"
+ ;;
+ *)
+ PLATFORM="linux-${ARCH}"
+ ;;
+ esac
+
+ cd src/current
+ emake ${PLATFORM} || die "Compile failed"
+}
+
+src_install() {
+ dosbin src/current/iozone
+ dodoc docs/IO*
+ dodoc docs/Run_rules.doc
+ dodoc src/current/Changes.txt
+ doman docs/iozone.1
+
+ dodir /usr/share/${PF}
+ insinto /usr/share/${PF}
+ cd src/current
+ doins Generate_Graphs Gnuplot.txt gengnuplot.sh gnu3d.dem
+
+ prepall
+}
diff --git a/app-benchmarks/iozone/metadata.xml b/app-benchmarks/iozone/metadata.xml
new file mode 100644
index 000000000000..b9fc2b9c6f11
--- /dev/null
+++ b/app-benchmarks/iozone/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+ <description>A user ebuild that I felt obliged to include. Please take over if you want
+it</description>
+</maintainer>
+<longdescription></longdescription>
+</pkgmetadata>