summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEmanuele Giaquinta <exg@gentoo.org>2006-06-27 23:46:07 +0000
committerEmanuele Giaquinta <exg@gentoo.org>2006-06-27 23:46:07 +0000
commitf591404393701e8f6da11b37510376d4001e4d2d (patch)
tree9b0819c08c867b867c8f504db20b9618deb72ba7 /app-benchmarks/acovea
parentMarked ~hppa (for media-gfx/inkscape). (diff)
downloadgentoo-2-f591404393701e8f6da11b37510376d4001e4d2d.tar.gz
gentoo-2-f591404393701e8f6da11b37510376d4001e4d2d.tar.bz2
gentoo-2-f591404393701e8f6da11b37510376d4001e4d2d.zip
Version bump, bug #86142. Add ~ppc keyword. Fix linking with --as-needed. Fix
double free issue by kristiaan.lenaerts@gmail.com. (Portage version: 2.1.1_pre1-r4)
Diffstat (limited to 'app-benchmarks/acovea')
-rw-r--r--app-benchmarks/acovea/ChangeLog12
-rw-r--r--app-benchmarks/acovea/acovea-5.1.1.ebuild34
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch16
-rw-r--r--app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch12
-rw-r--r--app-benchmarks/acovea/files/digest-acovea-5.1.13
5 files changed, 75 insertions, 2 deletions
diff --git a/app-benchmarks/acovea/ChangeLog b/app-benchmarks/acovea/ChangeLog
index 6a008570f01d..ce5a18da2c7c 100644
--- a/app-benchmarks/acovea/ChangeLog
+++ b/app-benchmarks/acovea/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-benchmarks/acovea
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/ChangeLog,v 1.6 2005/01/01 12:02:57 eradicator Exp $
+# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/ChangeLog,v 1.7 2006/06/27 23:46:07 exg Exp $
+
+*acovea-5.1.1 (27 Jun 2006)
+
+ 27 Jun 2006; Emanuele Giaquinta <exg@gentoo.org>
+ +files/acovea-5.1.1-asneeded.patch, +files/acovea-5.1.1-free-fix.patch,
+ +acovea-5.1.1.ebuild:
+ Version bump, bug #86142. Add ~ppc keyword. Fix linking with --as-needed. Fix
+ double free issue by kristiaan.lenaerts@gmail.com.
28 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/app-benchmarks/acovea/acovea-5.1.1.ebuild b/app-benchmarks/acovea/acovea-5.1.1.ebuild
new file mode 100644
index 000000000000..460b44aec01f
--- /dev/null
+++ b/app-benchmarks/acovea/acovea-5.1.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-benchmarks/acovea/acovea-5.1.1.ebuild,v 1.1 2006/06/27 23:46:07 exg Exp $
+
+inherit autotools
+
+DESCRIPTION="Analysis of Compiler Options via Evolutionary Algorithm"
+HOMEPAGE="http://www.coyotegulch.com/products/acovea/"
+SRC_URI="http://www.coyotegulch.com/distfiles/lib${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-libs/libcoyotl
+ dev-libs/libevocosm
+ dev-libs/expat"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/lib${P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-asneeded.patch
+ epatch "${FILESDIR}"/${P}-free-fix.patch
+ eautomake
+}
+
+src_install() {
+ make DESTDIR="${D}" install
+ dodoc ChangeLog NEWS README
+}
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
new file mode 100644
index 000000000000..f3620be7f4b6
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-asneeded.patch
@@ -0,0 +1,16 @@
+--- cmdline/Makefile.am.old 2006-06-28 00:48:31.069459287 +0200
++++ cmdline/Makefile.am 2006-06-28 00:48:40.917331263 +0200
+@@ -7,4 +7,4 @@
+
+ runacovea_SOURCES = runacovea.cpp
+
+-LIBS = -L../libacovea -lacovea -lcoyotl -levocosm -lexpat
++LIBS = -L../libacovea -lacovea -lcoyotl -levocosm
+--- libacovea/Makefile.am.old 2006-06-28 00:48:10.959720717 +0200
++++ libacovea/Makefile.am 2006-06-28 00:48:53.436168516 +0200
+@@ -16,3 +16,5 @@
+ library_include_HEADERS = $(h_sources)
+
+ DEFS=-I. -I$(srcdir)
++
++LIBS = -lexpat
diff --git a/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
new file mode 100644
index 000000000000..c64a0af7ac8a
--- /dev/null
+++ b/app-benchmarks/acovea/files/acovea-5.1.1-free-fix.patch
@@ -0,0 +1,12 @@
+--- benchmarks/treebench.c.old 2006-06-28 01:08:11.190117519 +0200
++++ benchmarks/treebench.c 2006-06-28 01:08:22.124975364 +0200
+@@ -201,8 +201,8 @@
+ if (page->m_links[n] != NULL)
+ recursive_destroy_page(page->m_links[n]);
+
+- free(page);
+ }
++ free(page);
+ }
+
+ static void free_btree(btree * btree)
diff --git a/app-benchmarks/acovea/files/digest-acovea-5.1.1 b/app-benchmarks/acovea/files/digest-acovea-5.1.1
new file mode 100644
index 000000000000..ad182ff84eeb
--- /dev/null
+++ b/app-benchmarks/acovea/files/digest-acovea-5.1.1
@@ -0,0 +1,3 @@
+MD5 e3bfa6b782205bad083ba58a8b882158 libacovea-5.1.1.tar.gz 363048
+RMD160 1baad6a9cd1c536243544d62c6479381d7e5ae04 libacovea-5.1.1.tar.gz 363048
+SHA256 e84167ac683e6bf7720bd3edf1fc60e77961eb489d31fa2c1d0a34e7d67ae079 libacovea-5.1.1.tar.gz 363048