summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2007-03-10 21:41:31 +0000
committerWolfram Schlich <wschlich@gentoo.org>2007-03-10 21:41:31 +0000
commitd417c8f32a75d5b411a41ca55478b2f1bab92c9f (patch)
treeb15b5cffb891291797c79d232f52c61a49b23704 /app-backup
parentRemove weird dyn_unpack hack (removal requested by Kugelfang). Should have no... (diff)
downloadgentoo-2-d417c8f32a75d5b411a41ca55478b2f1bab92c9f.tar.gz
gentoo-2-d417c8f32a75d5b411a41ca55478b2f1bab92c9f.tar.bz2
gentoo-2-d417c8f32a75d5b411a41ca55478b2f1bab92c9f.zip
version bump
(Portage version: 2.1.2-r12)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/bacula/ChangeLog13
-rw-r--r--app-backup/bacula/bacula-2.0.3.ebuild358
-rw-r--r--app-backup/bacula/files/2.0.3/bacula-all-conf23
-rw-r--r--app-backup/bacula/files/2.0.3/bacula-all-init71
-rw-r--r--app-backup/bacula/files/2.0.3/bacula-dir-conf15
-rw-r--r--app-backup/bacula/files/2.0.3/bacula-dir-init25
-rw-r--r--app-backup/bacula/files/2.0.3/bacula-fd-conf8
-rw-r--r--app-backup/bacula/files/2.0.3/bacula-fd-init22
-rw-r--r--app-backup/bacula/files/2.0.3/bacula-sd-conf11
-rw-r--r--app-backup/bacula/files/2.0.3/bacula-sd-init22
-rw-r--r--app-backup/bacula/files/bacula-2.0.3-default-configs.patch110
-rw-r--r--app-backup/bacula/files/bacula-2.0.3-gnomesu2gksu.diff36
-rw-r--r--app-backup/bacula/files/digest-bacula-2.0.36
-rw-r--r--app-backup/bacula/metadata.xml5
14 files changed, 724 insertions, 1 deletions
diff --git a/app-backup/bacula/ChangeLog b/app-backup/bacula/ChangeLog
index b8e9c35ee3b3..8e06ed20d10d 100644
--- a/app-backup/bacula/ChangeLog
+++ b/app-backup/bacula/ChangeLog
@@ -1,6 +1,17 @@
# ChangeLog for app-backup/bacula
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.26 2007/03/08 09:31:30 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.27 2007/03/10 21:41:31 wschlich Exp $
+
+*bacula-2.0.3 (10 Mar 2007)
+
+ 10 Mar 2007; Wolfram Schlich <wschlich@gentoo.org>
+ +files/2.0.3/bacula-all-init, +files/2.0.3/bacula-dir-init,
+ +files/bacula-2.0.3-default-configs.patch, +files/2.0.3/bacula-dir-conf,
+ +files/2.0.3/bacula-fd-conf, +files/bacula-2.0.3-gnomesu2gksu.diff,
+ +files/2.0.3/bacula-all-conf, +files/2.0.3/bacula-fd-init,
+ +files/2.0.3/bacula-sd-conf, +files/2.0.3/bacula-sd-init,
+ +bacula-2.0.3.ebuild:
+ version bump
08 Mar 2007; Lisa Seelye <lisa@gentoo.org> bacula-2.0.2.ebuild:
Change src_compile so --with-$mydbtype as per bug 169698
diff --git a/app-backup/bacula/bacula-2.0.3.ebuild b/app-backup/bacula/bacula-2.0.3.ebuild
new file mode 100644
index 000000000000..db367a01d8c1
--- /dev/null
+++ b/app-backup/bacula/bacula-2.0.3.ebuild
@@ -0,0 +1,358 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-2.0.3.ebuild,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+#
+# TODO:
+# - install stuff from examples/:
+# - examples/nagios/ + add nagios USE flag etc.
+# (see also example/reports/check_bacula_pools.sh which is newer
+# than examples/nagios/check_bacula_pools.sh)
+# - examples/autochangers/
+# - examples/devices/
+# - examples/python/
+# - examples/reports/baculareport.pl
+# - correctly filter unneeded /usr/libexec/bacula/ stuff depending
+# on selected USE flags, e.g. bacula-clientonly
+# - install bacula-web and/or bweb from bacula-gui
+#
+
+inherit eutils
+
+IUSE="bacula-clientonly bacula-console bacula-nodir bacula-nosd bacula-split-init doc gnome logrotate logwatch mysql postgres python readline sqlite sqlite3 ssl static tcpd wxwindows X"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+DESCRIPTION="Featureful client/server network backup suite"
+HOMEPAGE="http://www.bacula.org/"
+
+DOC_VER="${PV}"
+SRC_URI="mirror://sourceforge/bacula/${P}.tar.gz
+ doc? ( mirror://sourceforge/bacula/${PN}-docs-${DOC_VER}.tar.gz )"
+
+LICENSE="GPL-2"
+SLOT="0"
+
+DEPEND="
+ >=sys-libs/zlib-1.1.4
+ dev-libs/gmp
+ !bacula-clientonly? (
+ postgres? ( >=dev-db/postgresql-7.4.0 )
+ mysql? ( virtual/mysql )
+ sqlite? ( =dev-db/sqlite-2* )
+ sqlite3? ( >=dev-db/sqlite-3.0.0 )
+ virtual/mta
+ )
+ bacula-console? (
+ wxwindows? ( >=x11-libs/wxGTK-2.4.2 )
+ gnome? (
+ >=gnome-base/libgnome-2
+ x11-libs/gksu
+ )
+ )
+ ssl? ( dev-libs/openssl )
+ logrotate? ( app-admin/logrotate )
+ logwatch? ( sys-apps/logwatch )
+ tcpd? ( >=sys-apps/tcp-wrappers-7.6 )
+ readline? ( >=sys-libs/readline-4.1 )
+ doc? (
+ virtual/ghostscript
+ dev-tex/latex2html
+ )"
+RDEPEND="${DEPEND}
+ !bacula-clientonly? (
+ sys-block/mtx
+ app-arch/mt-st
+ )"
+
+pkg_setup() {
+ local dbnum
+ declare -i dbnum=0
+ if ! useq bacula-clientonly; then
+ if useq mysql; then
+ export mydbtype='mysql'
+ let dbnum++
+ fi
+ if useq postgres; then
+ export mydbtype='postgresql'
+ let dbnum++
+ fi
+ if useq sqlite; then
+ export mydbtype='sqlite'
+ let dbnum++
+ fi
+ if useq sqlite3; then
+ export mydbtype='sqlite3'
+ let dbnum++
+ fi
+ if [[ "${dbnum}" -lt 1 ]]; then
+ eerror
+ eerror "To use ${P} it is required to set a database in the USE flags."
+ eerror "Supported databases are mysql, postgresql, sqlite, sqlite3"
+ eerror
+ die "No database type selected."
+ elif [[ "${dbnum}" -gt 1 ]]; then
+ eerror
+ eerror "You have set ${P} to use multiple database types."
+ eerror "I don't know which to set as the default!"
+ eerror "You can use /etc/portage/package.use to set per-package USE flags"
+ eerror "Set it so only one database type, mysql, postgres, sqlite, sqlite3"
+ eerror
+ die "Multiple database types selected."
+ fi
+ fi
+
+ # create the daemon group and user
+ if [ -z "$(egetent group bacula)" ]; then
+ enewgroup bacula
+ einfo
+ einfo "The group 'bacula' has been created. Any users you add to this"
+ einfo "group have access to files created by the daemons."
+ einfo
+ fi
+ if ! useq bacula-clientonly; then
+ if [ -z "$(egetent passwd bacula)" ]; then
+ enewuser bacula -1 -1 /var/lib/bacula bacula,disk,tape,cdrom,cdrw
+ einfo
+ einfo "The user 'bacula' has been created. Please see the bacula manual"
+ einfo "for information about running bacula as a non-root user."
+ einfo
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # adjusts default configuration files for several binaries
+ # to /etc/bacula/<config> instead of ./<config>
+ pushd src && epatch "${FILESDIR}/${P}"-default-configs.patch && popd
+
+ # replaces (deprecated) gnomesu with gksu in the gnome menu files
+ useq bacula-console && useq gnome && epatch "${FILESDIR}/${P}"-gnomesu2gksu.diff
+}
+
+src_compile() {
+ local myconf=''
+
+ if useq bacula-clientonly; then
+ myconf="${myconf} \
+ $(use_enable bacula-clientonly client-only) \
+ $(use_enable static static-fd)"
+ else
+ myconf="${myconf} \
+ --with-${mydbtype} \
+ $(use_enable static static-tools) \
+ $(use_enable static static-fd) \
+ $(use_enable !bacula-nodir build-dird) \
+ $(use_enable !bacula-nosd build-stored)"
+ if ! useq bacula-nodir; then
+ myconf="${myconf} $(use_enable static static-dir)"
+ fi
+ if ! useq bacula-nosd; then
+ myconf="${myconf} $(use_enable static static-sd)"
+ fi
+
+ fi
+
+ if useq bacula-console; then
+ myconf="${myconf} \
+ $(use_with X x) \
+ $(use_enable gnome) \
+ $(use_enable gnome tray-monitor) \
+ $(use_enable wxwindows wx-console) \
+ $(use_enable static static-cons)"
+ fi
+
+ myconf="${myconf} \
+ $(use_with python) \
+ $(use_with readline) \
+ $(use_with ssl openssl) \
+ $(use_with tcpd tcp-wrappers)"
+
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --with-pid-dir=/var/run \
+ --sysconfdir=/etc/bacula \
+ --infodir=/usr/share/info \
+ --with-subsys-dir=/var/lock/subsys \
+ --with-working-dir=/var/lib/bacula \
+ --with-scriptdir=/usr/libexec/bacula \
+ --with-dir-user=bacula \
+ --with-dir-group=bacula \
+ --with-sd-user=root \
+ --with-sd-group=bacula \
+ --with-fd-user=root \
+ --with-fd-group=bacula \
+ --enable-smartalloc \
+ --host=${CHOST} \
+ ${myconf} \
+ || die "configure failed"
+
+ emake || die "emake failed"
+
+ # build docs from bacula-docs tarball
+ if useq doc; then
+ pushd "${WORKDIR}/${PN}-docs-${DOC_VER}"
+
+ ./configure \
+ --with-bacula=${S} \
+ || die "configure for bacula-docs failed"
+
+ # the main Makefile tries to build stuff in
+ # ./developer/ and ./bacula-web/, which is
+ # unfortunately broken in 2.0.3, so we only
+ # build stuff in ./manual/, which works.
+ pushd manual
+ emake || die "emake for bacula-docs failed"
+ popd
+
+ popd
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # remove some scripts we don't need at all
+ rm -f "${D}"/usr/libexec/bacula/{bacula,bacula-ctl-dir,bacula-ctl-fd,bacula-ctl-sd,startmysql,stopmysql}
+
+ # rename statically linked apps
+ if useq static; then
+ pushd "${D}"/usr/sbin
+ mv static-bacula-fd bacula-fd
+ mv static-bconsole bconsole
+ if ! useq bacula-clientonly; then
+ mv static-bacula-dir bacula-dir
+ mv static-bacula-sd bacula-sd
+ fi
+ if useq bacula-console && useq gnome; then
+ mv static-gnome-console gnome-console
+ fi
+ popd
+ fi
+
+ # gnome-console menu entries using gksu
+ if useq bacula-console && useq gnome; then
+ emake DESTDIR="${D}" install-menu-xsu \
+ || die "Failed to install gnome menu files"
+ fi
+
+ # extra files which 'make install' doesn't cover
+ if ! useq bacula-clientonly; then
+ # the database update scripts
+ diropts -m0750
+ dodir /usr/libexec/bacula/updatedb
+ insinto /usr/libexec/bacula/updatedb/
+ insopts -m0754
+ doins "${S}"/updatedb/*
+ fperms 0640 /usr/libexec/bacula/updatedb/README
+
+ # the logrotate configuration
+ if useq logrotate; then
+ diropts -m0755
+ dodir /etc/logrotate.d
+ insinto /etc/logrotate.d
+ insopts -m0644
+ newins "${S}"/scripts/logrotate bacula
+ fi
+
+ # the logwatch scripts
+ if useq logwatch; then
+ diropts -m0750
+ dodir /etc/log.d/scripts/services
+ dodir /etc/log.d/conf/logfiles
+ dodir /etc/log.d/conf/services
+ cd "${S}"/scripts/logwatch
+ emake DESTDIR="${D}" install || die "Failed to install logwatch scripts"
+ cd "${S}"
+ fi
+ fi
+
+ # documentation
+ for d in "${S}"/{ChangeLog,LICENSE,README,ReleaseNotes,SUPPORT,kernstodo,projects}; do
+ dodoc "${d}"
+ done
+ # FIXME: developers and bacula-web documentation is broken with 2.0.3 :-(
+ if useq doc; then
+#! dodoc "${WORKDIR}/${PN}-docs-${DOC_VER}"/developers/developers.pdf
+ dodoc "${WORKDIR}/${PN}-docs-${DOC_VER}"/manual/bacula.pdf
+ diropts -m0755
+#! dodir /usr/share/doc/"${PF}"/developers
+ dodir /usr/share/doc/"${PF}"/manual
+ insopts -m0644
+#! insinto /usr/share/doc/"${PF}"/developers
+#! doins "${WORKDIR}/${PN}-docs-${DOC_VER}"/developers/developers/*
+ insinto /usr/share/doc/"${PF}"/manual
+ doins "${WORKDIR}/${PN}-docs-${DOC_VER}"/manual/bacula/*
+ fi
+
+ # setup init scripts
+ myservices="fd"
+ if ! useq bacula-clientonly; then
+ if ! useq bacula-nodir; then
+ myservices="${myservices} dir"
+ fi
+ if ! useq bacula-nosd; then
+ myservices="${myservices} sd"
+ fi
+ fi
+ exeinto /etc/init.d/
+ insinto /etc/conf.d/
+ if useq bacula-split-init; then
+ myscripts=""
+ for service in ${myservices}; do
+ myscripts="${myscripts} bacula-${service}"
+ done
+ else
+ myscripts="bacula-all"
+ fi
+ for script in ${myscripts}; do
+ # copy over init script and config to a temporary location
+ # so we can modify them as needed
+ cp "${FILESDIR}/${PV}/${script}"-conf "${T}/${script}".conf
+ cp "${FILESDIR}/${PV}/${script}"-init "${T}/${script}".init
+ # set database dependancy for the all-in-one and director init scripts
+ case "${mydbtype}" in
+ sqlite*)
+ # sqlite + sqlite3 databases don't have daemons
+ sed -i -e "s:%database%::" "${T}/${script}".init
+ ;;
+ *)
+ # all other databases have daemons
+ sed -i -e "s:%database%:${mydbtype}:" "${T}/${script}".init
+ ;;
+ esac
+ # set services for the all-in-one init script
+ sed -i -e "s:%services%:${myservices}:" "${T}/${script}".conf
+ # install init script and config
+ newexe "${T}/${script}".init "${script}"
+ newins "${T}/${script}".conf "${script}"
+ done
+
+ # make sure the working directory exists
+ diropts -m0750
+ keepdir /var/lib/bacula
+}
+
+pkg_postinst() {
+ if useq bacula-clientonly; then
+ fowners root:bacula /var/lib/bacula
+ else
+ fowners bacula:bacula /var/lib/bacula
+ fi
+
+ if ! useq bacula-clientonly && ! useq bacula-nodir; then
+ einfo
+ einfo "If this is a new install, you must create the ${mydbtype} databases with:"
+ einfo " /usr/libexec/bacula/create_${mydbtype}_database"
+ einfo " /usr/libexec/bacula/make_${mydbtype}_tables"
+ einfo " /usr/libexec/bacula/grant_${mydbtype}_privileges"
+ einfo
+ einfo "If you're upgrading from a major release, you must upgrade your bacula catalog database."
+ einfo "Please read the manual chapter for how to upgrade your database."
+ einfo "You can find database upgrade scripts in /usr/libexec/bacula/updatedb."
+ einfo
+ fi
+}
diff --git a/app-backup/bacula/files/2.0.3/bacula-all-conf b/app-backup/bacula/files/2.0.3/bacula-all-conf
new file mode 100644
index 000000000000..3c0990231381
--- /dev/null
+++ b/app-backup/bacula/files/2.0.3/bacula-all-conf
@@ -0,0 +1,23 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.3/bacula-all-conf,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+# Config file for /etc/init.d/bacula
+
+# Add the daemons you want to run:
+# dir - Director (Master Control Program)
+# fd - File Daemon (Client)
+# sd - Storage Daemon
+SERVICES="%services%"
+
+# If the database server where you store your bacula catalog
+# is on a different machine, please set this to 0.
+LOCAL_DB=1
+
+# Options for each daemon.
+# The DIR and SD can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+SD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-sd.conf"
+FD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-fd.conf"
+DIR_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-dir.conf"
diff --git a/app-backup/bacula/files/2.0.3/bacula-all-init b/app-backup/bacula/files/2.0.3/bacula-all-init
new file mode 100644
index 000000000000..928c4797d70b
--- /dev/null
+++ b/app-backup/bacula/files/2.0.3/bacula-all-init
@@ -0,0 +1,71 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.3/bacula-all-init,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+depend() {
+ need net
+ if [ ${LOCAL_DB} -eq 1 ]; then
+ need "%database%"
+ fi
+ use dns
+}
+
+start() {
+ local retval
+ declare -i retval=0
+ for s in ${SERVICES} ; do
+ case ${s} in
+ sd)
+ ebegin "Starting bacula storage daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+ -- ${SD_OPTIONS}
+ let retval+=$?
+ ;;
+ fd)
+ ebegin "Starting bacula file daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+ -- ${FD_OPTIONS}
+ let retval+=$?
+ ;;
+ dir)
+ ebegin "Starting bacula director"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+ -- ${DIR_OPTIONS}
+ let retval+=$?
+ ;;
+ *)
+ eerror "Unrecognized service found in SERVICES: '${s}'"
+ ;;
+ esac
+ done
+ eend ${retval}
+}
+
+stop() {
+ local retval
+ declare -i retval=0
+ for s in ${SERVICES} ; do
+ case ${s} in
+ sd)
+ ebegin "Stopping bacula storage daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.*.pid
+ let retval+=$?
+ ;;
+ fd)
+ ebegin "Stopping bacula file daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.*.pid
+ let retval+=$?
+ ;;
+ dir)
+ ebegin "Stopping bacula director"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.*.pid
+ let retval+=$?
+ ;;
+ *)
+ eerror "Unrecognized service found in SERVICES: '${s}'"
+ ;;
+ esac
+ done
+ eend ${retval}
+}
diff --git a/app-backup/bacula/files/2.0.3/bacula-dir-conf b/app-backup/bacula/files/2.0.3/bacula-dir-conf
new file mode 100644
index 000000000000..dac064524092
--- /dev/null
+++ b/app-backup/bacula/files/2.0.3/bacula-dir-conf
@@ -0,0 +1,15 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.3/bacula-dir-conf,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-dir
+
+# If the database server where you store your bacula catalog
+# is on a different machine, please set this to 0.
+LOCAL_DB=1
+
+# Options for the director daemon.
+# The DIR can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+DIR_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-dir.conf"
diff --git a/app-backup/bacula/files/2.0.3/bacula-dir-init b/app-backup/bacula/files/2.0.3/bacula-dir-init
new file mode 100644
index 000000000000..098b6923ebcc
--- /dev/null
+++ b/app-backup/bacula/files/2.0.3/bacula-dir-init
@@ -0,0 +1,25 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.3/bacula-dir-init,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+depend() {
+ need net
+ if [ ${LOCAL_DB} -eq 1 ]; then
+ need "%database%"
+ fi
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula director"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-dir \
+ -- ${DIR_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula director"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-dir.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/2.0.3/bacula-fd-conf b/app-backup/bacula/files/2.0.3/bacula-fd-conf
new file mode 100644
index 000000000000..cd441d9d7f9e
--- /dev/null
+++ b/app-backup/bacula/files/2.0.3/bacula-fd-conf
@@ -0,0 +1,8 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.3/bacula-fd-conf,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-fd
+
+# Options for the file director.
+FD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-fd.conf"
diff --git a/app-backup/bacula/files/2.0.3/bacula-fd-init b/app-backup/bacula/files/2.0.3/bacula-fd-init
new file mode 100644
index 000000000000..ec3614ed6c0a
--- /dev/null
+++ b/app-backup/bacula/files/2.0.3/bacula-fd-init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.3/bacula-fd-init,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula file daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-fd \
+ -- ${FD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula file daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-fd.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/2.0.3/bacula-sd-conf b/app-backup/bacula/files/2.0.3/bacula-sd-conf
new file mode 100644
index 000000000000..c1afc894d33f
--- /dev/null
+++ b/app-backup/bacula/files/2.0.3/bacula-sd-conf
@@ -0,0 +1,11 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.3/bacula-sd-conf,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+# Config file for /etc/init.d/bacula-sd
+
+# Options for the storage daemon.
+# The SD can be run as a non-root user, however
+# please ensure that this user has proper permissions to
+# access your backup devices.
+SD_OPTIONS="-u root -g bacula -c /etc/bacula/bacula-sd.conf"
diff --git a/app-backup/bacula/files/2.0.3/bacula-sd-init b/app-backup/bacula/files/2.0.3/bacula-sd-init
new file mode 100644
index 000000000000..567c7d2cb884
--- /dev/null
+++ b/app-backup/bacula/files/2.0.3/bacula-sd-init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/files/2.0.3/bacula-sd-init,v 1.1 2007/03/10 21:41:31 wschlich Exp $
+
+depend() {
+ need net
+ use dns
+}
+
+start() {
+ ebegin "Starting bacula storage daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/bacula-sd \
+ -- ${SD_OPTIONS}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping bacula storage daemon"
+ start-stop-daemon --stop --quiet --pidfile /var/run/bacula-sd.*.pid
+ eend $?
+}
diff --git a/app-backup/bacula/files/bacula-2.0.3-default-configs.patch b/app-backup/bacula/files/bacula-2.0.3-default-configs.patch
new file mode 100644
index 000000000000..9f699b8cb595
--- /dev/null
+++ b/app-backup/bacula/files/bacula-2.0.3-default-configs.patch
@@ -0,0 +1,110 @@
+--- stored/bcopy.c 2006-11-27 05:03:01.000000000 -0500
++++ stored/bcopy.c 2007-01-11 21:14:58.883253250 -0500
+@@ -57,7 +57,7 @@
+ static uint32_t jobs = 0;
+ static DEV_BLOCK *out_block;
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false; /* proceed inspite of I/O errors */
+--- stored/bextract.c 2006-12-01 03:45:13.000000000 -0500
++++ stored/bextract.c 2007-01-11 21:13:33.333906750 -0500
+@@ -64,7 +64,7 @@
+ static uint32_t wsize; /* write size */
+ static uint64_t fileAddr = 0; /* file write address */
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false;
+--- stored/bls.c 2006-12-13 14:42:12.000000000 -0500
++++ stored/bls.c 2007-01-11 21:13:47.850814000 -0500
+@@ -59,7 +59,7 @@
+ static uint32_t num_files = 0;
+ static ATTR *attr;
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false;
+--- stored/bscan.c 2006-12-01 03:45:13.000000000 -0500
++++ stored/bscan.c 2007-01-11 21:14:05.375909250 -0500
+@@ -100,7 +100,7 @@
+ static int num_media = 0;
+ static int num_files = 0;
+
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+ STORES *me = NULL; /* our Global resource */
+ bool forge_on = false; /* proceed inspite of I/O errors */
+--- stored/btape.c 2006-12-14 06:41:00.000000000 -0500
++++ stored/btape.c 2007-01-11 21:14:29.265402250 -0500
+@@ -98,7 +98,7 @@
+
+
+ /* Static variables */
+-#define CONFIG_FILE "bacula-sd.conf"
++#define CONFIG_FILE "/etc/bacula/bacula-sd.conf"
+ char *configfile = NULL;
+
+ #define MAX_CMD_ARGS 30
+--- tray-monitor/tray-monitor.c 2006-12-01 03:45:14.000000000 -0500
++++ tray-monitor/tray-monitor.c 2007-01-11 21:17:29.828686750 -0500
+@@ -101,7 +101,7 @@
+ char** xpm_generic_var;
+ static gboolean blinkstate = TRUE;
+
+-#define CONFIG_FILE "./tray-monitor.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/tray-monitor.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- dird/dird.c 2006-12-22 10:01:05.000000000 -0500
++++ dird/dird.c 2007-01-11 21:18:16.255588250 -0500
+@@ -83,7 +83,7 @@
+ extern URES res_all;
+ #endif
+
+-#define CONFIG_FILE "bacula-dir.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/bacula-dir.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- console/console.c 2006-11-27 05:02:59.000000000 -0500
++++ console/console.c 2007-01-11 21:18:36.580858500 -0500
+@@ -104,7 +104,7 @@
+ static int sleepcmd(FILE *input, BSOCK *UA_sock);
+
+
+-#define CONFIG_FILE "bconsole.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/bconsole.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- gnome2-console/console.c 2006-12-08 09:27:10.000000000 -0500
++++ gnome2-console/console.c 2007-01-11 21:19:17.287402500 -0500
+@@ -93,7 +93,7 @@
+ static guint initial;
+ static int numdir = 0;
+
+-#define CONFIG_FILE "./gnome-console.conf" /* default configuration file */
++#define CONFIG_FILE "/etc/bacula/gnome-console.conf" /* default configuration file */
+
+ static void usage()
+ {
+--- filed/filed.c 2006-11-27 05:03:00.000000000 -0500
++++ filed/filed.c 2007-01-11 21:20:13.722929500 -0500
+@@ -49,7 +49,7 @@
+ bool no_signals = false;
+
+
+-#define CONFIG_FILE "bacula-fd.conf" /* default config file */
++#define CONFIG_FILE "/etc/bacula/bacula-fd.conf" /* default config file */
+
+ char *configfile = NULL;
+ static bool foreground = false;
diff --git a/app-backup/bacula/files/bacula-2.0.3-gnomesu2gksu.diff b/app-backup/bacula/files/bacula-2.0.3-gnomesu2gksu.diff
new file mode 100644
index 000000000000..015ad5940eaf
--- /dev/null
+++ b/app-backup/bacula/files/bacula-2.0.3-gnomesu2gksu.diff
@@ -0,0 +1,36 @@
+diff -urN scripts/bacula.desktop.gnome1.xsu.in scripts/bacula.desktop.gnome1.xsu.in
+--- scripts/bacula.desktop.gnome1.xsu.in 2004-03-28 19:08:45.000000000 +0200
++++ scripts/bacula.desktop.gnome1.xsu.in 2007-02-28 16:36:14.000000000 +0100
+@@ -2,7 +2,7 @@
+ Name=Bacula Console
+ Comment=Bacula Director Console
+ Icon=/usr/share/pixmaps/bacula.png
+-Exec=gnomesu -t "Query" -c "@sbindir@/gnome-console -c @sysconfdir@/gnome-console.conf" -d -e -m "In order to run the bacula console as root, ^additional information is required."
++Exec=gksu -u root -m 'Bacula Console needs to be run with superuser privileges' "@sbindir@/gnome-console -c @sysconfdir@/gnome-console.conf"
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
+diff -urN scripts/bacula.desktop.gnome2.xsu.in scripts/bacula.desktop.gnome2.xsu.in
+--- scripts/bacula.desktop.gnome2.xsu.in 2004-03-28 19:08:45.000000000 +0200
++++ scripts/bacula.desktop.gnome2.xsu.in 2007-02-28 16:36:25.000000000 +0100
+@@ -2,7 +2,7 @@
+ Name=Bacula Console
+ Comment=Bacula Director Console
+ Icon=/usr/share/pixmaps/bacula.png
+-Exec=gnomesu -t "Query" -c "@sbindir@/gnome-console -c @sysconfdir@/gnome-console.conf" -d -e -m "In order to run the bacula console as root, ^additional information is required."
++Exec=gksu -u root -m 'Bacula Console needs to be run with superuser privileges' "@sbindir@/gnome-console -c @sysconfdir@/gnome-console.conf"
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
+diff -urN scripts/wxconsole.desktop.xsu.in scripts/wxconsole.desktop.xsu.in
+--- scripts/wxconsole.desktop.xsu.in 2006-04-16 18:01:52.000000000 +0200
++++ scripts/wxconsole.desktop.xsu.in 2007-02-28 16:35:25.000000000 +0100
+@@ -2,7 +2,7 @@
+ Name=Bacula WX Console
+ Comment=Bacula Director Console
+ Icon=/usr/share/pixmaps/wxwin16x16.xpm
+-Exec=gnomesu -t "Query" -c "@sbindir@/wxconsole -c @sysconfdir@/wxconsole.conf" -d -e -m "In order to run the bacula wx console as root, ^additional information is required."
++Exec=gksu -u root -m 'Bacula Console needs to be run with superuser privileges' "@sbindir@/wxconsole -c @sysconfdir@/wxconsole.conf"
+ Terminal=false
+ Type=Application
+ Encoding=UTF-8
diff --git a/app-backup/bacula/files/digest-bacula-2.0.3 b/app-backup/bacula/files/digest-bacula-2.0.3
new file mode 100644
index 000000000000..071d57c11abe
--- /dev/null
+++ b/app-backup/bacula/files/digest-bacula-2.0.3
@@ -0,0 +1,6 @@
+MD5 443d2560ace95173a0d8ba465de493ef bacula-2.0.3.tar.gz 2527956
+RMD160 f632885b052f188d2b986c098167009353f32bb3 bacula-2.0.3.tar.gz 2527956
+SHA256 519336560be6e92c004975a5a61c2c438eac50e38d9ab699b215ba269720c2de bacula-2.0.3.tar.gz 2527956
+MD5 dce3aed621b9e4abee51cc89aebf4a58 bacula-docs-2.0.3.tar.gz 16601744
+RMD160 ba2492ea8e5e85234a5e02fc0f4b5ba70997ad43 bacula-docs-2.0.3.tar.gz 16601744
+SHA256 39e763b0860b73b20336d765e9496c08fc7e5940d3a9dc123cb929e45af66614 bacula-docs-2.0.3.tar.gz 16601744
diff --git a/app-backup/bacula/metadata.xml b/app-backup/bacula/metadata.xml
index e7f283ad6978..592e50bc9e38 100644
--- a/app-backup/bacula/metadata.xml
+++ b/app-backup/bacula/metadata.xml
@@ -2,4 +2,9 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>app-backup</herd>
+ <maintainer>
+ <email>wschlich@gentoo.org</email>
+ <name>Wolfram Schlich</name>
+ <description>Maintainer of 2.0 branch only</description>
+ </maintainer>
</pkgmetadata>