summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-01-04 03:31:48 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-01-04 03:31:48 +0000
commitc7c4f0f69f1f74071025cbf05e5aab01a7d6ec1a (patch)
tree521ae146fda24b982de4b46074e92ffb2f4832f1 /app-backup
parentBump to prerelease. (diff)
downloadgentoo-2-c7c4f0f69f1f74071025cbf05e5aab01a7d6ec1a.tar.gz
gentoo-2-c7c4f0f69f1f74071025cbf05e5aab01a7d6ec1a.tar.bz2
gentoo-2-c7c4f0f69f1f74071025cbf05e5aab01a7d6ec1a.zip
Version bump, bug #449356
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/spideroak-bin/ChangeLog10
-rw-r--r--app-backup/spideroak-bin/files/spideroak-bin-4.8.3-headless.patch8
-rw-r--r--app-backup/spideroak-bin/spideroak-bin-4.8.3.ebuild99
3 files changed, 115 insertions, 2 deletions
diff --git a/app-backup/spideroak-bin/ChangeLog b/app-backup/spideroak-bin/ChangeLog
index 04c136d928da..74f64d1e81f3 100644
--- a/app-backup/spideroak-bin/ChangeLog
+++ b/app-backup/spideroak-bin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/spideroak-bin
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/spideroak-bin/ChangeLog,v 1.28 2012/10/11 14:27:27 zmedico Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/spideroak-bin/ChangeLog,v 1.29 2013/01/04 03:31:48 blueness Exp $
+
+*spideroak-bin-4.8.3 (04 Jan 2013)
+
+ 04 Jan 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/spideroak-bin-4.8.3-headless.patch, +spideroak-bin-4.8.3.ebuild:
+ Version bump, bug #449356
11 Oct 2012; Zac Medico <zmedico@gentoo.org> spideroak-bin-4.7.9948.ebuild:
Use patchelf --set-rpath so that library dependencies can be properly tracked
diff --git a/app-backup/spideroak-bin/files/spideroak-bin-4.8.3-headless.patch b/app-backup/spideroak-bin/files/spideroak-bin-4.8.3-headless.patch
new file mode 100644
index 000000000000..eef9085a8c59
--- /dev/null
+++ b/app-backup/spideroak-bin/files/spideroak-bin-4.8.3-headless.patch
@@ -0,0 +1,8 @@
+--- usr/bin/SpiderOak.orig 2012-08-26 08:10:42.387011624 +0200
++++ usr/bin/SpiderOak 2012-08-26 08:10:48.899956298 +0200
+@@ -5,4 +5,4 @@
+ QT_PLUGIN_PATH= ; export QT_PLUGIN_PATH
+ SpiderOak_EXEC_SCRIPT=$(cd `dirname $0` ; pwd)/SpiderOak
+ export SpiderOak_EXEC_SCRIPT
+-exec "/opt/SpiderOak/lib/SpiderOak" "$@"
++exec "/opt/SpiderOak/lib/SpiderOak" --headless "$@"
diff --git a/app-backup/spideroak-bin/spideroak-bin-4.8.3.ebuild b/app-backup/spideroak-bin/spideroak-bin-4.8.3.ebuild
new file mode 100644
index 000000000000..d8037d5eecfe
--- /dev/null
+++ b/app-backup/spideroak-bin/spideroak-bin-4.8.3.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/spideroak-bin/spideroak-bin-4.8.3.ebuild,v 1.1 2013/01/04 03:31:48 blueness Exp $
+
+EAPI="4"
+
+inherit eutils
+
+SRC_URI_BASE="https://spideroak.com/getbuild?platform=ubuntu"
+
+DESCRIPTION="An easy, secure and consolidated free online backup, storage, access and sharing system."
+HOMEPAGE="https://spideroak.com"
+SRC_URI="x86? ( ${SRC_URI_BASE}&arch=i386&version=${PV} -> ${P}_x86.deb )
+ amd64? ( ${SRC_URI_BASE}&arch=x86_64&version=${PV} -> ${P}_amd64.deb )"
+RESTRICT="mirror strip"
+
+LICENSE="spideroak"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus headless"
+
+DEPEND="dev-util/patchelf"
+RDEPEND="
+ app-crypt/mit-krb5[keyutils]
+ dbus? ( sys-apps/dbus )
+ !headless? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ dev-libs/glib:2
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ )
+"
+
+S=${WORKDIR}
+
+QA_PREBUILT="*"
+
+src_unpack() {
+ unpack ${A}
+ unpack ./data.tar.gz
+ rm -f control.tar.gz data.tar.gz debian-binary
+ rm -f usr/share/doc/spideroak/copyright
+}
+
+src_prepare() {
+ use headless && epatch "${FILESDIR}"/${PF}-headless.patch
+
+ # Set RPATH for preserve-libs handling (bug #400979).
+ cd "${S}/opt/SpiderOak/lib" || die
+ local x
+ for x in `find` ; do
+ # Use \x7fELF header to separate ELF executables and libraries
+ [[ -f ${x} && $(od -t x1 -N 4 "${x}") == *"7f 45 4c 46"* ]] || continue
+ patchelf --set-rpath '$ORIGIN' "${x}" || \
+ die "patchelf failed on ${x}"
+ done
+}
+
+src_install() {
+ #install the wrapper script
+ exeinto /usr/bin
+ doexe usr/bin/SpiderOak
+
+ #install the executable
+ exeinto /opt/SpiderOak/lib
+ doexe opt/SpiderOak/lib/SpiderOak
+ rm -f opt/SpiderOak/lib/SpiderOak
+
+ #install the prebundled libraries
+ insinto /opt/SpiderOak
+ doins -r opt/SpiderOak/lib
+
+ #install the config files
+ use dbus || rm -rf etc/dbus-1
+ insinto /
+ doins -r etc
+
+ #install the manpage
+ doman usr/share/man/man1/SpiderOak.1.gz
+
+ if ! use headless ; then
+ domenu usr/share/applications/spideroak.desktop
+ doicon usr/share/pixmaps/SpiderOak.png
+ fi
+}
+
+pkg_postinst() {
+ if use headless; then
+ einfo "For instructions on running SpiderOak without a GUI, please read the FAQ:"
+ einfo " https://spideroak.com/faq/questions/62/how_do_i_install_spideroak_on_a_headless_linux_server/"
+ einfo " https://spideroak.com/faq/questions/67/how_can_i_use_spideroak_from_the_commandline/"
+ fi
+}