summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2011-11-16 07:54:09 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2011-11-16 07:54:09 +0000
commitb366ae5a62aba4366201b6a907ab525d20bb3961 (patch)
treebba1a19a78d9b6e53637712ba8dfabdb1058ba39 /app-backup
parentAdd Fedora's automatic crash reporter tool from the gnome overlay. (diff)
downloadgentoo-2-b366ae5a62aba4366201b6a907ab525d20bb3961.tar.gz
gentoo-2-b366ae5a62aba4366201b6a907ab525d20bb3961.tar.bz2
gentoo-2-b366ae5a62aba4366201b6a907ab525d20bb3961.zip
Disallow automagic testing of IPv6 working test when IPv6 build is requested. Otherwise breaks the configure when building USE=ipv6 on a buildhost without an IPv6 kernel.
(Portage version: 2.2.0_alpha74/cvs/Linux x86_64)
Diffstat (limited to 'app-backup')
-rw-r--r--app-backup/amanda/ChangeLog8
-rw-r--r--app-backup/amanda/amanda-2.6.1_p2.ebuild7
-rw-r--r--app-backup/amanda/amanda-3.2.1.ebuild5
-rw-r--r--app-backup/amanda/amanda-3.2.2.ebuild7
-rw-r--r--app-backup/amanda/amanda-3.3.0.ebuild5
5 files changed, 25 insertions, 7 deletions
diff --git a/app-backup/amanda/ChangeLog b/app-backup/amanda/ChangeLog
index 153220a209c8..d8a3afa33f31 100644
--- a/app-backup/amanda/ChangeLog
+++ b/app-backup/amanda/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-backup/amanda
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/ChangeLog,v 1.84 2011/10/13 15:02:29 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/ChangeLog,v 1.85 2011/11/16 07:54:09 robbat2 Exp $
+
+ 16 Nov 2011; Robin H. Johnson <robbat2@gentoo.org> amanda-2.6.1_p2.ebuild,
+ amanda-3.2.1.ebuild, amanda-3.2.2.ebuild, amanda-3.3.0.ebuild:
+ Disallow automagic testing of IPv6 working test when IPv6 build is requested.
+ Otherwise breaks the configure when building USE=ipv6 on a buildhost without
+ an IPv6 kernel.
*amanda-3.3.0 (13 Oct 2011)
diff --git a/app-backup/amanda/amanda-2.6.1_p2.ebuild b/app-backup/amanda/amanda-2.6.1_p2.ebuild
index ff682facf9bd..57e3919a3e5d 100644
--- a/app-backup/amanda/amanda-2.6.1_p2.ebuild
+++ b/app-backup/amanda/amanda-2.6.1_p2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-2.6.1_p2.ebuild,v 1.5 2010/09/10 21:41:01 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-2.6.1_p2.ebuild,v 1.6 2011/11/16 07:54:09 robbat2 Exp $
inherit autotools eutils
@@ -237,6 +237,9 @@ src_compile() {
# IPv6 fun.
myconf="${myconf} `use_with ipv6`"
+ # This is to prevent the IPv6-is-working test
+ # As the test fails on binpkg build hosts with no IPv6.
+ use ipv6 && export amanda_cv_working_ipv6=yes
# I18N
myconf="${myconf} `use_enable nls`"
diff --git a/app-backup/amanda/amanda-3.2.1.ebuild b/app-backup/amanda/amanda-3.2.1.ebuild
index 0a17909b26b3..dd7bc9186b65 100644
--- a/app-backup/amanda/amanda-3.2.1.ebuild
+++ b/app-backup/amanda/amanda-3.2.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-3.2.1.ebuild,v 1.9 2011/07/13 13:15:14 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-3.2.1.ebuild,v 1.10 2011/11/16 07:54:09 robbat2 Exp $
EAPI=3
inherit autotools eutils perl-module
@@ -268,6 +268,9 @@ src_configure() {
# IPv6 fun.
myconf="${myconf} `use_with ipv6`"
+ # This is to prevent the IPv6-is-working test
+ # As the test fails on binpkg build hosts with no IPv6.
+ use ipv6 && export amanda_cv_working_ipv6=yes
# I18N
myconf="${myconf} `use_enable nls`"
diff --git a/app-backup/amanda/amanda-3.2.2.ebuild b/app-backup/amanda/amanda-3.2.2.ebuild
index 209c245bf332..1c28698c6202 100644
--- a/app-backup/amanda/amanda-3.2.2.ebuild
+++ b/app-backup/amanda/amanda-3.2.2.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-3.2.2.ebuild,v 1.1 2011/03/17 20:52:36 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-3.2.2.ebuild,v 1.2 2011/11/16 07:54:09 robbat2 Exp $
EAPI=3
inherit autotools eutils perl-module
@@ -268,6 +268,9 @@ src_configure() {
# IPv6 fun.
myconf="${myconf} `use_with ipv6`"
+ # This is to prevent the IPv6-is-working test
+ # As the test fails on binpkg build hosts with no IPv6.
+ use ipv6 && export amanda_cv_working_ipv6=yes
# I18N
myconf="${myconf} `use_enable nls`"
diff --git a/app-backup/amanda/amanda-3.3.0.ebuild b/app-backup/amanda/amanda-3.3.0.ebuild
index be7b360a7f6c..084f94a0623b 100644
--- a/app-backup/amanda/amanda-3.3.0.ebuild
+++ b/app-backup/amanda/amanda-3.3.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-3.3.0.ebuild,v 1.1 2011/10/13 15:02:29 idl0r Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/amanda/amanda-3.3.0.ebuild,v 1.2 2011/11/16 07:54:09 robbat2 Exp $
EAPI=3
inherit autotools eutils perl-module
@@ -269,6 +269,9 @@ src_configure() {
# IPv6 fun.
myconf="${myconf} `use_with ipv6`"
+ # This is to prevent the IPv6-is-working test
+ # As the test fails on binpkg build hosts with no IPv6.
+ use ipv6 && export amanda_cv_working_ipv6=yes
# I18N
myconf="${myconf} `use_enable nls`"