summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2008-03-07 17:00:15 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2008-03-07 17:00:15 +0000
commit6f9420df1868016d2ebc177d8bbfe55f08791f79 (patch)
tree4d8b4b87e61ca0aa726512bdfe3b0f99fddbe2f1 /app-backup/dar
parentQA cleanup: Shorten DESCRIPTION. (diff)
downloadgentoo-2-6f9420df1868016d2ebc177d8bbfe55f08791f79.tar.gz
gentoo-2-6f9420df1868016d2ebc177d8bbfe55f08791f79.tar.bz2
gentoo-2-6f9420df1868016d2ebc177d8bbfe55f08791f79.zip
bumb
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-backup/dar')
-rw-r--r--app-backup/dar/ChangeLog9
-rw-r--r--app-backup/dar/dar-2.3.7.ebuild61
2 files changed, 68 insertions, 2 deletions
diff --git a/app-backup/dar/ChangeLog b/app-backup/dar/ChangeLog
index 6e20c6301d19..911e0f3c355e 100644
--- a/app-backup/dar/ChangeLog
+++ b/app-backup/dar/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-backup/dar
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.27 2007/10/15 16:25:42 matsuu Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/ChangeLog,v 1.28 2008/03/07 17:00:15 matsuu Exp $
+
+*dar-2.3.7 (07 Mar 2008)
+
+ 07 Mar 2008; MATSUU Takuto <matsuu@gentoo.org> +dar-2.3.7.ebuild:
+ Version bumped.
*dar-2.3.6 (15 Oct 2007)
diff --git a/app-backup/dar/dar-2.3.7.ebuild b/app-backup/dar/dar-2.3.7.ebuild
new file mode 100644
index 000000000000..8dcd013c4746
--- /dev/null
+++ b/app-backup/dar/dar-2.3.7.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-backup/dar/dar-2.3.7.ebuild,v 1.1 2008/03/07 17:00:15 matsuu Exp $
+
+inherit flag-o-matic
+
+DESCRIPTION="A full featured backup tool, aimed for disks (floppy,CDR(W),DVDR(W),zip,jazz etc.)"
+HOMEPAGE="http://dar.linux.free.fr/"
+SRC_URI="mirror://sourceforge/dar/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="acl dar32 dar64 doc nls ssl"
+
+DEPEND=">=sys-libs/zlib-1.2.3
+ >=app-arch/bzip2-1.0.2
+ acl? ( sys-apps/attr )
+ doc? ( app-doc/doxygen )
+ nls? ( sys-devel/gettext )
+ ssl? ( dev-libs/openssl )"
+
+pkg_setup() {
+ if use dar32 && use dar64 ; then
+ eerror "dar32 and dar64 cannot be enabled together."
+ eerror "Please remove one of them and try the emerge again."
+ die "Please remove dar32 or dar64."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i -e '/^dist_noinst_DATA/s/$/ macro_tools.hpp/' \
+ -e '/^noinst_HEADERS/s/macro_tools.hpp//' \
+ src/libdar/Makefile* || die
+}
+
+src_compile() {
+ local myconf="--disable-upx"
+
+ # Bug 103741
+ filter-flags -fomit-frame-pointer
+
+ use acl || myconf="${myconf} --disable-ea-support"
+ use dar32 && myconf="${myconf} --enable-mode=32"
+ use dar64 && myconf="${myconf} --enable-mode=64"
+ use doc || myconf="${myconf} --disable-build-html"
+ # use examples && myconf="${myconf} --enable-examples"
+ use nls || myconf="${myconf} --disable-nls"
+ use ssl || myconf="${myconf} --disable-libcrypto-linking"
+
+ econf ${myconf} || die
+ emake || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" pkgdatadir=/usr/share/doc/${PF}/html install || die
+
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}