summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWolfram Schlich <wschlich@gentoo.org>2010-05-14 08:07:52 +0000
committerWolfram Schlich <wschlich@gentoo.org>2010-05-14 08:07:52 +0000
commit47c0eb0a7cc52af0711cf4d81d5687c40942de50 (patch)
tree6fe71220029651e8253746e44ef42bbc49daa535 /app-backup/bacula
parentVersion bump. (diff)
downloadgentoo-2-47c0eb0a7cc52af0711cf4d81d5687c40942de50.tar.gz
gentoo-2-47c0eb0a7cc52af0711cf4d81d5687c40942de50.tar.bz2
gentoo-2-47c0eb0a7cc52af0711cf4d81d5687c40942de50.zip
fix bug #311099
(Portage version: 2.2_rc60/cvs/Linux i686)
Diffstat (limited to 'app-backup/bacula')
-rw-r--r--app-backup/bacula/ChangeLog5
-rw-r--r--app-backup/bacula/bacula-5.0.2.ebuild26
2 files changed, 17 insertions, 14 deletions
diff --git a/app-backup/bacula/ChangeLog b/app-backup/bacula/ChangeLog
index cc20d7a432b6..8d879cd24efd 100644
--- a/app-backup/bacula/ChangeLog
+++ b/app-backup/bacula/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-backup/bacula
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.84 2010/05/12 13:31:23 tomjbe Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/ChangeLog,v 1.85 2010/05/14 08:07:52 wschlich Exp $
+
+ 14 May 2010; Wolfram Schlich <wschlich@gentoo.org> bacula-5.0.2.ebuild:
+ fix bug #311099
12 May 2010; Thomas Beierlein <tomjbe@gentoo.org>
+files/5.0.1/bacula-5.0.1-lib-search-path.patch:
diff --git a/app-backup/bacula/bacula-5.0.2.ebuild b/app-backup/bacula/bacula-5.0.2.ebuild
index 3cf8f5aadaee..3bcbd8eff8e0 100644
--- a/app-backup/bacula/bacula-5.0.2.ebuild
+++ b/app-backup/bacula/bacula-5.0.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.0.2.ebuild,v 1.1 2010/05/11 06:50:19 wschlich Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-backup/bacula/bacula-5.0.2.ebuild,v 1.2 2010/05/14 08:07:52 wschlich Exp $
EAPI="2"
inherit eutils multilib
@@ -33,12 +33,10 @@ DEPEND="
>=sys-libs/zlib-1.1.4
dev-libs/gmp
!bacula-clientonly? (
- !bacula-nodir? (
- postgres? ( >=virtual/postgresql-server-7.4 )
- mysql? ( virtual/mysql )
- sqlite3? ( dev-db/sqlite:3 )
- virtual/mta
- )
+ postgres? ( >=virtual/postgresql-server-7.4 )
+ mysql? ( virtual/mysql )
+ sqlite3? ( dev-db/sqlite:3 )
+ !bacula-nodir? ( virtual/mta )
)
qt4? (
x11-libs/qt-svg:4
@@ -64,8 +62,7 @@ RDEPEND="${DEPEND}
)"
pkg_setup() {
- local dbnum
- declare -i dbnum=0
+ local -i dbnum=0
if ! use bacula-clientonly; then
if use mysql; then
export mydbtype=mysql
@@ -148,11 +145,14 @@ src_configure() {
$(use_enable static static-fd) \
$(use_enable !bacula-nodir build-dird) \
$(use_enable !bacula-nosd build-stored)"
+ # bug #311099
+ # database support needed by dir-only *and* sd-only
+ # build as well (for building bscan, btape, etc.)
+ myconf="${myconf} \
+ --with-${mydbtype} \
+ --enable-batch-insert"
if ! use bacula-nodir; then
- myconf="${myconf} \
- --with-${mydbtype} \
- --enable-batch-insert \
- $(use_enable static static-dir)"
+ myconf="${myconf} $(use_enable static static-dir)"
fi
if ! use bacula-nosd; then
myconf="${myconf} $(use_enable static static-sd)"