summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Harring <ferringb@gentoo.org>2010-12-31 09:18:02 +0000
committerBrian Harring <ferringb@gentoo.org>2010-12-31 09:18:02 +0000
commitbdccac4be6ca6f924efac70743697cbaad4e8c39 (patch)
tree91b5c7980e1a5c48460df01c487fe429f936ee02 /app-arch
parentVersion bump. (diff)
downloadgentoo-2-bdccac4be6ca6f924efac70743697cbaad4e8c39.tar.gz
gentoo-2-bdccac4be6ca6f924efac70743697cbaad4e8c39.tar.bz2
gentoo-2-bdccac4be6ca6f924efac70743697cbaad4e8c39.zip
fix false positives against xz-5 (bug 343829), remove 2.8.0 since the tests can fail for the fuzzer (fixed in later versions)
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/libarchive/ChangeLog8
-rw-r--r--app-arch/libarchive/files/libarchive-disable-lzma-size-test.patch47
-rw-r--r--app-arch/libarchive/libarchive-2.7.1-r1.ebuild3
-rw-r--r--app-arch/libarchive/libarchive-2.8.0.ebuild90
-rw-r--r--app-arch/libarchive/libarchive-2.8.3.ebuild3
-rw-r--r--app-arch/libarchive/libarchive-2.8.4.ebuild3
6 files changed, 60 insertions, 94 deletions
diff --git a/app-arch/libarchive/ChangeLog b/app-arch/libarchive/ChangeLog
index 67868035366d..5111187ee0a7 100644
--- a/app-arch/libarchive/ChangeLog
+++ b/app-arch/libarchive/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/libarchive
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.84 2010/12/18 01:42:13 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/ChangeLog,v 1.85 2010/12/31 09:18:01 ferringb Exp $
+
+ 31 Dec 2010; Brian Harring <ferringb@gentoo.org> libarchive-2.7.1-r1.ebuild,
+ -libarchive-2.8.0.ebuild, libarchive-2.8.3.ebuild, libarchive-2.8.4.ebuild,
+ +files/libarchive-disable-lzma-size-test.patch:
+ Disable false-positive test failure against xz-5 (bug #343829), remove 2.8.0
+ since there are a few bugs the fuzz tester spots in that version.
18 Dec 2010; Mart Raudsepp <leio@gentoo.org> libarchive-2.8.4.ebuild:
Add ~mips keyword - required by new cmake-2.8.3
diff --git a/app-arch/libarchive/files/libarchive-disable-lzma-size-test.patch b/app-arch/libarchive/files/libarchive-disable-lzma-size-test.patch
new file mode 100644
index 000000000000..4929685a2eb7
--- /dev/null
+++ b/app-arch/libarchive/files/libarchive-disable-lzma-size-test.patch
@@ -0,0 +1,47 @@
+Index: libarchive/test/test_write_compress_lzma.c
+===================================================================
+--- libarchive/test/test_write_compress_lzma.c (revision 2811)
++++ libarchive/test/test_write_compress_lzma.c (revision 2812)
+@@ -185,10 +185,15 @@
+ archive_write_close(a);
+ assert(0 == archive_write_finish(a));
+
+- /* Level 0 really does result in larger data. */
++ /* It would be nice to assert that compression-level=0 produced
++ * consistently larger/smaller results than the default compression,
++ * but the results here vary a lot depending on the version of liblzma
++ * being used. */
++ /*
+ failure("Compression-level=0 wrote %d bytes; default wrote %d bytes",
+ (int)used2, (int)used1);
+ assert(used2 > used1);
++ */
+
+ assert((a = archive_read_new()) != NULL);
+ assertA(0 == archive_read_support_format_all(a));
+Index: libarchive/test/test_write_compress_xz.c
+===================================================================
+--- libarchive/test/test_write_compress_xz.c (revision 2811)
++++ libarchive/test/test_write_compress_xz.c (revision 2812)
+@@ -193,10 +193,14 @@
+ archive_write_close(a);
+ assert(0 == archive_write_finish(a));
+
+- /* Level 0 really does result in larger data. */
++ /* I would like to assert that compression-level=0 results in
++ * larger data than the default compression, but that's not true
++ * for all versions of liblzma. */
++ /*
+ failure("Compression-level=0 wrote %d bytes; default wrote %d bytes",
+ (int)used2, (int)used1);
+ assert(used2 > used1);
++ */
+
+ assert((a = archive_read_new()) != NULL);
+ assertA(0 == archive_read_support_format_all(a));
+
+Egenskapsändringar för: .
+___________________________________________________________________
+Modified: svn:mergeinfo
+ Merged /trunk:r2811
+
diff --git a/app-arch/libarchive/libarchive-2.7.1-r1.ebuild b/app-arch/libarchive/libarchive-2.7.1-r1.ebuild
index 0ec6f8d0a5a2..6d8f7aaff2e2 100644
--- a/app-arch/libarchive/libarchive-2.7.1-r1.ebuild
+++ b/app-arch/libarchive/libarchive-2.7.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.7.1-r1.ebuild,v 1.10 2010/11/14 13:42:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.7.1-r1.ebuild,v 1.11 2010/12/31 09:18:02 ferringb Exp $
EAPI="2"
@@ -31,6 +31,7 @@ DEPEND="${RDEPEND}
virtual/os-headers )"
src_prepare() {
+ epatch "$FILESDIR"/libarchive-disable-lzma-size-test.patch
elibtoolize
epunt_cxx
}
diff --git a/app-arch/libarchive/libarchive-2.8.0.ebuild b/app-arch/libarchive/libarchive-2.8.0.ebuild
deleted file mode 100644
index a4d0390b6664..000000000000
--- a/app-arch/libarchive/libarchive-2.8.0.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.8.0.ebuild,v 1.3 2010/11/14 13:42:00 jlec Exp $
-
-EAPI="2"
-
-inherit eutils libtool toolchain-funcs flag-o-matic
-
-DESCRIPTION="BSD tar command"
-HOMEPAGE="http://code.google.com/p/libarchive/"
-SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz
- http://people.freebsd.org/~kientzle/libarchive/src/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="static static-libs acl xattr kernel_linux +bzip2 +lzma +zlib"
-
-COMPRESS_LIBS_DEPEND="lzma? ( app-arch/xz-utils )
- bzip2? ( app-arch/bzip2 )
- zlib? ( sys-libs/zlib )"
-
-RDEPEND="!dev-libs/libarchive
- dev-libs/openssl
- acl? ( virtual/acl )
- xattr? ( kernel_linux? ( sys-apps/attr ) )
- !static? ( ${COMPRESS_LIBS_DEPEND} )"
-DEPEND="${RDEPEND}
- ${COMPRESS_LIBS_DEPEND}
- kernel_linux? ( sys-fs/e2fsprogs
- virtual/os-headers )"
-
-src_prepare() {
- elibtoolize
- epunt_cxx
-}
-
-src_configure() {
- local myconf
-
- if ! use static ; then
- myconf="--enable-bsdtar=shared --enable-bsdcpio=shared"
- fi
-
- # force static libs for static binaries
- if use static && ! use static-libs; then
- myconf="${myconf} --enable-static"
- fi
-
- # Check for need of this in 2.7.1 and later, on 2.7.0, -Werror was
- # added to the final release, but since it's done in the
- # Makefile.am we can just work it around this way.
- append-flags -Wno-error
-
- # We disable lzmadec because we support the newer liblzma from xz-utils
- # and not liblzmadec with this version.
- econf --bindir=/bin \
- --enable-bsdtar --enable-bsdcpio \
- $(use_enable acl) $(use_enable xattr) \
- $(use_with zlib) \
- $(use_with bzip2 bz2lib) $(use_with lzma) \
- $(use_enable static-libs static) \
- --without-lzmadec \
- ${myconf} \
- --disable-dependency-tracking
-}
-
-src_test() {
- # Replace the default src_test so that it builds tests in parallel
- emake check || die "tests failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed."
-
- # remove useless .a and .la files (only for non static compilation)
- use static-libs || find "${D}" \( -name '*.a' -or -name '*.la' \) -delete
-
- # Create tar symlink for FreeBSD
- if [[ ${CHOST} == *-freebsd* ]]; then
- dosym bsdtar /bin/tar
- dosym bsdtar.1 /usr/share/man/man1/tar.1
- # We may wish to switch to symlink bsdcpio to cpio too one day
- fi
-
- dodoc NEWS README
- dodir /$(get_libdir)
- mv "${D}"/usr/$(get_libdir)/*.so* "${D}"/$(get_libdir)
- gen_usr_ldscript libarchive.so
-}
diff --git a/app-arch/libarchive/libarchive-2.8.3.ebuild b/app-arch/libarchive/libarchive-2.8.3.ebuild
index 51809e805ac6..4ed8ba4e04c0 100644
--- a/app-arch/libarchive/libarchive-2.8.3.ebuild
+++ b/app-arch/libarchive/libarchive-2.8.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.8.3.ebuild,v 1.3 2010/11/14 13:42:00 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.8.3.ebuild,v 1.4 2010/12/31 09:18:02 ferringb Exp $
EAPI="2"
@@ -31,6 +31,7 @@ DEPEND="${RDEPEND}
virtual/os-headers )"
src_prepare() {
+ epatch "$FILESDIR"/libarchive-disable-lzma-size-test.patch
elibtoolize
epunt_cxx
}
diff --git a/app-arch/libarchive/libarchive-2.8.4.ebuild b/app-arch/libarchive/libarchive-2.8.4.ebuild
index ca270847ab3a..5e9e839dcf88 100644
--- a/app-arch/libarchive/libarchive-2.8.4.ebuild
+++ b/app-arch/libarchive/libarchive-2.8.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.8.4.ebuild,v 1.3 2010/12/18 01:42:13 leio Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/libarchive/libarchive-2.8.4.ebuild,v 1.4 2010/12/31 09:18:02 ferringb Exp $
EAPI="2"
@@ -31,6 +31,7 @@ DEPEND="${RDEPEND}
virtual/os-headers )"
src_prepare() {
+ epatch "$FILESDIR"/libarchive-disable-lzma-size-test.patch
elibtoolize
epunt_cxx
}