summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-06 23:04:03 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-06 23:04:03 +0000
commita2315bb872c329c09048c0d86f0176710d1f199c (patch)
tree2d9b0917704a79801bb463744642e233fdd58d90 /app-arch
parentold (diff)
downloadgentoo-2-a2315bb872c329c09048c0d86f0176710d1f199c.tar.gz
gentoo-2-a2315bb872c329c09048c0d86f0176710d1f199c.tar.bz2
gentoo-2-a2315bb872c329c09048c0d86f0176710d1f199c.zip
Version bump #88124 by Nicolai Lissner.
(Portage version: 2.0.51.19)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/bzip2/ChangeLog9
-rw-r--r--app-arch/bzip2/bzip2-1.0.3.ebuild71
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.3-makefile-CFLAGS.patch16
-rw-r--r--app-arch/bzip2/files/bzip2-1.0.3-saneso.patch9
-rw-r--r--app-arch/bzip2/files/digest-bzip2-1.0.31
5 files changed, 105 insertions, 1 deletions
diff --git a/app-arch/bzip2/ChangeLog b/app-arch/bzip2/ChangeLog
index 280fd355c60c..bdeabbff68b9 100644
--- a/app-arch/bzip2/ChangeLog
+++ b/app-arch/bzip2/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-arch/bzip2
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.21 2005/03/31 15:52:22 kugelfang Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/ChangeLog,v 1.22 2005/04/06 23:04:03 vapier Exp $
+
+*bzip2-1.0.3 (06 Apr 2005)
+
+ 06 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +files/bzip2-1.0.3-makefile-CFLAGS.patch, +files/bzip2-1.0.3-saneso.patch,
+ +bzip2-1.0.3.ebuild:
+ Version bump #88124 by Nicolai Lissner.
31 Mar 2005; Danny van Dyk <kugelfang@gentoo.org> bzip2-1.0.2-r5.ebuild:
Fixed BUG #87280 (multilib-strict).
diff --git a/app-arch/bzip2/bzip2-1.0.3.ebuild b/app-arch/bzip2/bzip2-1.0.3.ebuild
new file mode 100644
index 000000000000..d3e463d4dfc0
--- /dev/null
+++ b/app-arch/bzip2/bzip2-1.0.3.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/bzip2/bzip2-1.0.3.ebuild,v 1.1 2005/04/06 23:04:03 vapier Exp $
+
+inherit multilib toolchain-funcs flag-o-matic
+
+DESCRIPTION="A high-quality data compressor used extensively by Gentoo Linux"
+HOMEPAGE="http://www.bzip.org/"
+SRC_URI="http://www.bzip.org/${PV}/${P}.tar.gz"
+
+LICENSE="BZIP2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="build static"
+
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.0.2-NULL-ptr-check.patch
+ epatch "${FILESDIR}"/${P}-makefile-CFLAGS.patch
+ epatch "${FILESDIR}"/${P}-saneso.patch
+ epatch "${FILESDIR}"/${PN}-1.0.2-progress.patch
+ sed -i -e 's:\$(PREFIX)/man:\$(PREFIX)/share/man:g' Makefile || die "sed manpath"
+
+ use static && append-flags -static
+
+ # - Generate symlinks instead of hardlinks
+ # - pass custom variables to control libdir
+ sed -i \
+ -e 's:ln $(PREFIX)/bin/:ln -s :' \
+ -e 's:$(PREFIX)/lib:$(PREFIX)/$(LIBDIR):g' \
+ Makefile || die "sed links"
+
+ # bzip2 will to run itself after it has built itself which we
+ # can't do if we are cross compiling. -solar
+ if [[ -x /bin/bzip2 ]] && tc-is-cross-compiler ; then
+ sed -i -e 's:./bzip2 -:bzip2 -:g' Makefile || die "sed cross-compile"
+ fi
+}
+
+src_compile() {
+ local makeopts="
+ CC=$(tc-getCC)
+ AR=$(tc-getAR)
+ RANLIB=$(tc-getRANLIB)
+ "
+ if ! use build ; then
+ emake ${makeopts} -f Makefile-libbz2_so all || die "Make failed libbz2"
+ fi
+ emake ${makeopts} all || die "Make failed"
+}
+
+src_install() {
+ if ! use build ; then
+ make PREFIX="${D}"/usr LIBDIR=$(get_libdir) install || die
+ mv "${D}"/usr/bin "${D}"/
+ dolib.so "${S}"/libbz2.so.${PV}
+ for l in libbz2.so{,.1{,.0}} ; do
+ dosym libbz2.so.${PV} /usr/$(get_libdir)/${l}
+ done
+
+ dodoc README* CHANGES Y2K_INFO bzip2.txt manual.*
+ else
+ into /
+ dobin bzip2 || die "dobin bzip2"
+ dosym bzip2 /bin/bzcat
+ dosym bzip2 /bin/bunzip2
+ fi
+}
diff --git a/app-arch/bzip2/files/bzip2-1.0.3-makefile-CFLAGS.patch b/app-arch/bzip2/files/bzip2-1.0.3-makefile-CFLAGS.patch
new file mode 100644
index 000000000000..077f2b953d29
--- /dev/null
+++ b/app-arch/bzip2/files/bzip2-1.0.3-makefile-CFLAGS.patch
@@ -0,0 +1,16 @@
+--- Makefile
++++ Makefile
+@@ -10,4 +10,4 @@
+ BIGFILES=-D_FILE_OFFSET_BITS=64
+-CFLAGS=-Wall -Winline -O -g $(BIGFILES)
++CFLAGS+=-Wall -Winline $(BIGFILES)
+
+ # Where you want it installed when you do 'make install'
+--- Makefile-libbz2_so.orig 2004-12-26 16:32:23.972195408 -0500
++++ Makefile-libbz2_so 2004-12-26 16:32:34.835543928 -0500
+@@ -11,4 +11,4 @@
+ BIGFILES=-D_FILE_OFFSET_BITS=64
+-CFLAGS=-fpic -fPIC -Wall -Winline -O -g
++CFLAGS+=-fpic -fPIC -Wall -Winline
+
+ OBJS= blocksort.o \
diff --git a/app-arch/bzip2/files/bzip2-1.0.3-saneso.patch b/app-arch/bzip2/files/bzip2-1.0.3-saneso.patch
new file mode 100644
index 000000000000..a5d6334e6614
--- /dev/null
+++ b/app-arch/bzip2/files/bzip2-1.0.3-saneso.patch
@@ -0,0 +1,9 @@
+taken from fedora
+
+--- bzip2-1.0.2/Makefile-libbz2_so
++++ bzip2-1.0.2/Makefile-libbz2_so
+@@ -23,3 +23,3 @@
+ all: $(OBJS)
+- $(CC) -shared -Wl,-soname -Wl,libbz2.so.1.0 -o libbz2.so.1.0.3 $(OBJS)
++ $(CC) -shared -Wl,-soname -Wl,libbz2.so.1 -o libbz2.so.1.0.3 $(OBJS)
+ $(CC) $(CFLAGS) -o bzip2-shared bzip2.c libbz2.so.1.0.2
diff --git a/app-arch/bzip2/files/digest-bzip2-1.0.3 b/app-arch/bzip2/files/digest-bzip2-1.0.3
new file mode 100644
index 000000000000..24bf9c7e285a
--- /dev/null
+++ b/app-arch/bzip2/files/digest-bzip2-1.0.3
@@ -0,0 +1 @@
+MD5 8a716bebecb6e647d2e8a29ea5d8447f bzip2-1.0.3.tar.gz 669075