summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2008-05-10 10:38:41 +0000
committerMike Frysinger <vapier@gentoo.org>2008-05-10 10:38:41 +0000
commit1beba61d5d4d6fbe1fbc496ec7019057c7a34e44 (patch)
tree7e906908122755e4ce1318ab3015d38dec2d2059 /app-arch
parentversion bump #220172 by dword ptr (diff)
downloadgentoo-2-1beba61d5d4d6fbe1fbc496ec7019057c7a34e44.tar.gz
gentoo-2-1beba61d5d4d6fbe1fbc496ec7019057c7a34e44.tar.bz2
gentoo-2-1beba61d5d4d6fbe1fbc496ec7019057c7a34e44.zip
Handle just -d in wrapper script as this is how tar calls it #220899 by Ulrich Müller.
(Portage version: 2.2_pre5)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lzma-utils/ChangeLog6
-rwxr-xr-xapp-arch/lzma-utils/files/lzma-nocxx.sh27
2 files changed, 22 insertions, 11 deletions
diff --git a/app-arch/lzma-utils/ChangeLog b/app-arch/lzma-utils/ChangeLog
index 96e89b63dc80..981837feb347 100644
--- a/app-arch/lzma-utils/ChangeLog
+++ b/app-arch/lzma-utils/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/lzma-utils
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma-utils/ChangeLog,v 1.32 2008/05/10 08:35:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lzma-utils/ChangeLog,v 1.33 2008/05/10 10:38:40 vapier Exp $
+
+ 10 May 2008; Mike Frysinger <vapier@gentoo.org> files/lzma-nocxx.sh:
+ Handle just -d in wrapper script as this is how tar calls it #220899 by
+ Ulrich Müller.
10 May 2008; Mike Frysinger <vapier@gentoo.org> +files/lzma-nocxx.sh,
lzma-utils-4.32.5.ebuild:
diff --git a/app-arch/lzma-utils/files/lzma-nocxx.sh b/app-arch/lzma-utils/files/lzma-nocxx.sh
index cc81029b4d61..92e9cdcc35d1 100755
--- a/app-arch/lzma-utils/files/lzma-nocxx.sh
+++ b/app-arch/lzma-utils/files/lzma-nocxx.sh
@@ -1,12 +1,19 @@
#!/bin/sh
-if [ "$1" = "-dc" ] ; then
- shift
- cat "$@" | lzmadec
-else
- (
- echo "You've built lzma-utils without C++ support."
- echo "If you want lzma support, rebuild with C++ support."
- ) 1>&2
- exit 1
-fi
+case $1 in
+ -dc)
+ shift
+ cat "$@" | lzmadec
+ ;;
+ -d)
+ shift
+ lzmadec
+ ;;
+ *)
+ (
+ echo "You've built lzma-utils without C++ support."
+ echo "If you want lzma support, rebuild with C++ support."
+ ) 1>&2
+ exit 1
+ ;;
+esac