summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRick Farina <zerochaos@gentoo.org>2013-10-10 21:34:03 +0000
committerRick Farina <zerochaos@gentoo.org>2013-10-10 21:34:03 +0000
commit1b1e58d08c45d3c0d9a2b6efc12e5684babaedd7 (patch)
treebea802d760a4ec7ae64d447b1afbe5b86808f239 /app-arch
parentVersion bump and add upstream data to metadata. (diff)
downloadgentoo-2-1b1e58d08c45d3c0d9a2b6efc12e5684babaedd7.tar.gz
gentoo-2-1b1e58d08c45d3c0d9a2b6efc12e5684babaedd7.tar.bz2
gentoo-2-1b1e58d08c45d3c0d9a2b6efc12e5684babaedd7.zip
ship headers and build shared lib for mksquashfs and other things that dep on lz4
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key DD11F94A)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/lz4/ChangeLog6
-rw-r--r--app-arch/lz4/lz4-9999.ebuild11
2 files changed, 14 insertions, 3 deletions
diff --git a/app-arch/lz4/ChangeLog b/app-arch/lz4/ChangeLog
index c415e4eee00d..036e4d568362 100644
--- a/app-arch/lz4/ChangeLog
+++ b/app-arch/lz4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-arch/lz4
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/ChangeLog,v 1.3 2013/09/18 16:28:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/ChangeLog,v 1.4 2013/10/10 21:34:03 zerochaos Exp $
+
+ 10 Oct 2013; Rick Farina <zerochaos@gentoo.org> lz4-9999.ebuild:
+ ship headers and build shared lib for mksquashfs and other things that dep on
+ lz4
18 Sep 2013; Michał Górny <mgorny@gentoo.org> lz4-9999.ebuild:
Fix creating lz4c symlink on amd64.
diff --git a/app-arch/lz4/lz4-9999.ebuild b/app-arch/lz4/lz4-9999.ebuild
index 662244cea131..7b680f8efac6 100644
--- a/app-arch/lz4/lz4-9999.ebuild
+++ b/app-arch/lz4/lz4-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-9999.ebuild,v 1.3 2013/09/18 16:28:36 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/lz4/lz4-9999.ebuild,v 1.4 2013/10/10 21:34:03 zerochaos Exp $
-EAPI=4
+EAPI=5
inherit cmake-utils subversion
@@ -29,6 +29,11 @@ src_prepare() {
mv "${S}/cmake/"* "${S}"
}
+src_configure() {
+ local mycmakeargs=(-DBUILD_SHARED_LIBS=ON)
+ cmake-utils_src_configure
+}
+
src_install() {
cmake-utils_src_install
@@ -38,4 +43,6 @@ src_install() {
else
dosym /usr/bin/{lz4c32,lz4c}
fi
+
+ doheader lz4.h lz4hc.h xxhash.h
}