summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-05-09 12:03:50 +0000
committerSamuli Suominen <drac@gentoo.org>2008-05-09 12:03:50 +0000
commit1457a534e619c84d266032a6122745521eefe966 (patch)
tree2cd714e5856b3e246eb8fdb8e847e428c793f87d /app-arch
parent#219203 - Fix for CVE-2008-1927 (diff)
downloadgentoo-2-1457a534e619c84d266032a6122745521eefe966.tar.gz
gentoo-2-1457a534e619c84d266032a6122745521eefe966.tar.bz2
gentoo-2-1457a534e619c84d266032a6122745521eefe966.zip
Fix parallel building and clean up, thanks to Peter Alfredsen.
(Portage version: 2.1.5_rc7)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/arj/ChangeLog7
-rw-r--r--app-arch/arj/arj-3.10.22-r2.ebuild50
2 files changed, 56 insertions, 1 deletions
diff --git a/app-arch/arj/ChangeLog b/app-arch/arj/ChangeLog
index 9ba23dbcd258..430fbcb716c8 100644
--- a/app-arch/arj/ChangeLog
+++ b/app-arch/arj/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-arch/arj
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/ChangeLog,v 1.30 2008/04/21 16:18:16 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/ChangeLog,v 1.31 2008/05/09 12:03:50 drac Exp $
+
+*arj-3.10.22-r2 (09 May 2008)
+
+ 09 May 2008; Samuli Suominen <drac@gentoo.org> +arj-3.10.22-r2.ebuild:
+ Fix parallel building and clean up, thanks to Peter Alfredsen.
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/app-arch/arj/arj-3.10.22-r2.ebuild b/app-arch/arj/arj-3.10.22-r2.ebuild
new file mode 100644
index 000000000000..120039339eb9
--- /dev/null
+++ b/app-arch/arj/arj-3.10.22-r2.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/arj/arj-3.10.22-r2.ebuild,v 1.1 2008/05/09 12:03:50 drac Exp $
+
+inherit autotools eutils toolchain-funcs
+
+PATCH_LEVEL=4
+
+DESCRIPTION="Utility for opening arj archives"
+HOMEPAGE="http://arj.sourceforge.net"
+SRC_URI="mirror://debian/pool/main/a/arj/${P/-/_}.orig.tar.gz
+ mirror://debian/pool/main/a/arj/${P/-/_}-${PATCH_LEVEL}.diff.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${WORKDIR}"/${P/-/_}-${PATCH_LEVEL}.diff
+ EPATCH_SUFFIX="patch" EPATCH_FORCE="yes" \
+ epatch debian/patches
+
+ cd gnu
+ eautoconf
+}
+
+src_compile() {
+ cd gnu
+ CFLAGS="${CFLAGS} -Wall" econf
+
+ cd "${S}"
+ sed -i -e '/stripgcc/d' GNUmakefile || die "sed failed."
+
+ ARJLIBDIR="/usr/$(get_libdir)"
+
+ emake CC=$(tc-getCC) libdir="${ARJLIBDIR}" \
+ pkglibdir="${ARJLIBDIR}" all || die "emake failed."
+}
+
+src_install() {
+ emake pkglibdir="${ARJLIBDIR}" \
+ DESTDIR="${D}" install || die "emake install failed."
+
+ dodoc doc/rev_hist.txt
+}