summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2006-07-12 12:05:30 +0000
committerSeemant Kulleen <seemant@gentoo.org>2006-07-12 12:05:30 +0000
commit10e684d77c40dad7e63b58f4ebb70c3cb8a3c299 (patch)
tree237fa31246c120222663d60e33828bbf89c2602a /app-arch
parentMarked stable on x86. Removed version 1.1.1 (diff)
downloadgentoo-2-10e684d77c40dad7e63b58f4ebb70c3cb8a3c299.tar.gz
gentoo-2-10e684d77c40dad7e63b58f4ebb70c3cb8a3c299.tar.bz2
gentoo-2-10e684d77c40dad7e63b58f4ebb70c3cb8a3c299.zip
version bump, thanks to James in bug #138889
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'app-arch')
-rw-r--r--app-arch/ipkg-utils/ChangeLog8
-rw-r--r--app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.0508313
-rw-r--r--app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild39
3 files changed, 49 insertions, 1 deletions
diff --git a/app-arch/ipkg-utils/ChangeLog b/app-arch/ipkg-utils/ChangeLog
index 5de5d3ba7120..f222cd49df54 100644
--- a/app-arch/ipkg-utils/ChangeLog
+++ b/app-arch/ipkg-utils/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-arch/ipkg-utils
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.6 2006/07/01 16:06:06 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ChangeLog,v 1.7 2006/07/12 12:05:30 seemant Exp $
+
+*ipkg-utils-1.7.050831 (12 Jul 2006)
+
+ 12 Jul 2006; Seemant Kulleen <seemant@gentoo.org>
+ +ipkg-utils-1.7.050831.ebuild:
+ version bump, thanks to James in bug #138889
01 Jul 2006; Seemant Kulleen <seemant@gentoo.org>
+files/ipkg-utils-1.7-build_fixes.patch, ipkg-utils-1.7.ebuild:
diff --git a/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831 b/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831
new file mode 100644
index 000000000000..050fe1b78d8e
--- /dev/null
+++ b/app-arch/ipkg-utils/files/digest-ipkg-utils-1.7.050831
@@ -0,0 +1,3 @@
+MD5 4ede7edd4bcb69d9a0b74af2f68fd6da ipkg-utils-050831.tar.gz 29175
+RMD160 0b41d3afa907013f105f704afe9327ddeda360b3 ipkg-utils-050831.tar.gz 29175
+SHA256 1dde1111fbca85977855db9acb557097a32a5133d8764a05ea36a89a1205394b ipkg-utils-050831.tar.gz 29175
diff --git a/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild b/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild
new file mode 100644
index 000000000000..dfa3208f6b71
--- /dev/null
+++ b/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/ipkg-utils/ipkg-utils-1.7.050831.ebuild,v 1.1 2006/07/12 12:05:30 seemant Exp $
+
+inherit distutils eutils toolchain-funcs versionator
+
+MY_P=${PN}-$(get_version_component_range 3)
+
+DESCRIPTION="Tools for working with the ipkg binary package format"
+HOMEPAGE="http://www.openembedded.org/"
+SRC_URI="http://handhelds.org/download/packages/ipkg-utils/${MY_P}.tar.gz"
+LICENSE="GPL-2"
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~mips ~ppc ~x86"
+S=${WORKDIR}/${MY_P}
+
+DEPEND="dev-lang/python"
+
+src_unpack() {
+ unpack ${A}; cd ${S}
+
+ epatch ${FILESDIR}/${PN}-1.7-build_fixes.patch
+}
+
+src_compile() {
+ distutils_src_compile
+ emake CC="$(tc-getCC)" || die "emake failed"
+}
+
+src_install() {
+ distutils_src_install
+ make DESTDIR=${D} install || die
+}
+
+pkg_postinst() {
+ einfo "Consider installing sys-apps/fakeroot for use with the ipkg-build command,"
+ einfo "that makes it possible to build packages as a normal user."
+}