summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2005-02-26 14:05:02 +0000
committerNed Ludd <solar@gentoo.org>2005-02-26 14:05:02 +0000
commitbab86a88329b97daaf8198573b5917439e8e1a13 (patch)
treec03a02fa0328f55ccc97a06956e5157d44256d47 /app-arch/unace/unace-1.2b-r1.ebuild
parentkdelibs 3.4.0_rc1 (diff)
downloadgentoo-2-bab86a88329b97daaf8198573b5917439e8e1a13.tar.gz
gentoo-2-bab86a88329b97daaf8198573b5917439e8e1a13.tar.bz2
gentoo-2-bab86a88329b97daaf8198573b5917439e8e1a13.zip
- security bump for unace-1.2b (the last) opensource release bug #81958. I'd like for us to remove the binary only 2.2 which partially remains vuln. No clear upgrade path. will p.mask or something
(Portage version: 2.0.51-r15)
Diffstat (limited to 'app-arch/unace/unace-1.2b-r1.ebuild')
-rw-r--r--app-arch/unace/unace-1.2b-r1.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/app-arch/unace/unace-1.2b-r1.ebuild b/app-arch/unace/unace-1.2b-r1.ebuild
new file mode 100644
index 000000000000..fbc88f568c1b
--- /dev/null
+++ b/app-arch/unace/unace-1.2b-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/unace/unace-1.2b-r1.ebuild,v 1.1 2005/02/26 14:05:02 solar Exp $
+
+inherit eutils
+
+DESCRIPTION="ACE unarchiver"
+HOMEPAGE="http://www.winace.com/"
+SRC_URI="http://wilma.vub.ac.be/~pdewacht/${P}.tar.gz"
+
+LICENSE="freedist"
+SLOT="1"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/libc"
+
+S="${WORKDIR}/${PN}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ cp unix/makefile .
+ cp unix/gccmaked .
+ epatch ${FILESDIR}/unace-1.2b-CAN-2005-0160-CAN-2005-0161.patch
+}
+
+src_compile() {
+ sed -i -e "s/^CFLAGS = -O.*/CFLAGS = -Wall ${CFLAGS}/g" \
+ -e "s/-DCASEINSENSE//g" \
+ makefile
+
+ emake dep || die
+ emake || die
+}
+
+src_install() {
+ dobin unace || die
+ dodoc readme.txt changes.log
+}