summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJon Nall <nall@gentoo.org>2002-10-30 02:22:38 +0000
committerJon Nall <nall@gentoo.org>2002-10-30 02:22:38 +0000
commitbab5c01b8e5ce3983480762a7b511ee68c45d4d4 (patch)
treec97e5aa8b43dd97cbb2c417e4088a7f04340d37e /app-arch/stuffit
parentadding license for Aladdin Stuffit (diff)
downloadgentoo-2-bab5c01b8e5ce3983480762a7b511ee68c45d4d4.tar.gz
gentoo-2-bab5c01b8e5ce3983480762a7b511ee68c45d4d4.tar.bz2
gentoo-2-bab5c01b8e5ce3983480762a7b511ee68c45d4d4.zip
Initial commit of Aladdin Stuffit into gentoo CVS
Diffstat (limited to 'app-arch/stuffit')
-rw-r--r--app-arch/stuffit/ChangeLog9
-rw-r--r--app-arch/stuffit/files/digest-stuffit-5.2.0.6111
-rw-r--r--app-arch/stuffit/stuffit-5.2.0.611.ebuild88
3 files changed, 98 insertions, 0 deletions
diff --git a/app-arch/stuffit/ChangeLog b/app-arch/stuffit/ChangeLog
new file mode 100644
index 000000000000..c60086d64f42
--- /dev/null
+++ b/app-arch/stuffit/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-arch/stuffit
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/stuffit/ChangeLog,v 1.1 2002/10/30 02:22:38 nall Exp $
+
+*stuffit-5.2.0.611 (29 Oct 2002)
+
+ 29 10 2002; Jon Nall <nall@gentoo.org> stuffit-5.2.0.611.ebuild :
+ Initial import. Ebuild thanks to CJ Kucera <pez@apocalyptech.com>
+ in bug #9845.
diff --git a/app-arch/stuffit/files/digest-stuffit-5.2.0.611 b/app-arch/stuffit/files/digest-stuffit-5.2.0.611
new file mode 100644
index 000000000000..79933bb0d5f9
--- /dev/null
+++ b/app-arch/stuffit/files/digest-stuffit-5.2.0.611
@@ -0,0 +1 @@
+MD5 9046256f7775cc8b324447c7c3e8f941 stuffit520.611linux-i386.tgz 1955619
diff --git a/app-arch/stuffit/stuffit-5.2.0.611.ebuild b/app-arch/stuffit/stuffit-5.2.0.611.ebuild
new file mode 100644
index 000000000000..b0cab32ee698
--- /dev/null
+++ b/app-arch/stuffit/stuffit-5.2.0.611.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/stuffit/stuffit-5.2.0.611.ebuild,v 1.1 2002/10/30 02:22:38 nall Exp $
+
+MY_P="stuffit520.611linux-i386"
+DESCRIPTION="Aladdin Software's StuffIt and StuffIt Expander"
+HOMEPAGE="http://stuffit.com/"
+SRC_URI="${MY_P}.tgz"
+LICENSE="Stuffit"
+SLOT="0"
+KEYWORDS="x86 -ppc -sparc -sparc64 -alpha"
+
+IUSE=""
+DEPEND=""
+RDEPEND=""
+
+S=${WORKDIR}
+INSTALLDIR="/opt/stuffit"
+#RESTRICT="fetch nostrip"
+
+pkg_setup() {
+ if [ ${ARCH} != "x86" ] ; then
+ einfo "This is an x86 only package, sorry"
+ die "Not supported on your ARCH"
+ fi
+}
+
+src_unpack() {
+ if [ ! -f ${DISTDIR}/${MY_P}.tgz ] ; then
+ einfo
+ einfo "Please download ${MY_P} from ${HOMEPAGE}downloads.html"
+ einfo "(click on the Linux Evaluation Link), and put it in ${DISTDIR}"
+ einfo
+ einfo "Note that StuffIt requires registration within 15 days,"
+ einfo "but StuffIt Expander is freeware."
+ einfo
+ die
+ fi
+ unpack ${MY_P}.tgz
+}
+
+src_install() {
+
+ # First do the binaries
+ exeinto ${INSTALLDIR}/bin
+ doexe ${S}/bin/stuff
+ doexe ${S}/bin/unstuff
+
+ # Now the registration binary
+ exeinto ${INSTALLDIR}/extra
+ doexe ${S}/bin/register
+
+ # Now the documentation
+ docinto stuff
+ dodoc ${S}/doc/stuff/LICENSE
+ dodoc ${S}/doc/stuff/README
+ dodoc ${S}/doc/stuff/INSTALL
+ dohtml ${S}/doc/stuff/stuff.html
+ docinto unstuff
+ dodoc ${S}/doc/unstuff/LICENSE
+ dodoc ${S}/doc/unstuff/README
+ dodoc ${S}/doc/unstuff/INSTALL
+ dohtml ${S}/doc/unstuff/unstuff.html
+
+ # And now the man pages
+ doman ${S}/man/man1/*
+
+ # Also add the executables to the path
+ dodir etc/env.d
+ echo -e "PATH=${INSTALLDIR}/bin\nROOTPATH=${INSTALLDIR}/bin" > \
+ ${D}/etc/env.d/10stuffit
+
+}
+
+pkg_postinst() {
+ env-update
+ einfo
+ einfo "Reminder: StuffIt requires registration within 15 days."
+ einfo "The registration program is located in ${INSTALLDIR}/extra"
+ einfo
+ einfo "The binaries are named 'stuff' and 'unstuff'"
+ einfo
+}
+
+pkg_postrm() {
+ # Get rid of those extraneous PATH entries.
+ env-update
+}