summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDror Levin <spatz@gentoo.org>2010-09-04 13:23:51 +0000
committerDror Levin <spatz@gentoo.org>2010-09-04 13:23:51 +0000
commit4f0a65fef2bb282b64b22890aafe364630895dc8 (patch)
tree2645ea0d50cefb9d48cbed25d0d1387c2dd672cc /app-arch/pigz/pigz-2.1.6-r1.ebuild
parentalpha stable (diff)
downloadgentoo-2-4f0a65fef2bb282b64b22890aafe364630895dc8.tar.gz
gentoo-2-4f0a65fef2bb282b64b22890aafe364630895dc8.tar.bz2
gentoo-2-4f0a65fef2bb282b64b22890aafe364630895dc8.zip
Add patch to support double dash command-line option (--), bug 335852.
(Portage version: 2.2_rc74/cvs/Linux x86_64)
Diffstat (limited to 'app-arch/pigz/pigz-2.1.6-r1.ebuild')
-rw-r--r--app-arch/pigz/pigz-2.1.6-r1.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-arch/pigz/pigz-2.1.6-r1.ebuild b/app-arch/pigz/pigz-2.1.6-r1.ebuild
new file mode 100644
index 000000000000..a2797c34e0c0
--- /dev/null
+++ b/app-arch/pigz/pigz-2.1.6-r1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/pigz/pigz-2.1.6-r1.ebuild,v 1.1 2010/09/04 13:23:51 spatz Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A parallel implementation of gzip"
+HOMEPAGE="http://www.zlib.net/pigz/"
+SRC_URI="http://www.zlib.net/pigz/${P}.tar.gz"
+
+LICENSE="PIGZ"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86 ~amd64-linux ~sparc64-solaris"
+IUSE="symlink test"
+
+RDEPEND="sys-libs/zlib"
+DEPEND="${RDEPEND}
+ test? ( app-arch/ncompress )"
+
+src_prepare() {
+ sed -i -e '/^CFLAGS=/ d' -e '4s/cc/$(CC) $(LDFLAGS)/' "${S}/Makefile" || die
+ epatch "${FILESDIR}/${P}-doubledash.patch"
+ tc-export CC
+}
+
+src_install() {
+ dobin ${PN} || die "Failed to install"
+ dosym /usr/bin/${PN} /usr/bin/un${PN} || die
+ dodoc README || die
+ doman ${PN}.1 || die
+
+ if use symlink; then
+ dosym /usr/bin/${PN} /usr/bin/gzip || die
+ dosym /usr/bin/un${PN} /usr/bin/gunzip || die
+ fi
+}