summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-05-04 06:13:23 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-05-04 06:13:23 +0000
commitcc72d8157199ca84a6de0e82a97f270ed76d7d90 (patch)
tree775a1f104ea71b827e04b0545828ab06d25e127b /app-arch/lzop
parentremove all 4.1.7* ebuilds (diff)
downloadgentoo-2-cc72d8157199ca84a6de0e82a97f270ed76d7d90.tar.gz
gentoo-2-cc72d8157199ca84a6de0e82a97f270ed76d7d90.tar.bz2
gentoo-2-cc72d8157199ca84a6de0e82a97f270ed76d7d90.zip
added lzop - very fast compression/decompression utility
Diffstat (limited to 'app-arch/lzop')
-rw-r--r--app-arch/lzop/ChangeLog9
-rw-r--r--app-arch/lzop/files/digest-lzop-1.001
-rw-r--r--app-arch/lzop/lzop-1.00.ebuild29
3 files changed, 39 insertions, 0 deletions
diff --git a/app-arch/lzop/ChangeLog b/app-arch/lzop/ChangeLog
new file mode 100644
index 000000000000..25724ddc679a
--- /dev/null
+++ b/app-arch/lzop/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for app-arch/lzop
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# /space/gentoo/cvsroot/gentoo-x86/dev-lang/gpc/ChangeLog,v 1.2 2002/04/14 09:14:32 george Exp
+
+
+*lzop-1.00, (03 May 2002)
+
+ Initial release
+
diff --git a/app-arch/lzop/files/digest-lzop-1.00 b/app-arch/lzop/files/digest-lzop-1.00
new file mode 100644
index 000000000000..79813fcca3d1
--- /dev/null
+++ b/app-arch/lzop/files/digest-lzop-1.00
@@ -0,0 +1 @@
+MD5 ef267ac5ea24ccf4ae779f4afb0ab48e lzop-1.00.tar.gz 160972
diff --git a/app-arch/lzop/lzop-1.00.ebuild b/app-arch/lzop/lzop-1.00.ebuild
new file mode 100644
index 000000000000..6cf3c793051e
--- /dev/null
+++ b/app-arch/lzop/lzop-1.00.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author George Shapovalov <georges@cco.caltech.edu>
+# /space/gentoo/cvsroot/gentoo-x86/dev-libs/gmp/gmp-3.1.1-r1.ebuild,v 1.4 2001/11/24 18:40:50 drobbins Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Utility for fast (even reat-time) compression/decompression"
+SRC_URI="http://www.oberhumer.com/opensource/lzop/download/${P}.tar.gz"
+HOMEPAGE="http://www.oberhumer.com/opensource/lzop/"
+DEPEND="virtual/glibc
+ dev-libs/lzo"
+RDEPEND="virtual/glibc"
+
+src_compile() {
+ ./configure --host=${CHOST} \
+ --prefix=/usr --disable-shared
+ assert
+
+ make || die
+}
+
+src_install() {
+ make prefix=${D}/usr install || die
+
+ dodoc AUTHORS ChangeLog COPYING* NEWS README THANKS
+ dodoc doc/lzop.{txt,ps}
+ dohtml doc/*.html
+
+}