summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-08-11 14:54:42 +0000
committerMike Frysinger <vapier@gentoo.org>2004-08-11 14:54:42 +0000
commit436633f467cb9af7f23c096c5dd275ed29774f1c (patch)
tree74b8a15b7fed63ab9a93beff9191720f2ef46802 /app-arch/gzip-x86/gzip-x86-0.91.ebuild
parentversion bump (Manifest recommit) (diff)
downloadgentoo-2-436633f467cb9af7f23c096c5dd275ed29774f1c.tar.gz
gentoo-2-436633f467cb9af7f23c096c5dd275ed29774f1c.tar.bz2
gentoo-2-436633f467cb9af7f23c096c5dd275ed29774f1c.zip
Version bump #25804 by Tobias Sager.
Diffstat (limited to 'app-arch/gzip-x86/gzip-x86-0.91.ebuild')
-rw-r--r--app-arch/gzip-x86/gzip-x86-0.91.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/app-arch/gzip-x86/gzip-x86-0.91.ebuild b/app-arch/gzip-x86/gzip-x86-0.91.ebuild
new file mode 100644
index 000000000000..486d885661ea
--- /dev/null
+++ b/app-arch/gzip-x86/gzip-x86-0.91.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-arch/gzip-x86/gzip-x86-0.91.ebuild,v 1.1 2004/08/11 14:54:42 vapier Exp $
+
+inherit gcc
+
+MY_P=${PN/-/_}-${PV}
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="an optimized gzip for x86 arch"
+HOMEPAGE="http://www.BitWagon.com/ftp/"
+SRC_URI="http://www.BitWagon.com/ftp/${MY_P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE=""
+
+DEPEND="virtual/libc"
+PROVIDE="virtual/gzip"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ rm -f config.h.in
+ autoheader || die
+}
+
+src_compile() {
+ econf --bindir=/bin || die
+ emake CCAS="$(gcc-getCC)" || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+}