summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarc Hildebrand <zypher@gentoo.org>2004-03-11 09:43:55 +0000
committerMarc Hildebrand <zypher@gentoo.org>2004-03-11 09:43:55 +0000
commit28ee9cb875c4b672f821ba9a2de0e14ebb365717 (patch)
tree7c56e7fb0bd7a5a11f1070665998b91312ab1eb7 /app-arch/freeze/freeze-2.5.0.ebuild
parentsome minor fixes, and bump the rev for a new patch (Manifest recommit) (diff)
downloadgentoo-2-28ee9cb875c4b672f821ba9a2de0e14ebb365717.tar.gz
gentoo-2-28ee9cb875c4b672f821ba9a2de0e14ebb365717.tar.bz2
gentoo-2-28ee9cb875c4b672f821ba9a2de0e14ebb365717.zip
initial commit
Diffstat (limited to 'app-arch/freeze/freeze-2.5.0.ebuild')
-rw-r--r--app-arch/freeze/freeze-2.5.0.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/app-arch/freeze/freeze-2.5.0.ebuild b/app-arch/freeze/freeze-2.5.0.ebuild
new file mode 100644
index 000000000000..1418d5f31205
--- /dev/null
+++ b/app-arch/freeze/freeze-2.5.0.ebuild
@@ -0,0 +1,44 @@
+DESCRIPTION="freeze / melt compression program"
+SRC_URI="ftp://ftp.ibiblio.org/pub/Linux/utils/compress/${P}.tar.gz"
+HOMEPAGE="http://www.ibiblio.org/pub/Linux/utils/compress/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="x86"
+IUSE=""
+
+DEPEND="virtual/glibc"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ # hard links confuse prepman and these links are absolute
+ sed -i.orig \
+ -e "s:ln -f \$@ \$(DEST):ln -sf freeze \$(DEST):g" \
+ -e "s:ln -f \$@ \$(MANDEST):ln -sf freeze.\$(SEC) \$(MANDEST):g" \
+ Makefile.in
+}
+
+src_compile() {
+ cd ${S}
+
+ econf || die "configure failed"
+ emake CC="gcc" \
+ CFLAGS="$CFLAGS" \
+ OPTIONS="-DDEFFILE=\\\"/etc/freeze.cnf\\\"" \
+ || die "compile failed"
+}
+
+src_install() {
+ cd ${S}
+
+ dodir /usr/bin /usr/share/man/man1
+ make DEST="$D/usr/bin" \
+ MANDEST="$D/usr/share/man/man1" \
+ install
+
+ dobin showhuf
+ dodoc README *.lsm
+}