summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2007-02-01 18:08:25 +0000
committerAndrej Kacian <ticho@gentoo.org>2007-02-01 18:08:25 +0000
commit594921923278686c92938e15c3a8a51a0e70ea0d (patch)
treec6a465527f92d90cca2fa6b50ec601d1c70b2481 /app-antivirus
parentremove old ebuild (diff)
downloadgentoo-2-594921923278686c92938e15c3a8a51a0e70ea0d.tar.gz
gentoo-2-594921923278686c92938e15c3a8a51a0e70ea0d.tar.bz2
gentoo-2-594921923278686c92938e15c3a8a51a0e70ea0d.zip
New release candidate.
(Portage version: 2.1.2-r5)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog7
-rw-r--r--app-antivirus/clamav/clamav-0.90_rc3.ebuild120
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.90_rc33
3 files changed, 129 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 761dea57d935..8972db9005ce 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.195 2007/01/23 15:22:40 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.196 2007/02/01 18:08:25 ticho Exp $
+
+*clamav-0.90_rc3 (01 Feb 2007)
+
+ 01 Feb 2007; Andrej Kacian <ticho@gentoo.org> +clamav-0.90_rc3.ebuild:
+ New release candidate.
23 Jan 2007; Marius Mauch <genone@gentoo.org> clamav-0.88.5.ebuild,
clamav-0.88.6.ebuild, clamav-0.88.7.ebuild, clamav-0.88.7-r1.ebuild,
diff --git a/app-antivirus/clamav/clamav-0.90_rc3.ebuild b/app-antivirus/clamav/clamav-0.90_rc3.ebuild
new file mode 100644
index 000000000000..05006b802577
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.90_rc3.ebuild
@@ -0,0 +1,120 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.90_rc3.ebuild,v 1.1 2007/02/01 18:08:25 ticho Exp $
+
+inherit eutils flag-o-matic fixheadtails
+
+MY_P="${P/_/}"
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="crypt milter selinux mailwrapper"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
+ >=sys-libs/zlib-1.2.1-r3
+ >=net-misc/curl-7.10.0
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-clamav )
+ sys-apps/grep"
+PROVIDE="virtual/antivirus"
+
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if use milter; then
+ if [ ! -e /usr/lib/libmilter.a ] ; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
+ ewarn "this flag for clamav as well to disable milter support."
+ die "need milter-enabled sendmail"
+ fi
+ fi
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+ # use id utility instead of /etc/passwd parsing (bug #72540)
+ myconf="${myconf} --enable-id-check"
+ use milter && {
+ myconf="${myconf} --enable-milter"
+ use mailwrapper && \
+ myconf="${myconf} --with-sendmail=/usr/sbin/sendmail.sendmail"
+ }
+
+ ht_fix_file configure
+ econf ${myconf} \
+ --enable-experimental \
+ --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
+ newconfd ${FILESDIR}/clamd.conf clamd
+ newinitd ${FILESDIR}/clamd.rc clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+
+ dodir /var/run/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ dodir /var/log/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ # Change /etc/clamd.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1 yes:" \
+ ${D}/etc/clamd.conf
+
+ # Do the same for /etc/freshclam.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(UpdateLogFile\) .*:\1 /var/log/clamav/freshclam.log:" \
+ ${D}/etc/freshclam.conf
+
+ if use milter ; then
+ echo "START_MILTER=no" \
+ >> ${D}/etc/conf.d/clamd
+ echo "MILTER_SOCKET=\"/var/run/clamav/clmilter.sock\"" \
+ >>${D}/etc/conf.d/clamd
+ echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
+ >>${D}/etc/conf.d/clamd
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ if use milter ; then
+ elog "For simple instructions how to setup the clamav-milter"
+ elog "read /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+ ewarn "This is a RELEASE CANDIDATE version, with EXPERIMENTAL code ENABLED."
+ ewarn "USE AT YOUR OWN RISK. Report bugs at http://bugs.clamav.net"
+ echo
+ ebeep 3
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.90_rc3 b/app-antivirus/clamav/files/digest-clamav-0.90_rc3
new file mode 100644
index 000000000000..c80b075dc78e
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.90_rc3
@@ -0,0 +1,3 @@
+MD5 5af2bdbbb255829dd590609d900c1854 clamav-0.90rc3.tar.gz 10784835
+RMD160 24e66ec3352c7e1007cddea278cba161d0fb4e3d clamav-0.90rc3.tar.gz 10784835
+SHA256 aba20f98453affeeb60427bdd432b7c5a5115f17aa2734cf1393c750f95d66ad clamav-0.90rc3.tar.gz 10784835