summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrej Kacian <ticho@gentoo.org>2006-12-19 02:34:45 +0000
committerAndrej Kacian <ticho@gentoo.org>2006-12-19 02:34:45 +0000
commit32a04e02b9d40720dfd80521fc1c90cb4ec0eb75 (patch)
tree8e8223d6c58821044f274569b0a45b34707b3082 /app-antivirus
parentAdded entry app-antivirus/clamav:onaccess (diff)
downloadgentoo-2-32a04e02b9d40720dfd80521fc1c90cb4ec0eb75.tar.gz
gentoo-2-32a04e02b9d40720dfd80521fc1c90cb4ec0eb75.tar.bz2
gentoo-2-32a04e02b9d40720dfd80521fc1c90cb4ec0eb75.zip
Add support for clamuko - on-access file scanning using dazuko kernel module. Closes bug #99992 by Alon Bar-Lev <alonbl at gentoo.org>.
(Portage version: 2.1.2_rc3-r5)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog8
-rw-r--r--app-antivirus/clamav/clamav-0.88.7-r1.ebuild126
-rw-r--r--app-antivirus/clamav/files/digest-clamav-0.88.7-r13
3 files changed, 136 insertions, 1 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index 01ad6c13a475..8f58f443f5e5 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-antivirus/clamav
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.189 2006/12/17 21:17:08 killerfox Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.190 2006/12/19 02:34:45 ticho Exp $
+
+*clamav-0.88.7-r1 (19 Dec 2006)
+
+ 19 Dec 2006; Andrej Kacian <ticho@gentoo.org> +clamav-0.88.7-r1.ebuild:
+ Add support for clamuko - on-access file scanning using dazuko kernel
+ module. Closes bug #99992 by Alon Bar-Lev <alonbl at gentoo.org>.
17 Dec 2006; René Nussbaumer <killerfox@gentoo.org> clamav-0.88.7.ebuild:
Stable on hppa. See bug #157698.
diff --git a/app-antivirus/clamav/clamav-0.88.7-r1.ebuild b/app-antivirus/clamav/clamav-0.88.7-r1.ebuild
new file mode 100644
index 000000000000..44f83bd44143
--- /dev/null
+++ b/app-antivirus/clamav/clamav-0.88.7-r1.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.88.7-r1.ebuild,v 1.1 2006/12/19 02:34:45 ticho Exp $
+
+inherit eutils flag-o-matic fixheadtails
+
+DESCRIPTION="Clam Anti-Virus Scanner"
+HOMEPAGE="http://www.clamav.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="crypt milter selinux mailwrapper onaccess"
+
+DEPEND="virtual/libc
+ crypt? ( >=dev-libs/gmp-4.1.2 )
+ milter? ( || ( mail-filter/libmilter mail-mta/sendmail ) )
+ onaccess? ( sys-fs/dazuko )
+ >=sys-libs/zlib-1.2.1-r3
+ >=net-misc/curl-7.10.0
+ >=sys-apps/sed-4"
+RDEPEND="${DEPEND}
+ selinux? ( sec-policy/selinux-clamav )
+ sys-apps/grep"
+PROVIDE="virtual/antivirus"
+
+pkg_setup() {
+ if use milter; then
+ if [ ! -e /usr/lib/libmilter.a ] ; then
+ ewarn "In order to enable milter support, clamav needs sendmail with enabled milter"
+ ewarn "USE flag. Either recompile sendmail with milter USE flag enabled, or disable"
+ ewarn "this flag for clamav as well to disable milter support."
+ die "need milter-enabled sendmail"
+ fi
+ fi
+ if use onaccess ; then
+ echo
+ ewarn "Warning: On access scan support is experimental!"
+ echo
+ fi
+ enewgroup clamav
+ enewuser clamav -1 -1 /dev/null clamav
+}
+
+src_compile() {
+ has_version =sys-libs/glibc-2.2* && filter-lfs-flags
+
+ local myconf
+
+ # we depend on fixed zlib, so we can disable this check to prevent redundant
+ # warning (bug #61749)
+ myconf="${myconf} --disable-zlib-vcheck"
+ # use id utility instead of /etc/passwd parsing (bug #72540)
+ myconf="${myconf} --enable-id-check"
+ use milter && {
+ myconf="${myconf} --enable-milter"
+ use mailwrapper && \
+ myconf="${myconf} --with-sendmail=/usr/sbin/sendmail.sendmail"
+ }
+
+ ht_fix_file configure
+ econf ${myconf} \
+ $(use_enable dazuko clamuko) \
+ --with-dbdir=/var/lib/clamav || die
+ emake || die
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+ dodoc AUTHORS BUGS NEWS README ChangeLog FAQ INSTALL
+ newconfd ${FILESDIR}/clamd.conf clamd
+ newinitd ${FILESDIR}/clamd.rc clamd
+ dodoc ${FILESDIR}/clamav-milter.README.gentoo
+
+ dodir /var/run/clamav
+ keepdir /var/run/clamav
+ fowners clamav:clamav /var/run/clamav
+ dodir /var/log/clamav
+ keepdir /var/log/clamav
+ fowners clamav:clamav /var/log/clamav
+
+ # Change /etc/clamd.conf to be usable out of the box
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/clamd.pid:" \
+ -e "s:.*\(LocalSocket\) .*:\1 /var/run/clamav/clamd.sock:" \
+ -e "s:.*\(User\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/clamav/clamd.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/clamd.conf
+
+ # Do the same for /etc/freshclam.conf
+ sed -i -e "s:^\(Example\):\# \1:" \
+ -e "s:.*\(PidFile\) .*:\1 /var/run/clamav/freshclam.pid:" \
+ -e "s:.*\(DatabaseOwner\) .*:\1 clamav:" \
+ -e "s:^\#\(LogFile\) .*:\1 /var/log/freshclam.log:" \
+ -e "s:^\#\(LogTime\).*:\1:" \
+ ${D}/etc/freshclam.conf
+
+ if use milter ; then
+ echo "START_MILTER=no" \
+ >> ${D}/etc/conf.d/clamd
+ echo "MILTER_SOCKET=\"/var/run/clamav/clmilter.sock\"" \
+ >>${D}/etc/conf.d/clamd
+ echo "MILTER_OPTS=\"-m 10 --timeout=0\"" \
+ >>${D}/etc/conf.d/clamd
+ fi
+
+ if use onaccess ; then
+ dodir /etc/udev/rules.d
+ echo "KERNEL==\"dazuko\", NAME=\"%k\", GROUP=\"clamav\", MODE=\"0660\"" \
+ >${D}/etc/udev/rules.d/60-dazuko.rules
+ fi
+}
+
+pkg_postinst() {
+ echo
+ ewarn "Warning: clamd and/or freshclam have not been restarted."
+ ewarn "You should restart them with: /etc/init.d/clamd restart"
+ echo
+ if use milter ; then
+ einfo "For simple instructions how to setup the clamav-milter type:"
+ echo " zless /usr/share/doc/${PF}/clamav-milter.README.gentoo.gz"
+ echo
+ fi
+}
diff --git a/app-antivirus/clamav/files/digest-clamav-0.88.7-r1 b/app-antivirus/clamav/files/digest-clamav-0.88.7-r1
new file mode 100644
index 000000000000..766a04de5f01
--- /dev/null
+++ b/app-antivirus/clamav/files/digest-clamav-0.88.7-r1
@@ -0,0 +1,3 @@
+MD5 34a9d58cf5bcb04dbe3eb32b5367a3f8 clamav-0.88.7.tar.gz 9510548
+RMD160 14d7c6255df618b16b704fc1cb5ce2b1385fa0e8 clamav-0.88.7.tar.gz 9510548
+SHA256 702cb5928bff3d0e647a4a6b505d434e3a0f10f2af74bddac5239a200b92d1e2 clamav-0.88.7.tar.gz 9510548