summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2012-05-31 15:44:59 +0000
committerTim Harder <radhermit@gentoo.org>2012-05-31 15:44:59 +0000
commit16f136f2216a08db7db711429fd8aca15fe38ef6 (patch)
treef1212357fdb332d2b4df36f2d04b4dc456381f8f /app-antivirus
parentVersion bump (diff)
downloadgentoo-2-16f136f2216a08db7db711429fd8aca15fe38ef6.tar.gz
gentoo-2-16f136f2216a08db7db711429fd8aca15fe38ef6.tar.bz2
gentoo-2-16f136f2216a08db7db711429fd8aca15fe38ef6.zip
Fix build with gcc-4.7 (bug #412349 by Alphat-PC).
(Portage version: 2.2.0_alpha108/cvs/Linux x86_64)
Diffstat (limited to 'app-antivirus')
-rw-r--r--app-antivirus/clamav/ChangeLog6
-rw-r--r--app-antivirus/clamav/clamav-0.97.4.ebuild7
-rw-r--r--app-antivirus/clamav/files/clamav-0.97.4-gcc47.patch24
3 files changed, 34 insertions, 3 deletions
diff --git a/app-antivirus/clamav/ChangeLog b/app-antivirus/clamav/ChangeLog
index f3f3a4898a20..806dc662fc7c 100644
--- a/app-antivirus/clamav/ChangeLog
+++ b/app-antivirus/clamav/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for app-antivirus/clamav
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.415 2012/05/31 03:01:55 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/ChangeLog,v 1.416 2012/05/31 15:44:58 radhermit Exp $
+
+ 31 May 2012; Tim Harder <radhermit@gentoo.org> clamav-0.97.4.ebuild,
+ +files/clamav-0.97.4-gcc47.patch:
+ Fix build with gcc-4.7 (bug #412349 by Alphat-PC).
31 May 2012; Zac Medico <zmedico@gentoo.org> clamav-0.97.3.ebuild,
clamav-0.97.4.ebuild:
diff --git a/app-antivirus/clamav/clamav-0.97.4.ebuild b/app-antivirus/clamav/clamav-0.97.4.ebuild
index fe32690a8102..819797be4137 100644
--- a/app-antivirus/clamav/clamav-0.97.4.ebuild
+++ b/app-antivirus/clamav/clamav-0.97.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.97.4.ebuild,v 1.3 2012/05/31 03:01:52 zmedico Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-antivirus/clamav/clamav-0.97.4.ebuild,v 1.4 2012/05/31 15:44:58 radhermit Exp $
EAPI=4
@@ -31,7 +31,10 @@ RESTRICT="test"
DOCS=( AUTHORS BUGS ChangeLog FAQ INSTALL NEWS README UPGRADE )
-PATCHES=( "${FILESDIR}"/${PN}-0.97-nls.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.97-nls.patch
+ "${FILESDIR}"/${PN}-0.97.4-gcc47.patch
+)
pkg_setup() {
enewgroup clamav
diff --git a/app-antivirus/clamav/files/clamav-0.97.4-gcc47.patch b/app-antivirus/clamav/files/clamav-0.97.4-gcc47.patch
new file mode 100644
index 000000000000..d5cbf2eb8f9f
--- /dev/null
+++ b/app-antivirus/clamav/files/clamav-0.97.4-gcc47.patch
@@ -0,0 +1,24 @@
+From bb8ab5ce7ea4e276c310f5a638cd61c0cceb47d1 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?T=C3=B6r=C3=B6k=20Edvin?= <edwin@clamav.net>
+Date: Mon, 14 May 2012 20:13:21 +0300
+Subject: [PATCH] Fix build with gcc-4.7
+
+---
+ .../c++/llvm/lib/ExecutionEngine/JIT/Intercept.cpp | 1 +
+ 1 files changed, 1 insertions(+), 0 deletions(-)
+
+diff --git a/libclamav/c++/llvm/lib/ExecutionEngine/JIT/Intercept.cpp b/libclamav/c++/llvm/lib/ExecutionEngine/JIT/Intercept.cpp
+index 274f816..a4e7eee 100644
+--- a/libclamav/c++/llvm/lib/ExecutionEngine/JIT/Intercept.cpp
++++ b/libclamav/c++/llvm/lib/ExecutionEngine/JIT/Intercept.cpp
+@@ -19,6 +19,7 @@
+ #include "llvm/Support/ErrorHandling.h"
+ #include "llvm/System/DynamicLibrary.h"
+ #include "llvm/Config/config.h"
++#include <unistd.h>
+ using namespace llvm;
+
+ // AtExitHandlers - List of functions to call when the program exits,
+--
+1.7.8.6
+