summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2005-07-02 08:56:06 +0000
committerDoug Goldstein <cardoe@gentoo.org>2005-07-02 08:56:06 +0000
commiteeb37eb2d4c59844e8a7ff62ffeea1c6dbd8375d (patch)
treea417fb8f7118d9c53a0b74526dc91139e2cde0cd /app-admin
parentVersion bumped. This closes bug #97099. (diff)
downloadgentoo-2-eeb37eb2d4c59844e8a7ff62ffeea1c6dbd8375d.tar.gz
gentoo-2-eeb37eb2d4c59844e8a7ff62ffeea1c6dbd8375d.tar.bz2
gentoo-2-eeb37eb2d4c59844e8a7ff62ffeea1c6dbd8375d.zip
some FreeBSD fix-ups
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/gamin/ChangeLog5
-rw-r--r--app-admin/gamin/gamin-0.1.1.ebuild27
2 files changed, 15 insertions, 17 deletions
diff --git a/app-admin/gamin/ChangeLog b/app-admin/gamin/ChangeLog
index d736973594d8..2f086ec2422e 100644
--- a/app-admin/gamin/ChangeLog
+++ b/app-admin/gamin/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/gamin
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.21 2005/06/19 15:35:29 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/ChangeLog,v 1.22 2005/07/02 08:56:06 cardoe Exp $
+
+ 02 Jul 2005; Doug Goldstein <cardoe@gentoo.org> gamin-0.1.1.ebuild:
+ some FreeBSD fix-ups
*gamin-0.1.1 (19 Jun 2005)
diff --git a/app-admin/gamin/gamin-0.1.1.ebuild b/app-admin/gamin/gamin-0.1.1.ebuild
index bcb846adf0f7..ef648e86f42d 100644
--- a/app-admin/gamin/gamin-0.1.1.ebuild
+++ b/app-admin/gamin/gamin-0.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.1.ebuild,v 1.1 2005/06/19 15:35:29 dsd Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gamin/gamin-0.1.1.ebuild,v 1.2 2005/07/02 08:56:06 cardoe Exp $
inherit eutils
@@ -29,32 +29,27 @@ src_unpack() {
}
src_compile() {
-
econf \
- --enable-inotify \
- `use_enable debug` \
- `use_enable debug debug-api` \
- || die
+ $(use_enable kernel_linux inotify) \
+ $(use_enable debug) \
+ $(use_enable debug debug-api) \
+ || die "econf failed"
emake || die "emake failed"
-
}
src_install() {
-
make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog README TODO NEWS doc/*txt
-
use doc && dohtml doc/*
-
}
pkg_postinst() {
-
- einfo "It is strongly suggested you use Gamin with an inotify enabled"
- einfo "kernel for best performance. For this release of gamin you need"
- einfo "at least an inotify 0.23-6 patched kernel, gentoo-sources-2.6.12"
- einfo "provides this patch for example."
-
+ if use kernel_linux; then
+ einfo "It is strongly suggested you use Gamin with an inotify enabled"
+ einfo "kernel for best performance. For this release of gamin you need"
+ einfo "at least an inotify 0.23-6 patched kernel, gentoo-sources-2.6.12"
+ einfo "provides this patch for example."
+ fi
}