summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-09-23 15:50:58 +0000
committerJeroen Roovers <jer@gentoo.org>2013-09-23 15:50:58 +0000
commit98b6664f0f10f713f3c55929fec799880c0b8431 (patch)
tree31b343b80326b37183f3f89d60c6c80f48ac90b1 /app-admin
parentadd zeromq-3.2.4 (diff)
downloadgentoo-2-98b6664f0f10f713f3c55929fec799880c0b8431.tar.gz
gentoo-2-98b6664f0f10f713f3c55929fec799880c0b8431.tar.bz2
gentoo-2-98b6664f0f10f713f3c55929fec799880c0b8431.zip
Version bump.
(Portage version: 2.2.6/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sysstat/ChangeLog7
-rw-r--r--app-admin/sysstat/sysstat-10.1.7.ebuild80
2 files changed, 86 insertions, 1 deletions
diff --git a/app-admin/sysstat/ChangeLog b/app-admin/sysstat/ChangeLog
index 58d763b91fba..0a46f174991e 100644
--- a/app-admin/sysstat/ChangeLog
+++ b/app-admin/sysstat/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/sysstat
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.244 2013/06/09 16:56:16 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/ChangeLog,v 1.245 2013/09/23 15:50:58 jer Exp $
+
+*sysstat-10.1.7 (23 Sep 2013)
+
+ 23 Sep 2013; Jeroen Roovers <jer@gentoo.org> +sysstat-10.1.7.ebuild:
+ Version bump.
*sysstat-10.1.6 (09 Jun 2013)
diff --git a/app-admin/sysstat/sysstat-10.1.7.ebuild b/app-admin/sysstat/sysstat-10.1.7.ebuild
new file mode 100644
index 000000000000..53be64051e6c
--- /dev/null
+++ b/app-admin/sysstat/sysstat-10.1.7.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sysstat/sysstat-10.1.7.ebuild,v 1.1 2013/09/23 15:50:58 jer Exp $
+
+EAPI=5
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="System performance tools for Linux"
+HOMEPAGE="http://pagesperso-orange.fr/sebastien.godard/"
+SRC_URI="${HOMEPAGE}${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~sparc ~x86"
+IUSE="cron debug +doc isag nls lm_sensors"
+
+RDEPEND="
+ cron? ( sys-process/cronbase )
+ isag? (
+ dev-lang/tk
+ dev-vcs/rcs
+ sci-visualization/gnuplot
+ )
+ nls? ( virtual/libintl )
+ lm_sensors? ( sys-apps/lm_sensors )
+"
+DEPEND="
+ ${RDEPEND}
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i nls/
+ local lingua pofile
+ for pofile in nls/*.po; do
+ lingua=${pofile/nls\/}
+ lingua=${lingua/.po}
+ if ! has ${lingua} ${LINGUAS}; then
+ rm "nls/${lingua}.po" || die
+ fi
+ done
+ fi
+ epatch "${FILESDIR}"/${PN}-10.0.4-flags.patch
+}
+
+src_configure() {
+ tc-export AR
+ sa_lib_dir=/usr/$(get_libdir)/sa \
+ conf_dir=/etc \
+ rcdir=Gentoo-does-not-use-rc.d \
+ econf \
+ $(use_enable cron install-cron) \
+ $(use_enable debug debuginfo) \
+ $(use_enable doc documentation ) \
+ $(use_enable isag install-isag) \
+ $(use_enable lm_sensors sensors) \
+ $(use_enable nls)
+}
+
+src_compile() {
+ emake LFLAGS="${LDFLAGS}"
+}
+
+src_install() {
+ keepdir /var/log/sa
+
+ use cron && dodir /etc/cron.{daily,hourly}
+
+ emake \
+ DESTDIR="${D}" \
+ DOC_DIR=/usr/share/doc/${PF} \
+ install
+
+ dodoc contrib/sargraph/sargraph
+
+ newinitd "${FILESDIR}"/sysstat.init.d sysstat
+
+ use doc && rm -f "${D}"usr/share/doc/${PF}/COPYING
+}