summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatsuu Takuto <matsuu@gentoo.org>2011-12-04 17:11:03 +0000
committerMatsuu Takuto <matsuu@gentoo.org>2011-12-04 17:11:03 +0000
commit8ab44f946617fbe442d94d1ba6d3e41eba84f00f (patch)
treea703ec8e165217e24101e2df4f9ddc415b25fd61 /app-admin
parentAdd missing DEPEND (libX11), remove unused DEPEND (libXext). Clean up path na... (diff)
downloadgentoo-2-8ab44f946617fbe442d94d1ba6d3e41eba84f00f.tar.gz
gentoo-2-8ab44f946617fbe442d94d1ba6d3e41eba84f00f.tar.bz2
gentoo-2-8ab44f946617fbe442d94d1ba6d3e41eba84f00f.zip
multiple puppetmasters support, bug #299799. Added minimal USE flag, bug #385181.
(Portage version: 2.1.10.39/cvs/Linux x86_64)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/puppet/ChangeLog10
-rw-r--r--app-admin/puppet/files/puppetmaster-2.7.6.confd18
-rw-r--r--app-admin/puppet/files/puppetmaster-2.7.6.init34
-rw-r--r--app-admin/puppet/puppet-2.6.11.ebuild165
-rw-r--r--app-admin/puppet/puppet-2.7.6-r1.ebuild (renamed from app-admin/puppet/puppet-2.7.5.ebuild)75
5 files changed, 103 insertions, 199 deletions
diff --git a/app-admin/puppet/ChangeLog b/app-admin/puppet/ChangeLog
index c5cd4b586394..d4c40942fdd3 100644
--- a/app-admin/puppet/ChangeLog
+++ b/app-admin/puppet/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-admin/puppet
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.94 2011/11/06 13:21:43 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/ChangeLog,v 1.95 2011/12/04 17:11:02 matsuu Exp $
+
+*puppet-2.7.6-r1 (04 Dec 2011)
+
+ 04 Dec 2011; MATSUU Takuto <matsuu@gentoo.org> -puppet-2.6.11.ebuild,
+ -puppet-2.7.5.ebuild, +puppet-2.7.6-r1.ebuild,
+ +files/puppetmaster-2.7.6.confd, +files/puppetmaster-2.7.6.init:
+ multiple puppetmasters support, bug #299799. Added minimal USE flag, bug
+ #385181.
06 Nov 2011; Brent Baude <ranger@gentoo.org> puppet-2.6.12.ebuild:
Marking puppet-2.6.12 ppc for bug 388161
diff --git a/app-admin/puppet/files/puppetmaster-2.7.6.confd b/app-admin/puppet/files/puppetmaster-2.7.6.confd
new file mode 100644
index 000000000000..afecf479a6a1
--- /dev/null
+++ b/app-admin/puppet/files/puppetmaster-2.7.6.confd
@@ -0,0 +1,18 @@
+# Location of PID files
+PUPPETMASTER_PID_DIR="/var/run/puppet"
+
+# Where to log general messages to.
+# Specify syslog to send log messages to the system log.
+#PUPPETMASTER_LOG="syslog"
+
+# You may specify other parameters to the puppetmaster here
+#PUPPETMASTER_EXTRA_OPTS="--noca"
+
+# You may specify an alternate port on which puppetmaster should listen.
+# Default is: 8140
+#PUPPETMASTER_PORT="8140"
+
+# To start multiple servers:
+# # cp /etc/conf.d/puppetmaster /etc/conf.d/puppetmaster.master_8141
+# # ln -s puppetmaster /etc/init.d/puppetmaster.master_8141
+# # ${EDITOR} /etc/conf.d/puppetmaster.master_8141 (set 8141 to PUPPETMASTER_PORT)
diff --git a/app-admin/puppet/files/puppetmaster-2.7.6.init b/app-admin/puppet/files/puppetmaster-2.7.6.init
new file mode 100644
index 000000000000..05ed1eb30878
--- /dev/null
+++ b/app-admin/puppet/files/puppetmaster-2.7.6.init
@@ -0,0 +1,34 @@
+#!/sbin/runscript
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+if [ "${SVCNAME}" = "puppetmaster" ] ; then
+ PUPPETMASTER_PID="master"
+else
+ PUPPETMASTER_PID="${SVCNAME#*.}"
+fi
+pidfile="${PUPPETMASTER_PID_DIR}/${PUPPETMASTER_PID}.pid"
+
+command_args="--pidfile ${pidfile}"
+if [ -n "${PUPPETMASTER_PORT}" ] ; then
+ command_args="${command_args} --masterport ${PUPPETMASTER_PORT}"
+fi
+command_args="${command_args} ${PUPPETMASTER_EXTRA_OPTS}"
+
+command="/usr/bin/puppetmasterd"
+extra_started_commands="reload"
+
+depend() {
+ need localmount net
+ use dns logger slapd netmount nfsmount
+}
+
+start_pre() {
+ checkpath --dir --owner puppet:puppet "${PUPPETMASTER_PID_DIR}"
+}
+
+reload() {
+ ebegin "Reloading ${SVCNAME}"
+ start-stop-daemon --signal HUP --pidfile "${pidfile}"
+ eend $? "Failed to stop ${SVCNAME}"
+}
diff --git a/app-admin/puppet/puppet-2.6.11.ebuild b/app-admin/puppet/puppet-2.6.11.ebuild
deleted file mode 100644
index 952f2b4074ba..000000000000
--- a/app-admin/puppet/puppet-2.6.11.ebuild
+++ /dev/null
@@ -1,165 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.6.11.ebuild,v 1.6 2011/10/09 17:44:00 xarthisius Exp $
-
-EAPI="3"
-USE_RUBY="ruby18"
-
-RUBY_FAKEGEM_TASK_DOC=""
-RUBY_FAKEGEM_TASK_TEST="test"
-RUBY_FAKEGEM_EXTRADOC="CHANGELOG* README*"
-
-inherit elisp-common xemacs-elisp-common eutils ruby-fakegem
-
-DESCRIPTION="A system automation and configuration management software"
-HOMEPAGE="http://puppetlabs.com/"
-
-LICENSE="GPL-2"
-SLOT="0"
-IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite3 vim-syntax xemacs"
-KEYWORDS="amd64 hppa ppc sparc x86"
-
-ruby_add_rdepend "
- >=dev-ruby/facter-1.5.1
- augeas? ( dev-ruby/ruby-augeas )
- diff? ( dev-ruby/diff-lcs )
- doc? ( dev-ruby/rdoc )
- ldap? ( dev-ruby/ruby-ldap )
- shadow? ( dev-ruby/ruby-shadow )
- sqlite3? ( dev-ruby/sqlite3-ruby )
- virtual/ruby-ssl"
-# couchdb? ( dev-ruby/couchrest )
-# mongrel? ( www-servers/mongrel )
-# rack? ( >=dev-ruby/rack-1 )
-# rails? (
-# dev-ruby/rails
-# >=dev-ruby/activerecord-2.1
-# )
-# stomp? ( dev-ruby/stomp )
-
-DEPEND="${DEPEND}
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )"
-RDEPEND="${RDEPEND}
- emacs? ( virtual/emacs )
- xemacs? ( app-editors/xemacs )
- rrdtool? ( >=net-analyzer/rrdtool-1.2.23[ruby] )
- selinux? ( sys-libs/libselinux[ruby] )
- >=app-portage/eix-0.18.0"
-
-SITEFILE="50${PN}-mode-gentoo.el"
-
-pkg_setup() {
- enewgroup puppet
- enewuser puppet -1 -1 /var/lib/puppet puppet
-}
-
-all_ruby_compile() {
- all_fakegem_compile
-
- if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
- fi
-
- if use xemacs ; then
- # Create a separate version for xemacs to be able to install
- # emacs and xemacs in parallel.
- mkdir ext/xemacs || die
- cp ext/emacs/* ext/xemacs/ || die
- xemacs-elisp-compile ext/xemacs/puppet-mode.el || die "xemacs-elisp-compile failed"
- fi
-}
-
-each_fakegem_install() {
- ${RUBY} install.rb --destdir="${D}" install || die
-}
-
-all_ruby_install() {
- all_fakegem_install
-
- newinitd "${FILESDIR}"/puppetmaster.init puppetmaster || die
- doconfd conf/gentoo/conf.d/puppetmaster || die
- newinitd "${FILESDIR}"/puppet.init puppet || die
- doconfd conf/gentoo/conf.d/puppet || die
-
- # Initial configuration files
- keepdir /etc/puppet/manifests || die
- keepdir /etc/puppet/modules || die
- insinto /etc/puppet
-
- # Bug #338439
- #doins conf/gentoo/puppet/* || die
- doins conf/redhat/*.conf || die
- doins conf/auth.conf || die
-
- # Location of log and data files
- keepdir /var/run/puppet || die
- keepdir /var/log/puppet || die
- keepdir /var/lib/puppet/ssl || die
- keepdir /var/lib/puppet/facts || die
- keepdir /var/lib/puppet/files || die
- fowners -R puppet:puppet /var/{run,log,lib}/puppet || die
-
- if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el* || die "xemacs-elisp-install failed"
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
- fi
-
- if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema || die
- fi
-
- if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim || die
- insinto /usr/share/vim/vimfiles/ftplugin; doins ext/vim/ftplugin/puppet.vim || die
- insinto /usr/share/vim/vimfiles/indent; doins ext/vim/indent/puppet.vim || die
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim || die
- fi
-
- # ext and examples files
- for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}" || die
- done
- docinto conf; dodoc conf/namespaceauth.conf || die
-}
-
-pkg_postinst() {
- elog
- elog "Please, *don't* include the --ask option in EMERGE_EXTRA_OPTS as this could"
- elog "cause puppet to hang while installing packages."
- elog
- elog "Puppet uses eix to get information about currently installed packages,"
- elog "so please keep the eix metadata cache updated so puppet is able to properly"
- elog "handle package installations."
- elog
- elog "Currently puppet only supports adding and removing services to the default"
- elog "runlevel, if you want to add/remove a service from another runlevel you may"
- elog "do so using symlinking."
- elog
-
- if [ \
- -f "${EPREFIX}/etc/puppet/puppetd.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetmaster.conf" -o \
- -f "${EPREFIX}/etc/puppet/puppetca.conf" \
- ] ; then
- elog
- elog "Please remove deprecated config files."
- elog " /etc/puppet/puppetca.conf"
- elog " /etc/puppet/puppetd.conf"
- elog " /etc/puppet/puppetmasterd.conf"
- elog
- fi
-
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
-
-pkg_postrm() {
- use emacs && elisp-site-regen
- use xemacs && xemacs-elisp-site-regen
-}
diff --git a/app-admin/puppet/puppet-2.7.5.ebuild b/app-admin/puppet/puppet-2.7.6-r1.ebuild
index 3b489a0b8bb3..a972b08dcb48 100644
--- a/app-admin/puppet/puppet-2.7.5.ebuild
+++ b/app-admin/puppet/puppet-2.7.6-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.5.ebuild,v 1.1 2011/09/30 23:58:51 matsuu Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/puppet/puppet-2.7.6-r1.ebuild,v 1.1 2011/12/04 17:11:02 matsuu Exp $
-EAPI="3"
+EAPI="4"
# ruby19: dev-ruby/ruby-ldap has no ruby19
USE_RUBY="ruby18"
@@ -17,7 +17,7 @@ HOMEPAGE="http://puppetlabs.com/"
LICENSE="Apache-2.0"
SLOT="0"
-IUSE="augeas diff doc emacs ldap rrdtool selinux shadow sqlite3 vim-syntax xemacs"
+IUSE="augeas diff doc emacs ldap minimal rrdtool selinux shadow sqlite3 vim-syntax xemacs"
KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
ruby_add_rdepend "
@@ -59,72 +59,81 @@ all_ruby_compile() {
all_fakegem_compile
if use emacs ; then
- elisp-compile ext/emacs/puppet-mode.el || die "elisp-compile failed"
+ elisp-compile ext/emacs/puppet-mode.el
fi
if use xemacs ; then
# Create a separate version for xemacs to be able to install
# emacs and xemacs in parallel.
- mkdir ext/xemacs || die
- cp ext/emacs/* ext/xemacs/ || die
- xemacs-elisp-compile ext/xemacs/puppet-mode.el || die "xemacs-elisp-compile failed"
+ mkdir ext/xemacs
+ cp ext/emacs/* ext/xemacs/
+ xemacs-elisp-compile ext/xemacs/puppet-mode.el
fi
}
each_fakegem_install() {
- ${RUBY} install.rb --destdir="${D}" install || die
+ ${RUBY} install.rb --destdir="${D}" install
}
all_ruby_install() {
all_fakegem_install
- newinitd "${FILESDIR}"/puppetmaster.init puppetmaster || die
- doconfd conf/gentoo/conf.d/puppetmaster || die
- newinitd "${FILESDIR}"/puppet.init puppet || die
- doconfd conf/gentoo/conf.d/puppet || die
+ newinitd "${FILESDIR}"/puppet.init puppet
+ doconfd conf/gentoo/conf.d/puppet
# Initial configuration files
- keepdir /etc/puppet/manifests || die
- keepdir /etc/puppet/modules || die
insinto /etc/puppet
-
# Bug #338439
- #doins conf/gentoo/puppet/* || die
- doins conf/redhat/*.conf || die
- doins conf/auth.conf || die
+ #doins conf/gentoo/puppet/*
+ doins conf/redhat/puppet.conf
# Location of log and data files
- keepdir /var/run/puppet || die
- keepdir /var/log/puppet || die
- keepdir /var/lib/puppet/ssl || die
- keepdir /var/lib/puppet/facts || die
- keepdir /var/lib/puppet/files || die
- fowners -R puppet:puppet /var/{run,log,lib}/puppet || die
+ keepdir /var/{run,log}/puppet
+ fowners -R puppet:puppet /var/{run,log}/puppet
+
+ if use minimal ; then
+ rm "${ED}/usr/bin/puppetmasterd"
+ rm "${ED}/etc/puppet/auth.conf"
+ else
+ newinitd "${FILESDIR}"/puppetmaster-2.7.6.init puppetmaster
+ newconfd "${FILESDIR}"/puppetmaster-2.7.6.confd puppetmaster
+
+ insinto /etc/puppet
+ doins conf/redhat/fileserver.conf
+
+ keepdir /etc/puppet/manifests
+ keepdir /etc/puppet/modules
+
+ keepdir /var/lib/puppet/ssl
+ keepdir /var/lib/puppet/facts
+ keepdir /var/lib/puppet/files
+ fowners -R puppet:puppet /var/{run,log,lib}/puppet
+ fi
if use emacs ; then
- elisp-install ${PN} ext/emacs/puppet-mode.el* || die "elisp-install failed"
- elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ elisp-install ${PN} ext/emacs/puppet-mode.el*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
if use xemacs ; then
- xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el* || die "xemacs-elisp-install failed"
- xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}" || die
+ xemacs-elisp-install ${PN} ext/xemacs/puppet-mode.el*
+ xemacs-elisp-site-file-install "${FILESDIR}/${SITEFILE}"
fi
if use ldap ; then
- insinto /etc/openldap/schema; doins ext/ldap/puppet.schema || die
+ insinto /etc/openldap/schema; doins ext/ldap/puppet.schema
fi
if use vim-syntax ; then
- insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim || die
- insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim || die
+ insinto /usr/share/vim/vimfiles/ftdetect; doins ext/vim/ftdetect/puppet.vim
+ insinto /usr/share/vim/vimfiles/syntax; doins ext/vim/syntax/puppet.vim
fi
# ext and examples files
for f in $(find ext examples -type f) ; do
- docinto "$(dirname ${f})"; dodoc "${f}" || die
+ docinto "$(dirname ${f})"; dodoc "${f}"
done
- docinto conf; dodoc conf/namespaceauth.conf || die
+ docinto conf; dodoc conf/namespaceauth.conf
}
pkg_postinst() {