summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-01-21 17:10:40 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-01-21 17:10:40 +0000
commit7f549d060c8b3e9c2be33c0fc88af1193892d26c (patch)
tree226d47bc765f9503c43c70a9e73627cf40363a60 /app-admin
parentStable x86 && drop old (diff)
downloadgentoo-2-7f549d060c8b3e9c2be33c0fc88af1193892d26c.tar.gz
gentoo-2-7f549d060c8b3e9c2be33c0fc88af1193892d26c.tar.bz2
gentoo-2-7f549d060c8b3e9c2be33c0fc88af1193892d26c.zip
Use toolchain-funcs to get compiler name; bug #119638
(Portage version: 2.1.2-r1)
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/logrotate/ChangeLog7
-rw-r--r--app-admin/logrotate/logrotate-3.7.2.ebuild9
2 files changed, 10 insertions, 6 deletions
diff --git a/app-admin/logrotate/ChangeLog b/app-admin/logrotate/ChangeLog
index b23aa25d53a8..abc1a5d1e39c 100644
--- a/app-admin/logrotate/ChangeLog
+++ b/app-admin/logrotate/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for app-admin/logrotate
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.64 2006/12/29 17:23:57 gustavoz Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/ChangeLog,v 1.65 2007/01/21 17:10:40 dang Exp $
+
+ 21 Jan 2007; Daniel Gryniewicz <dang@gentoo.org> logrotate-3.7.2.ebuild:
+ Use toolchain-funcs to get compiler name; bug #119638
29 Dec 2006; Gustavo Zacarias <gustavoz@gentoo.org>
logrotate-3.7.2.ebuild:
diff --git a/app-admin/logrotate/logrotate-3.7.2.ebuild b/app-admin/logrotate/logrotate-3.7.2.ebuild
index 3a0e63b3bf04..20bc46e74faf 100644
--- a/app-admin/logrotate/logrotate-3.7.2.ebuild
+++ b/app-admin/logrotate/logrotate-3.7.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.2.ebuild,v 1.8 2006/12/29 17:23:57 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/logrotate/logrotate-3.7.2.ebuild,v 1.9 2007/01/21 17:10:40 dang Exp $
-inherit eutils
+inherit eutils toolchain-funcs
DESCRIPTION="Rotates, compresses, and mails system logs"
HOMEPAGE="http://www.gentoo.org"
@@ -35,7 +35,8 @@ src_unpack() {
src_compile() {
local myconf
- useq selinux && myconf='WITH_SELINUX=yes'
+ myconf="CC=$(tc-getCC)"
+ useq selinux && myconf="${myconf} WITH_SELINUX=yes"
emake ${myconf} || die "emake failed"
}