summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-28 01:13:01 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-28 01:13:01 +0000
commit102f29a03526ff89762fc29b2d96102839e274d1 (patch)
treec6ff90cc425f9fa2e9ee635114f586e68b6f91c6 /app-admin
parentMarked stable on mips. (Manifest recommit) (diff)
downloadgentoo-2-102f29a03526ff89762fc29b2d96102839e274d1.tar.gz
gentoo-2-102f29a03526ff89762fc29b2d96102839e274d1.tar.bz2
gentoo-2-102f29a03526ff89762fc29b2d96102839e274d1.zip
arm KEYWORD
Diffstat (limited to 'app-admin')
-rw-r--r--app-admin/sudo/sudo-1.6.7_p5.ebuild32
1 files changed, 15 insertions, 17 deletions
diff --git a/app-admin/sudo/sudo-1.6.7_p5.ebuild b/app-admin/sudo/sudo-1.6.7_p5.ebuild
index ed8780197273..a0fb42f828ad 100644
--- a/app-admin/sudo/sudo-1.6.7_p5.ebuild
+++ b/app-admin/sudo/sudo-1.6.7_p5.ebuild
@@ -1,39 +1,37 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.6.7_p5.ebuild,v 1.13 2004/04/25 21:42:52 agriffis Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/sudo/sudo-1.6.7_p5.ebuild,v 1.14 2004/04/28 01:13:01 vapier Exp $
+
+#
+# TODO: Fix support for krb4 and krb5
+#
DESCRIPTION="Allows certain users/groups to run commands as root"
-SRC_URI="ftp://ftp.sudo.ws/pub/sudo/${P/_/}.tar.gz"
HOMEPAGE="http://www.sudo.ws/"
+SRC_URI="ftp://ftp.sudo.ws/pub/sudo/${P/_/}.tar.gz"
-SLOT="0"
LICENSE="Sudo"
-KEYWORDS="x86 ppc sparc alpha hppa amd64 ia64 mips s390"
+SLOT="0"
+KEYWORDS="x86 ppc sparc mips alpha arm hppa amd64 ia64 s390"
IUSE="pam"
-S=${WORKDIR}/${P/_/}
DEPEND="pam? ( >=sys-libs/pam-0.73-r1 )"
-#
-# TODO: Fix support for krb4 and krb5
-#
+S=${WORKDIR}/${P/_/}
src_compile() {
- local myconf
- use pam \
- && myconf="--with-pam" \
- || myconf="--without-pam"
-
- econf --with-all-insults \
+ econf \
+ --with-all-insults \
--disable-path-info \
--with-env-editor \
- ${myconf} || die "econf failed"
+ `use_with pam` \
+ || die "econf failed"
emake || die
}
src_install() {
- einstall
- dodoc BUGS CHANGES HISTORY LICENSE PORTING README RUNSON TODO \
+ einstall || die
+ dodoc BUGS CHANGES HISTORY PORTING README RUNSON TODO \
TROUBLESHOOTING UPGRADE sample.*
insinto /etc/pam.d
doins ${FILESDIR}/sudo