summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Heim <phreak@gentoo.org>2006-09-16 15:46:45 +0000
committerChristian Heim <phreak@gentoo.org>2006-09-16 15:46:45 +0000
commitb13608e785dc3a147826845ce294c62974cda196 (patch)
treef9801349e8fd0899efa8d21dfcf0d5a63bb43a84 /app-admin/whowatch/files
parentppc stable (diff)
downloadgentoo-2-b13608e785dc3a147826845ce294c62974cda196.tar.gz
gentoo-2-b13608e785dc3a147826845ce294c62974cda196.tar.bz2
gentoo-2-b13608e785dc3a147826845ce294c62974cda196.zip
Revision bump, fixing compilation with gcc-4 (#146138, thanks to Janne Pikkarainen for the inital patch), fixing usage with gcc-3.4 (#102339, WORKSFORME with gcc-3.4.6). Also updating the ChangeLog (ChrisWhite didn't on 2005/11/06). Taking maintainership of the package.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'app-admin/whowatch/files')
-rw-r--r--app-admin/whowatch/files/digest-whowatch-1.5.22
-rw-r--r--app-admin/whowatch/files/digest-whowatch-1.5.2-r13
-rw-r--r--app-admin/whowatch/files/whowatch-1.5.2-Makefile.in.patch13
-rw-r--r--app-admin/whowatch/files/whowatch-1.5.2-gcc4.patch13
4 files changed, 31 insertions, 0 deletions
diff --git a/app-admin/whowatch/files/digest-whowatch-1.5.2 b/app-admin/whowatch/files/digest-whowatch-1.5.2
index 4109e1f1d642..9aa9d74f5a06 100644
--- a/app-admin/whowatch/files/digest-whowatch-1.5.2
+++ b/app-admin/whowatch/files/digest-whowatch-1.5.2
@@ -1 +1,3 @@
MD5 95ad3ea12b1c33e59e93c9a1ab1812d3 whowatch-1.5.2.tar.gz 51613
+RMD160 ec3ce5a72a688202a9c5bcb2e52376cfc79e1611 whowatch-1.5.2.tar.gz 51613
+SHA256 fa4d9fbb94529f2dac28c14c9cc37587754df3acc5fd69bd780fd46fafebcc9f whowatch-1.5.2.tar.gz 51613
diff --git a/app-admin/whowatch/files/digest-whowatch-1.5.2-r1 b/app-admin/whowatch/files/digest-whowatch-1.5.2-r1
new file mode 100644
index 000000000000..9aa9d74f5a06
--- /dev/null
+++ b/app-admin/whowatch/files/digest-whowatch-1.5.2-r1
@@ -0,0 +1,3 @@
+MD5 95ad3ea12b1c33e59e93c9a1ab1812d3 whowatch-1.5.2.tar.gz 51613
+RMD160 ec3ce5a72a688202a9c5bcb2e52376cfc79e1611 whowatch-1.5.2.tar.gz 51613
+SHA256 fa4d9fbb94529f2dac28c14c9cc37587754df3acc5fd69bd780fd46fafebcc9f whowatch-1.5.2.tar.gz 51613
diff --git a/app-admin/whowatch/files/whowatch-1.5.2-Makefile.in.patch b/app-admin/whowatch/files/whowatch-1.5.2-Makefile.in.patch
new file mode 100644
index 000000000000..0bb0a8689463
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.5.2-Makefile.in.patch
@@ -0,0 +1,13 @@
+diff -Nur whowatch-1.5.2/Makefile.in whowatch-1.5.2-new/Makefile.in
+--- whowatch-1.5.2/Makefile.in Sun Mar 11 15:04:41 2001
++++ whowatch-1.5.2-new/Makefile.in Thu Jun 28 09:09:27 2001
+@@ -70,7 +70,9 @@
+ rm -rf ./*.o
+ rm -f whowatch
+ install: whowatch
++ $(INSTALL) -d $(bindir)
+ $(INSTALL) -m 755 whowatch $(bindir)/whowatch
++ $(INSTALL) -d $(mandir)/man1
+ $(INSTALL) -m 644 whowatch.1 $(mandir)/man1/whowatch.1
+
+ distclean:
diff --git a/app-admin/whowatch/files/whowatch-1.5.2-gcc4.patch b/app-admin/whowatch/files/whowatch-1.5.2-gcc4.patch
new file mode 100644
index 000000000000..d731cc67968c
--- /dev/null
+++ b/app-admin/whowatch/files/whowatch-1.5.2-gcc4.patch
@@ -0,0 +1,13 @@
+Index: whowatch-1.5.2/process.c
+===================================================================
+--- whowatch-1.5.2.orig/process.c
++++ whowatch-1.5.2/process.c
+@@ -74,7 +74,7 @@ void synchronize()
+ memset(z, 0, sizeof *z);
+ check_line(l);
+ z->line = l++;
+- (struct process *) p->priv = z;
++ p->priv = z;
+ z->proc = p;
+ if (*current){
+ z->next = *current;