summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-10-15 07:22:51 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-10-15 07:22:51 +0000
commitab7fed87f95e828ca4554155bf231a36641ef67f (patch)
treec14f921a4e64253a43130799658d30c6c68ea444 /app-admin/tmpwatch
parentVersion bumped. (diff)
downloadgentoo-2-ab7fed87f95e828ca4554155bf231a36641ef67f.tar.gz
gentoo-2-ab7fed87f95e828ca4554155bf231a36641ef67f.tar.bz2
gentoo-2-ab7fed87f95e828ca4554155bf231a36641ef67f.zip
version bump (bug 189475)
(Portage version: 2.1.3.9)
Diffstat (limited to 'app-admin/tmpwatch')
-rw-r--r--app-admin/tmpwatch/ChangeLog8
-rw-r--r--app-admin/tmpwatch/files/digest-tmpwatch-2.9.11.13
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.9.11.1.ebuild39
3 files changed, 49 insertions, 1 deletions
diff --git a/app-admin/tmpwatch/ChangeLog b/app-admin/tmpwatch/ChangeLog
index 6e8eefdd22dc..e61c0558002b 100644
--- a/app-admin/tmpwatch/ChangeLog
+++ b/app-admin/tmpwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/tmpwatch
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.53 2007/03/19 02:00:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.54 2007/10/15 07:22:50 opfer Exp $
+
+*tmpwatch-2.9.11.1 (15 Oct 2007)
+
+ 15 Oct 2007; Christian Faulhammer <opfer@gentoo.org>
+ +tmpwatch-2.9.11.1.ebuild:
+ version bump (bug 189475)
19 Mar 2007; Bryan Østergaard <kloeri@gentoo.org> metadata.xml:
Remove ka0ttic from metadata.xml due to retirement.
diff --git a/app-admin/tmpwatch/files/digest-tmpwatch-2.9.11.1 b/app-admin/tmpwatch/files/digest-tmpwatch-2.9.11.1
new file mode 100644
index 000000000000..d69ac6adb139
--- /dev/null
+++ b/app-admin/tmpwatch/files/digest-tmpwatch-2.9.11.1
@@ -0,0 +1,3 @@
+MD5 e5e1c61464dcf6ab8ff6f4b7cf6facf0 tmpwatch-2.9.11-1.src.rpm 24379
+RMD160 d0a47c5975b9c9c345792dd0e5fc38fe34dcfcc9 tmpwatch-2.9.11-1.src.rpm 24379
+SHA256 95078fb550131bda331dc6fe5012c6be70a41015634d7b00897a6fce85e5bb8a tmpwatch-2.9.11-1.src.rpm 24379
diff --git a/app-admin/tmpwatch/tmpwatch-2.9.11.1.ebuild b/app-admin/tmpwatch/tmpwatch-2.9.11.1.ebuild
new file mode 100644
index 000000000000..a326f83a055c
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.9.11.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/tmpwatch-2.9.11.1.ebuild,v 1.1 2007/10/15 07:22:50 opfer Exp $
+
+inherit rpm versionator
+
+RPM_P="${PN}-$(replace_version_separator 3 '-')"
+MY_P="${RPM_P%-*}"
+
+DESCRIPTION="Utility recursively searches through specified directories and removes files which have not been accessed in a specified period of time"
+HOMEPAGE="http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/${RPM_P}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ rpm_src_unpack
+
+ cd "${S}"
+ sed -i -e "s:..RPM_OPT_FLAGS.:${CFLAGS}:" \
+ -e "s:^CVS:#CVS:g" Makefile \
+ || die "sed Makefile failed"
+ sed -i 's|/sbin/fuser|/bin/fuser|' tmpwatch.c \
+ || die "sed tmpwatch.c failed"
+ sed -i 's|/sbin|/bin|' tmpwatch.8 || die "sed tmpwatch.8 failed"
+}
+
+src_install() {
+ dosbin tmpwatch || die "dosbin failed"
+ doman tmpwatch.8 || die "doman failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}" || die 'failed to install cron'
+}