summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChristian Faulhammer <opfer@gentoo.org>2007-11-22 08:25:04 +0000
committerChristian Faulhammer <opfer@gentoo.org>2007-11-22 08:25:04 +0000
commit8d792c61bb12335b105ff8895b05be3f2547feeb (patch)
tree7736b245cb2e4853fe06aa7fb3e4f42f13f91deb /app-admin/tmpwatch
parentstable x86, security bug 197519 (diff)
downloadgentoo-2-8d792c61bb12335b105ff8895b05be3f2547feeb.tar.gz
gentoo-2-8d792c61bb12335b105ff8895b05be3f2547feeb.tar.bz2
gentoo-2-8d792c61bb12335b105ff8895b05be3f2547feeb.zip
version bump
(Portage version: 2.1.3.19)
Diffstat (limited to 'app-admin/tmpwatch')
-rw-r--r--app-admin/tmpwatch/ChangeLog8
-rw-r--r--app-admin/tmpwatch/files/digest-tmpwatch-2.9.11.23
-rw-r--r--app-admin/tmpwatch/tmpwatch-2.9.11.2.ebuild39
3 files changed, 49 insertions, 1 deletions
diff --git a/app-admin/tmpwatch/ChangeLog b/app-admin/tmpwatch/ChangeLog
index e61c0558002b..c7ae407d3140 100644
--- a/app-admin/tmpwatch/ChangeLog
+++ b/app-admin/tmpwatch/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/tmpwatch
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.54 2007/10/15 07:22:50 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/ChangeLog,v 1.55 2007/11/22 08:25:03 opfer Exp $
+
+*tmpwatch-2.9.11.2 (22 Nov 2007)
+
+ 22 Nov 2007; Christian Faulhammer <opfer@gentoo.org>
+ +tmpwatch-2.9.11.2.ebuild:
+ version bump
*tmpwatch-2.9.11.1 (15 Oct 2007)
diff --git a/app-admin/tmpwatch/files/digest-tmpwatch-2.9.11.2 b/app-admin/tmpwatch/files/digest-tmpwatch-2.9.11.2
new file mode 100644
index 000000000000..6b54967ee87b
--- /dev/null
+++ b/app-admin/tmpwatch/files/digest-tmpwatch-2.9.11.2
@@ -0,0 +1,3 @@
+MD5 6918dd3f36b950d299c6e1a12fc769df tmpwatch-2.9.11-2.src.rpm 24852
+RMD160 75f4980d25e78a297e76d9309148ce9b730e7f05 tmpwatch-2.9.11-2.src.rpm 24852
+SHA256 83459b39396234ce8b1e8848ff839049b0644df76bbc9c630bc6b6b35c8c7b30 tmpwatch-2.9.11-2.src.rpm 24852
diff --git a/app-admin/tmpwatch/tmpwatch-2.9.11.2.ebuild b/app-admin/tmpwatch/tmpwatch-2.9.11.2.ebuild
new file mode 100644
index 000000000000..aeaac6c0f85a
--- /dev/null
+++ b/app-admin/tmpwatch/tmpwatch-2.9.11.2.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/tmpwatch/tmpwatch-2.9.11.2.ebuild,v 1.1 2007/11/22 08:25:03 opfer Exp $
+
+inherit rpm versionator
+
+RPM_P="${PN}-$(replace_version_separator 3 '-')"
+MY_P="${RPM_P%-*}"
+
+DESCRIPTION="Utility recursively searches through specified directories and removes files which have not been accessed in a specified period of time"
+HOMEPAGE="http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/"
+SRC_URI="http://download.fedora.redhat.com/pub/fedora/linux/development/source/SRPMS/${RPM_P}.src.rpm"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ rpm_src_unpack
+
+ cd "${S}"
+ sed -i -e "s:..RPM_OPT_FLAGS.:${CFLAGS}:" \
+ -e "s:^CVS:#CVS:g" Makefile \
+ || die "sed Makefile failed"
+ sed -i 's|/sbin/fuser|/bin/fuser|' tmpwatch.c \
+ || die "sed tmpwatch.c failed"
+ sed -i 's|/sbin|/bin|' tmpwatch.8 || die "sed tmpwatch.8 failed"
+}
+
+src_install() {
+ dosbin tmpwatch || die "dosbin failed"
+ doman tmpwatch.8 || die "doman failed"
+
+ exeinto /etc/cron.daily
+ newexe "${FILESDIR}/${PN}.cron" "${PN}" || die 'failed to install cron'
+}