summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJosé María Alonso <nimiux@gentoo.org>2013-09-16 22:23:41 +0000
committerJosé María Alonso <nimiux@gentoo.org>2013-09-16 22:23:41 +0000
commitb9eebc41e4cd919921ffa77f05174941d6f3e420 (patch)
tree6f6895d7954ec401d09a8e780b24943174b40c61 /app-admin/mktwpol
parentInstall also unix socket support. (diff)
downloadgentoo-2-b9eebc41e4cd919921ffa77f05174941d6f3e420.tar.gz
gentoo-2-b9eebc41e4cd919921ffa77f05174941d6f3e420.tar.bz2
gentoo-2-b9eebc41e4cd919921ffa77f05174941d6f3e420.zip
Version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key D628E536)
Diffstat (limited to 'app-admin/mktwpol')
-rw-r--r--app-admin/mktwpol/ChangeLog7
-rw-r--r--app-admin/mktwpol/mktwpol-0.1.5.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/app-admin/mktwpol/ChangeLog b/app-admin/mktwpol/ChangeLog
index 66a9e17d7e4a..c66a687b203f 100644
--- a/app-admin/mktwpol/ChangeLog
+++ b/app-admin/mktwpol/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/mktwpol
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/mktwpol/ChangeLog,v 1.1 2013/09/10 21:40:15 nimiux Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mktwpol/ChangeLog,v 1.2 2013/09/16 22:23:41 nimiux Exp $
+
+*mktwpol-0.1.5 (16 Sep 2013)
+
+ 16 Sep 2013; Chema Alonso <nimiux@gentoo.org> +mktwpol-0.1.5.ebuild:
+ Version bump
*mktwpol-0.1.4 (10 Sep 2013)
diff --git a/app-admin/mktwpol/mktwpol-0.1.5.ebuild b/app-admin/mktwpol/mktwpol-0.1.5.ebuild
new file mode 100644
index 000000000000..e83f7d6b5eaf
--- /dev/null
+++ b/app-admin/mktwpol/mktwpol-0.1.5.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/mktwpol/mktwpol-0.1.5.ebuild,v 1.1 2013/09/16 22:23:41 nimiux Exp $
+
+EAPI=5
+
+DESCRIPTION="Bash scripts to create and maintain tripwire database"
+HOMEPAGE="https://sourceforge.net/projects/mktwpol"
+SRC_URI="mirror://sourceforge/mktwpol/${P}.tar.gz"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND="app-admin/tripwire"
+
+src_install() {
+
+ dosbin mktwpol.sh twsetup.sh
+ fperms 750 /usr/sbin/mktwpol.sh /usr/sbin/twsetup.sh
+
+ local d
+ for d in README* ChangeLog AUTHORS NEWS TODO CHANGES THANKS BUGS \
+ FAQ CREDITS CHANGELOG ; do
+ [[ -s "${d}" ]] && dodoc "${d}"
+ done
+}
+
+pkg_postinst() {
+ elog
+ elog "Installation and setup of tripwire ..."
+ elog " - Run: \`twsetup.sh\`"
+ elog
+ elog "Maintenance of tripwire as packages are added and/or deleted ..."
+ elog " - Run: \`mktwpol.sh -u\` to update tripwire policy"
+ elog
+}