summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimo Gurr <tgurr@gentoo.org>2009-02-28 19:44:44 +0000
committerTimo Gurr <tgurr@gentoo.org>2009-02-28 19:44:44 +0000
commit0a0b30205310765cbcb0e120a413dea7c9a57645 (patch)
tree53d18bf1a2cb7edaa6a49ab86376a04eed296719 /app-admin/keepassx
parentAdd RDEPEND (diff)
downloadgentoo-2-0a0b30205310765cbcb0e120a413dea7c9a57645.tar.gz
gentoo-2-0a0b30205310765cbcb0e120a413dea7c9a57645.tar.bz2
gentoo-2-0a0b30205310765cbcb0e120a413dea7c9a57645.zip
Version bump, fixing bug #260104. Also removing pre-stripping workaround since it's handled at eclass level now and upstream added a nostrip option, fixing bug #248711.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/keepassx')
-rw-r--r--app-admin/keepassx/ChangeLog9
-rw-r--r--app-admin/keepassx/keepassx-0.4.0_beta1.ebuild47
2 files changed, 55 insertions, 1 deletions
diff --git a/app-admin/keepassx/ChangeLog b/app-admin/keepassx/ChangeLog
index b5c06935d71e..847507c62846 100644
--- a/app-admin/keepassx/ChangeLog
+++ b/app-admin/keepassx/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for app-admin/keepassx
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.36 2009/02/01 19:20:51 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/ChangeLog,v 1.37 2009/02/28 19:44:44 tgurr Exp $
+
+*keepassx-0.4.0_beta1 (28 Feb 2009)
+
+ 28 Feb 2009; Timo Gurr <tgurr@gentoo.org> +keepassx-0.4.0_beta1.ebuild:
+ Version bump, fixing bug #260104. Also removing pre-stripping workaround
+ since it's handled at eclass level now and upstream added a nostrip
+ option, fixing bug #248711.
01 Feb 2009; nixnut <nixnut@gentoo.org> keepassx-0.3.4.ebuild:
ppc stable #256415
diff --git a/app-admin/keepassx/keepassx-0.4.0_beta1.ebuild b/app-admin/keepassx/keepassx-0.4.0_beta1.ebuild
new file mode 100644
index 000000000000..e6dfd45f57a8
--- /dev/null
+++ b/app-admin/keepassx/keepassx-0.4.0_beta1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/keepassx/keepassx-0.4.0_beta1.ebuild,v 1.1 2009/02/28 19:44:44 tgurr Exp $
+
+EAPI="2"
+
+inherit eutils qt4 versionator
+
+MY_PV=$(delete_version_separator 3)
+
+DESCRIPTION="Qt password manager compatible with its Win32 and Pocket PC versions."
+HOMEPAGE="http://keepassx.sourceforge.net/"
+SRC_URI="http://www.keepassx.org/download/KeePassX-${MY_PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug pch"
+DEPEND="|| ( ( x11-libs/qt-core:4[qt3support]
+ x11-libs/qt-gui:4[qt3support]
+ x11-libs/qt-xmlpatterns:4 )
+ ( =x11-libs/qt-4.3*:4[png,qt3support,zlib] ) )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-${MY_PV}"
+
+src_configure() {
+ local conf_add
+ use debug && conf_add="${conf_add} debug" || conf_add="${conf_add} release"
+ use pch && conf_add="${conf_add} PRECOMPILED=1" || conf_add="${conf_add} PRECOMPILED=0"
+
+ eqmake4 ${PN}.pro -recursive \
+ PREFIX="${D}/usr" \
+ CONFIG+="${conf_add}" \
+ || die "eqmake4 failed."
+}
+
+src_compile(){
+ # workaround compile failure due to distcc, bug #214327
+ PATH=${PATH/\/usr\/lib\/distcc\/bin:}
+ emake || die "emake failed"
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc changelog || die "dodoc failed"
+}