summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2011-10-25 07:18:18 +0000
committerJustin Lecher <jlec@gentoo.org>2011-10-25 07:18:18 +0000
commitb7c146dcdcf3ab96dd3772395508ed00f3ee1e06 (patch)
tree224543bfe0979eb4695ca8ab6131ea7dcbc84e3a /app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild
parentInitial import (thanks to all contributors in bug #283784). (diff)
downloadgentoo-2-b7c146dcdcf3ab96dd3772395508ed00f3ee1e06.tar.gz
gentoo-2-b7c146dcdcf3ab96dd3772395508ed00f3ee1e06.tar.bz2
gentoo-2-b7c146dcdcf3ab96dd3772395508ed00f3ee1e06.zip
Add fix for underlinking when using gold
(Portage version: 2.2.0_alpha71/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild')
-rw-r--r--app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild9
1 files changed, 7 insertions, 2 deletions
diff --git a/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild b/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild
index 02ec2778d325..d289005c93e3 100644
--- a/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild
+++ b/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild
@@ -1,12 +1,12 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild,v 1.1 2011/10/23 06:23:10 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/gnome-system-tools/gnome-system-tools-2.32.0-r1.ebuild,v 1.2 2011/10/25 07:18:17 jlec Exp $
EAPI="3"
GCONF_DEBUG="no"
GNOME2_LA_PUNT="yes"
-inherit gnome2
+inherit eutils gnome2
DESCRIPTION="Tools aimed to make easy the administration of UNIX systems"
HOMEPAGE="http://www.gnome.org/projects/gst/"
@@ -49,3 +49,8 @@ pkg_setup() {
G2CONF="${G2CONF} --disable-shares"
fi
}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gold.patch
+ gnome2_src_prepare
+}