summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2012-08-24 14:23:02 +0000
committerFabio Erculiani <lxnay@gentoo.org>2012-08-24 14:23:02 +0000
commit34bf9b50e1f8944b11b6161d86042906e6263c47 (patch)
tree10872860f05497422923fd1b13686698089d4721 /app-admin/equo
parentStable for HPPA (bug #432384). (diff)
downloadgentoo-2-34bf9b50e1f8944b11b6161d86042906e6263c47.tar.gz
gentoo-2-34bf9b50e1f8944b11b6161d86042906e6263c47.tar.bz2
gentoo-2-34bf9b50e1f8944b11b6161d86042906e6263c47.zip
version bump
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'app-admin/equo')
-rw-r--r--app-admin/equo/ChangeLog7
-rw-r--r--app-admin/equo/equo-136.ebuild43
2 files changed, 49 insertions, 1 deletions
diff --git a/app-admin/equo/ChangeLog b/app-admin/equo/ChangeLog
index b76365424bad..31e1991a7990 100644
--- a/app-admin/equo/ChangeLog
+++ b/app-admin/equo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-admin/equo
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.20 2012/07/11 18:30:41 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/ChangeLog,v 1.21 2012/08/24 14:23:02 lxnay Exp $
+
+*equo-136 (24 Aug 2012)
+
+ 24 Aug 2012; Fabio Erculiani <lxnay@gentoo.org> +equo-136.ebuild:
+ version bump
*equo-1.0_rc124 (11 Jul 2012)
diff --git a/app-admin/equo/equo-136.ebuild b/app-admin/equo/equo-136.ebuild
new file mode 100644
index 000000000000..77492fc3d7d8
--- /dev/null
+++ b/app-admin/equo/equo-136.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/equo/equo-136.ebuild,v 1.1 2012/08/24 14:23:02 lxnay Exp $
+
+EAPI=3
+PYTHON_DEPEND="2"
+inherit eutils python bash-completion-r1
+
+DESCRIPTION="Entropy Package Manager text-based client"
+HOMEPAGE="http://www.sabayon.org"
+LICENSE="GPL-2"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+SRC_URI="mirror://sabayon/sys-apps/entropy-${PV}.tar.bz2"
+
+S="${WORKDIR}/entropy-${PV}"
+
+DEPEND="~sys-apps/entropy-${PV}"
+RDEPEND="${DEPEND} sys-apps/file[python]"
+
+src_compile() {
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" LIBDIR="usr/lib" equo-install || die "make install failed"
+ newbashcomp "${S}/misc/equo-completion.bash" equo
+}
+
+pkg_postinst() {
+ python_mod_optimize "/usr/lib/entropy/client"
+ echo
+ elog "If you would like to allow users in the 'entropy' group"
+ elog "to update available package repositories, please consider"
+ elog "to install sys-apps/rigo-daemon"
+ echo
+}
+
+pkg_postrm() {
+ python_mod_cleanup "/usr/lib/entropy/client"
+}