summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-03-30 11:26:07 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-03-30 11:26:07 +0000
commit8fa083900ce2d5045aad085df92b66034ec89c2a (patch)
tree930e4a9f4bb08f0da3e38f9f21f35046e9ffdb9c /app-admin/diradm/diradm-2.9.3.ebuild
parentReadd ~ia64 keyword wrt bug 172559 (diff)
downloadgentoo-2-8fa083900ce2d5045aad085df92b66034ec89c2a.tar.gz
gentoo-2-8fa083900ce2d5045aad085df92b66034ec89c2a.tar.bz2
gentoo-2-8fa083900ce2d5045aad085df92b66034ec89c2a.zip
Bump for new upstream version, and also fix bug #172174 for IUSE.
(Portage version: 2.1.2.2)
Diffstat (limited to 'app-admin/diradm/diradm-2.9.3.ebuild')
-rw-r--r--app-admin/diradm/diradm-2.9.3.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/app-admin/diradm/diradm-2.9.3.ebuild b/app-admin/diradm/diradm-2.9.3.ebuild
new file mode 100644
index 000000000000..6138e0215d86
--- /dev/null
+++ b/app-admin/diradm/diradm-2.9.3.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/diradm/diradm-2.9.3.ebuild,v 1.1 2007/03/30 11:26:07 robbat2 Exp $
+
+inherit eutils
+
+DESCRIPTION="diradm is a nearly complete nss/shadow suite for managing POSIX users/groups/data in LDAP."
+#HOMEPAGE="http://research.iat.sfu.ca/custom-software/diradm/"
+#SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+HOMEPAGE="http://orbis-terrarum.net/~robbat2/"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~ppc64 ~ppc ~x86 ~amd64"
+IUSE="samba irixpasswd automount test"
+DEPEND="net-nds/openldap
+ sys-apps/gawk
+ sys-apps/coreutils
+ sys-apps/grep
+ dev-lang/perl
+ app-shells/bash
+ sys-apps/sed
+ virtual/perl-MIME-Base64
+ samba? (
+ dev-perl/Crypt-SmbHash
+ >=net-fs/samba-3.0.6
+ )
+ test? ( dev-perl/Crypt-SmbHash >=net-fs/samba-3.0.6 dev-util/dejagnu )"
+
+pkg_setup() {
+ if use test; then
+ if built_with_use net-nds/openldap minimal ; then
+ die "You MUST have a non-minimal build of OpenLDAP to use the testcases!"
+ fi
+ elog "Warning, for test usage, diradm is built with all optional features!"
+ fi
+}
+
+src_compile() {
+ local myconf
+ if use test; then
+ myconf="--enable-samba --enable-automount --enable-irixpasswd"
+ else
+ myconf="`use_enable samba` `use_enable automount` `use_enable irixpasswd`"
+ fi
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc CHANGES* README AUTHORS COPYING ChangeLog NEWS README.prefork THANKS TODO KNOWN-BUGS
+ if use irixpasswd; then
+ insinto /etc/openldap/schema
+ doins irixpassword.schema
+ fi
+}
+
+pkg_postinst() {
+ elog "The new diradm pulls many settings from your LDAP configuration."
+ elog "But don't forget to customize /etc/diradm.conf for other settings."
+ elog "Please see the README to instructions if you problems."
+}
+
+src_test() {
+ use test || die "You must build diradm with USE=test to run the testcases!"
+ emake -j1 check
+}