summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Shakaryan <omp@gentoo.org>2008-03-27 19:54:43 +0000
committerDavid Shakaryan <omp@gentoo.org>2008-03-27 19:54:43 +0000
commit10ec7be5284cd8e9573c0c84ee0537f6ed47304e (patch)
treea6aedd2d39bc8f4d642d060af9e9af36e347a637 /app-admin/conky
parentamd64/x86 stable, bug #214754 (diff)
downloadgentoo-2-10ec7be5284cd8e9573c0c84ee0537f6ed47304e.tar.gz
gentoo-2-10ec7be5284cd8e9573c0c84ee0537f6ed47304e.tar.bz2
gentoo-2-10ec7be5284cd8e9573c0c84ee0537f6ed47304e.zip
Version bump per request of Brenden Matthews. (bug #214330)
(Portage version: 2.1.4.4)
Diffstat (limited to 'app-admin/conky')
-rw-r--r--app-admin/conky/ChangeLog8
-rw-r--r--app-admin/conky/conky-1.5.0.ebuild136
-rw-r--r--app-admin/conky/files/conky-1.5.0-disable-x11.patch22
3 files changed, 165 insertions, 1 deletions
diff --git a/app-admin/conky/ChangeLog b/app-admin/conky/ChangeLog
index 497dcd1b4aa4..6e58922c9dec 100644
--- a/app-admin/conky/ChangeLog
+++ b/app-admin/conky/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/conky
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.68 2008/03/19 07:14:26 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/ChangeLog,v 1.69 2008/03/27 19:54:42 omp Exp $
+
+*conky-1.5.0 (27 Mar 2008)
+
+ 27 Mar 2008; David Shakaryan <omp@gentoo.org>
+ +files/conky-1.5.0-disable-x11.patch, +conky-1.5.0.ebuild:
+ Version bump per request of Brenden Matthews. (bug #214330)
19 Mar 2008; Christian Faulhammer <opfer@gentoo.org>
conky-1.4.9-r1.ebuild:
diff --git a/app-admin/conky/conky-1.5.0.ebuild b/app-admin/conky/conky-1.5.0.ebuild
new file mode 100644
index 000000000000..f4ed01de76b7
--- /dev/null
+++ b/app-admin/conky/conky-1.5.0.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/conky/conky-1.5.0.ebuild,v 1.1 2008/03/27 19:54:42 omp Exp $
+
+inherit eutils
+# used for epause
+
+DESCRIPTION="An advanced, highly configurable system monitor for X"
+HOMEPAGE="http://conky.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="audacious bmpx debug hddtemp ipv6 mpd nano-syntax rss truetype vim-syntax smapi wifi X"
+
+DEPEND_COMMON="
+ virtual/libc
+ X? (
+ x11-libs/libICE
+ x11-libs/libXext
+ x11-libs/libX11
+ x11-libs/libSM
+ x11-libs/libXrender
+ x11-libs/libXdamage
+ x11-libs/libXft
+ truetype? ( >=media-libs/freetype-2 )
+ audacious? ( >=media-sound/audacious-1.4.0 )
+ bmpx? ( media-sound/bmpx
+ >=sys-apps/dbus-0.35
+ )
+ )
+ rss? ( dev-libs/libxml2
+ net-misc/curl
+ )
+ wifi? ( net-wireless/wireless-tools )
+ !ipv6? ( >=dev-libs/glib-2.0 )"
+RDEPEND="${DEPEND_COMMON}
+ hddtemp? ( app-admin/hddtemp )
+ vim-syntax? ( || ( app-editors/vim
+ app-editors/gvim ) )
+ nano-syntax? ( app-editors/nano )"
+DEPEND="
+ ${DEPEND_COMMON}
+ X? (
+ x11-libs/libXt
+ x11-proto/xextproto
+ x11-proto/xproto
+ )"
+
+pkg_setup() {
+ if use audacious; then
+ if has_version <media-sound/audacious-1.5.0 && ! built_with_use media-sound/audacious dbus; then
+ eerror "media-sound/audacious is not built with dbus USE flag."
+ eerror "Please add 'dbus' to your USE flags, and re-emerge media-sound/audacious."
+ die "media-sound/audacious needs USE=dbus"
+ fi
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-disable-x11.patch"
+}
+
+src_compile() {
+ local mymake
+ if useq ipv6 ; then
+ ewarn "You have the ipv6 USE flag enabled. Please note that using"
+ ewarn "the ipv6 USE flag with Conky disables the port monitor."
+ epause
+ else
+ mymake="MPD_NO_IPV6=noipv6"
+ fi
+ local myconf
+ myconf="--enable-proc-uptime"
+ if useq X; then
+ myconf="${myconf} --enable-x11 --enable-double-buffer --enable-xdamage --enable-own-window"
+ myconf="${myconf} $(use_enable truetype xft)"
+ else
+ myconf="${myconf} --disable-x11 --disable-double-buffer --disable-xdamage --disable-own-window"
+ myconf="${myconf} --disable-xft"
+ fi
+ econf \
+ ${myconf} \
+ $(use_enable audacious) \
+ $(use_enable bmpx) \
+ $(use_enable debug) \
+ $(use_enable hddtemp ) \
+ $(use_enable mpd) \
+ $(use_enable rss) \
+ $(use_enable smapi) \
+ $(use_enable wifi wlan) \
+ $(use_enable !ipv6 portmon) || die "econf failed"
+ emake ${mymake} || die "compile failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc ChangeLog AUTHORS README
+ dohtml doc/docs.html doc/config_settings.html doc/variables.html
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles/ftdetect
+ doins "${S}"/extras/vim/ftdetect/conkyrc.vim
+
+ insinto /usr/share/vim/vimfiles/syntax
+ doins "${S}"/extras/vim/syntax/conkyrc.vim
+ fi
+
+ if use nano-syntax; then
+ insinto /usr/share/nano/
+ doins "${S}"/extras/nano/conky.nanorc
+ fi
+}
+
+pkg_postinst() {
+ elog "You can find the sample configuration file at"
+ elog "/etc/conky/conky.conf. To customize it, copy"
+ elog "/etc/conky/conky.conf to ~/.conkyrc and edit"
+ elog "it to your liking."
+ elog
+ elog "For more info on Conky's new features,"
+ elog "please look at the README and ChangeLog:"
+ elog "/usr/share/doc/${PF}/README.bz2"
+ elog "/usr/share/doc/${PF}/ChangeLog.bz2"
+ elog "There are also pretty html docs available"
+ elog "on Conky's site or in /usr/share/doc/${PF}"
+ elog
+ elog "Also see http://www.gentoo.org/doc/en/conky-howto.xml"
+ elog
+ elog "Vim syntax highlighting for conkyrc now enabled with"
+ elog "USE=vim-syntax, for Nano with USE=nano-syntax"
+ elog
+}
diff --git a/app-admin/conky/files/conky-1.5.0-disable-x11.patch b/app-admin/conky/files/conky-1.5.0-disable-x11.patch
new file mode 100644
index 000000000000..10fafc90d9cb
--- /dev/null
+++ b/app-admin/conky/files/conky-1.5.0-disable-x11.patch
@@ -0,0 +1,22 @@
+Index: src/conky.c
+===================================================================
+--- src/conky.c (revision 1040)
++++ src/conky.c (revision 1041)
+@@ -127,6 +127,8 @@
+ exit(0);
+ }
+
++static char *suffixes[] = { "B", "kiB", "MiB", "GiB", "TiB", "PiB", "" };
++
+ #ifdef X11
+
+ /* text size */
+@@ -164,8 +166,6 @@
+ static int font_count = -1;
+ struct font_list *fonts = NULL;
+
+-static char *suffixes[] = { "B", "kiB", "MiB", "GiB", "TiB", "PiB", "" };
+-
+ #ifdef XFT
+
+ #define font_height() (use_xft ? (fonts[selected_font].xftfont->ascent + \