summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAkinori Hattori <hattya@gentoo.org>2006-07-12 12:17:11 +0000
committerAkinori Hattori <hattya@gentoo.org>2006-07-12 12:17:11 +0000
commitb6d4d8f4f9d5c68a9b868c08906633b52934ac36 (patch)
treeba3280e5476e1ee6c3b9b15276c69e71b4c71218 /app-admin/chrootuid/chrootuid-1.3.ebuild
parentremove cruft, since 1.07 is now stable on the same arches as 1.02 was, closin... (diff)
downloadgentoo-2-b6d4d8f4f9d5c68a9b868c08906633b52934ac36.tar.gz
gentoo-2-b6d4d8f4f9d5c68a9b868c08906633b52934ac36.tar.bz2
gentoo-2-b6d4d8f4f9d5c68a9b868c08906633b52934ac36.zip
added ~ia64 keyword.
(Portage version: 2.1.1_pre2-r6)
Diffstat (limited to 'app-admin/chrootuid/chrootuid-1.3.ebuild')
-rw-r--r--app-admin/chrootuid/chrootuid-1.3.ebuild15
1 files changed, 9 insertions, 6 deletions
diff --git a/app-admin/chrootuid/chrootuid-1.3.ebuild b/app-admin/chrootuid/chrootuid-1.3.ebuild
index e9b7e6a5014a..17f1722a9b4a 100644
--- a/app-admin/chrootuid/chrootuid-1.3.ebuild
+++ b/app-admin/chrootuid/chrootuid-1.3.ebuild
@@ -1,29 +1,32 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chrootuid/chrootuid-1.3.ebuild,v 1.9 2006/04/25 16:16:31 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chrootuid/chrootuid-1.3.ebuild,v 1.10 2006/07/12 12:17:11 hattya Exp $
IUSE=""
-MY_P="${P/-/}"
+MY_P=${P/-/}
DESCRIPTION="run a network service at low privilege level and with restricted file system access"
HOMEPAGE="ftp://ftp.porcupine.org/pub/security/index.html"
SRC_URI="ftp://ftp.porcupine.org/pub/security/${MY_P}.tar.gz"
-DEPEND=">=sys-apps/sed-4"
LICENSE="BSD"
-KEYWORDS="amd64 ppc x86"
+KEYWORDS="amd64 ~ia64 ppc x86"
SLOT="0"
-S="${WORKDIR}/${MY_P}"
+S=${WORKDIR}/${MY_P}
src_compile() {
+
# Add in our own custom CFLAGS
sed -i "s/CFLAGS\t=/CFLAGS = ${CFLAGS} #/" Makefile
- emake || die "emake failed :'("
+ emake || die
+
}
src_install() {
+
dobin chrootuid
doman chrootuid.1
dodoc README chrootuid_license
+
}