summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenedikt Boehm <hollow@gentoo.org>2013-02-10 20:02:16 +0000
committerBenedikt Boehm <hollow@gentoo.org>2013-02-10 20:02:16 +0000
commitf11a5b989e937b4ad61aac5b316955e783d00b1a (patch)
tree95f83d8fbc7b034b75b2db718d3151b23cf59019 /app-admin/chef-expander
parentversion bump (diff)
downloadgentoo-2-f11a5b989e937b4ad61aac5b316955e783d00b1a.tar.gz
gentoo-2-f11a5b989e937b4ad61aac5b316955e783d00b1a.tar.bz2
gentoo-2-f11a5b989e937b4ad61aac5b316955e783d00b1a.zip
version bump
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'app-admin/chef-expander')
-rw-r--r--app-admin/chef-expander/ChangeLog10
-rw-r--r--app-admin/chef-expander/chef-expander-10.20.0.ebuild50
-rw-r--r--app-admin/chef-expander/files/initd/chef-expander17
3 files changed, 69 insertions, 8 deletions
diff --git a/app-admin/chef-expander/ChangeLog b/app-admin/chef-expander/ChangeLog
index 211a6f6885e3..12a668cf6676 100644
--- a/app-admin/chef-expander/ChangeLog
+++ b/app-admin/chef-expander/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/chef-expander
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-expander/ChangeLog,v 1.10 2012/12/27 07:07:17 hollow Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-expander/ChangeLog,v 1.11 2013/02/10 20:02:16 hollow Exp $
+
+*chef-expander-10.20.0 (10 Feb 2013)
+
+ 10 Feb 2013; Benedikt Böhm <hollow@gentoo.org>
+ +chef-expander-10.20.0.ebuild, files/initd/chef-expander:
+ version bump
*chef-expander-10.16.4 (27 Dec 2012)
diff --git a/app-admin/chef-expander/chef-expander-10.20.0.ebuild b/app-admin/chef-expander/chef-expander-10.20.0.ebuild
new file mode 100644
index 000000000000..9ccf08c2ce93
--- /dev/null
+++ b/app-admin/chef-expander/chef-expander-10.20.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/chef-expander/chef-expander-10.20.0.ebuild,v 1.1 2013/02/10 20:02:16 hollow Exp $
+
+EAPI=4
+USE_RUBY="ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+RUBY_FAKEGEM_TASK_TEST="spec"
+
+RUBY_FAKEGEM_EXTRADOC="README.rdoc"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Configuration management tool"
+HOMEPAGE="http://wiki.opscode.com/display/chef"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# specs require a live rabbitmq server
+RESTRICT="test"
+
+ruby_add_rdepend "~app-admin/chef-${PV}
+ >=dev-ruby/amqp-0.6.7
+ <dev-ruby/amqp-0.7
+ >=dev-ruby/bunny-0.6.0
+ >=dev-ruby/em-http-request-0.2.11
+ <dev-ruby/em-http-request-0.3
+ >=dev-ruby/eventmachine-0.12.10
+ >=dev-ruby/fast_xs-0.7.3
+ >=dev-ruby/highline-1.6.1
+ <dev-ruby/highline-1.7
+ >=dev-ruby/mixlib-log-1.2.0
+ >=dev-ruby/uuidtools-2.1.1
+ <dev-ruby/uuidtools-2.2
+ >=dev-ruby/yajl-ruby-1.0
+ <dev-ruby/yajl-ruby-2"
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doinitd "${FILESDIR}/initd/chef-expander"
+ doconfd "${FILESDIR}/confd/chef-expander"
+
+ keepdir /etc/chef /var/{lib,log,run}/chef
+ fowners chef:chef /var/{lib,log,run}/chef
+}
diff --git a/app-admin/chef-expander/files/initd/chef-expander b/app-admin/chef-expander/files/initd/chef-expander
index 11befdfb5aea..651f7c8eec19 100644
--- a/app-admin/chef-expander/files/initd/chef-expander
+++ b/app-admin/chef-expander/files/initd/chef-expander
@@ -1,22 +1,27 @@
#!/sbin/runscript
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
CHEF_EXPANDER_LOGFILE=${CHEF_EXPANDER_LOGFILE:-/var/log/chef/expander.log}
CONFIGFILE=${CONFIGFILE:-/etc/chef/solr.rb}
+CHEF_USER=${CHEF_USER:-chef}
+CHEF_GROUP=${CHEF_GROUP:-chef}
pidfile=${CHEF_EXPANDER_PIDFILE:-/var/run/chef/expander.pid}
command=${CHEF_EXPANDER_BINARY:-/usr/bin/chef-expander}
command_args="-d -P ${pidfile} -L ${CHEF_EXPANDER_LOGFILE} -c ${CONFIGFILE} ${CHEF_EXPANDER_OPTS}"
-
-user=${CHEF_USER:-chef}
-group=${CHEF_GROUP:-chef}
+start_stop_daemon_args="--user ${CHEF_USER} --group ${CHEF_GROUP}"
depend() {
need net chef-solr
}
start_pre() {
- checkpath -q -d -m 0750 -o ${user}:${group} /etc/chef /var/{lib,log,run}/chef
- checkpath -q -f -m 0600 ${CONFIGFILE}
+ checkpath -q -d -m 0750 -o ${CHEF_USER}:${CHEF_GROUP} \
+ /etc/chef \
+ /etc/chef/certificates \
+ /var/{lib,log,run}/chef
+
+ checkpath -q -f -m 0600 -o ${CHEF_USER}:${CHEF_GROUP} \
+ ${CONFIGFILE}
}