summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Ahlberg <aliz@gentoo.org>2002-10-21 09:27:18 +0000
committerDaniel Ahlberg <aliz@gentoo.org>2002-10-21 09:27:18 +0000
commitd16ce11c67543655ce4aa85949a8fe1067c87c13 (patch)
treee5d2220a0a3bd594984f3b2083673e1a610f4474 /app-admin/aide
parentgcc3.2 fix (diff)
downloadgentoo-2-d16ce11c67543655ce4aa85949a8fe1067c87c13.tar.gz
gentoo-2-d16ce11c67543655ce4aa85949a8fe1067c87c13.tar.bz2
gentoo-2-d16ce11c67543655ce4aa85949a8fe1067c87c13.zip
Version bump.
Diffstat (limited to 'app-admin/aide')
-rw-r--r--app-admin/aide/ChangeLog8
-rw-r--r--app-admin/aide/aide-0.9.ebuild55
-rw-r--r--app-admin/aide/files/digest-aide-0.91
3 files changed, 63 insertions, 1 deletions
diff --git a/app-admin/aide/ChangeLog b/app-admin/aide/ChangeLog
index 99ac9442bb41..9c3d426f0ef6 100644
--- a/app-admin/aide/ChangeLog
+++ b/app-admin/aide/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for app-admin/aide
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/ChangeLog,v 1.4 2002/08/13 19:25:20 pvdabeel Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/ChangeLog,v 1.5 2002/10/21 09:27:18 aliz Exp $
+
+*aide-0.9 (21 Oct 2002)
+
+ 21 Oct 2002; Daniel Ahlberg <aliz@gentoo.org> :
+ Version bump. Found by Joshua Brindle <jbrindle@snu.edu> in #5372.
+ Also contains updates from Paul Belt <gaarde@yahoo.com> in #5372.
*aide-0.8 (15 Mar 2002)
diff --git a/app-admin/aide/aide-0.9.ebuild b/app-admin/aide/aide-0.9.ebuild
new file mode 100644
index 000000000000..d2c41cb05874
--- /dev/null
+++ b/app-admin/aide/aide-0.9.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-admin/aide/aide-0.9.ebuild,v 1.1 2002/10/21 09:27:18 aliz Exp $
+
+IUSE="nls postgres zlib crypt"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="AIDE (Advanced Intrusion Detection Environment) is a free replacement for Tripwire"
+HOMEPAGE="http://www.cs.tut.fi/~rammer/aide.html"
+SRC_URI="http://www.cs.tut.fi/~rammer/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="sys-apps/gzip
+ sys-devel/bison
+ sys-devel/flex
+ dev-libs/libgcrypt
+ app-crypt/mhash
+ crypt? ( dev-libs/libgcrypt )
+ postgres? ( dev-db/postgresql )"
+
+RDEPEND=""
+
+src_compile() {
+
+ local myconf
+ use postgres && myconf="${myconf} --with-psql"
+ use nls && myconf="${myconf} --with-locale"
+ use zlib && myconf="${myconf} --with-zlib"
+ use crypt && myconf="${myconf} --with-gcrypt"
+
+
+ econf \
+ --with-zlib \
+ --sysconfdir=/etc/aide \
+ --with-mhash \
+ --with-extra-lib=/usr/lib \
+ ${myconf} || die
+
+ emake || die
+}
+
+src_install() {
+
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
+
+ dodir /etc/aide
+ cp doc/aide.conf ${D}/etc/aide
+
+ dodoc AUTHORS COPYING INSTALL NEWS README
+ dohtml doc/manual.html
+
+}
diff --git a/app-admin/aide/files/digest-aide-0.9 b/app-admin/aide/files/digest-aide-0.9
new file mode 100644
index 000000000000..3a1ad78d9d33
--- /dev/null
+++ b/app-admin/aide/files/digest-aide-0.9
@@ -0,0 +1 @@
+MD5 877b1f515a9e25afda75e06805d687fb aide-0.9.tar.gz 216096