summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2010-10-13 21:10:23 +0000
committerWilliam Hubbs <williamh@gentoo.org>2010-10-13 21:10:23 +0000
commited27e44f3dc27a2c3fb7e6087bcc5f0405c77220 (patch)
treed0a8a510c6b199bfd66eb0ab478862f997f6cbb4 /app-accessibility
parentUnset dbus env variable to fix pyatspi module detection. (diff)
downloadgentoo-2-ed27e44f3dc27a2c3fb7e6087bcc5f0405c77220.tar.gz
gentoo-2-ed27e44f3dc27a2c3fb7e6087bcc5f0405c77220.tar.bz2
gentoo-2-ed27e44f3dc27a2c3fb7e6087bcc5f0405c77220.zip
version bump
(Portage version: 2.2_rc91/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speakup/ChangeLog7
-rw-r--r--app-accessibility/speakup/speakup-3.1.6.ebuild67
2 files changed, 73 insertions, 1 deletions
diff --git a/app-accessibility/speakup/ChangeLog b/app-accessibility/speakup/ChangeLog
index c1234535b129..2aec27d13ab4 100644
--- a/app-accessibility/speakup/ChangeLog
+++ b/app-accessibility/speakup/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for app-accessibility/speakup
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.45 2010/06/29 14:26:42 williamh Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/ChangeLog,v 1.46 2010/10/13 21:10:23 williamh Exp $
+
+*speakup-3.1.6 (13 Oct 2010)
+
+ 13 Oct 2010; William Hubbs <williamh@gentoo.org> +speakup-3.1.6.ebuild:
+ version bump
29 Jun 2010; William Hubbs <williamh@gentoo.org> speakup-9999.ebuild:
Speakup now requires at least kernel 2.6.26.
diff --git a/app-accessibility/speakup/speakup-3.1.6.ebuild b/app-accessibility/speakup/speakup-3.1.6.ebuild
new file mode 100644
index 000000000000..5fb1a3d0273e
--- /dev/null
+++ b/app-accessibility/speakup/speakup-3.1.6.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speakup/speakup-3.1.6.ebuild,v 1.1 2010/10/13 21:10:23 williamh Exp $
+
+EAPI="2"
+
+inherit linux-mod
+
+DESCRIPTION="The speakup linux kernel based screen reader."
+HOMEPAGE="http://linux-speakup.org"
+SRC_URI="ftp://linux-speakup.org/pub/speakup/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="modules"
+
+MODULE_NAMES="speakup(${PN}:\"${S}\"/src)
+ speakup_acntpc(${PN}:\"${S}\"/src)
+ speakup_acntsa(${PN}:\"${S}\"/src)
+ speakup_apollo(${PN}:\"${S}\"/src)
+ speakup_audptr(${PN}:\"${S}\"/src)
+ speakup_bns(${PN}:\"${S}\"/src)
+ speakup_decext(${PN}:\"${S}\"/src)
+ speakup_decpc(${PN}:\"${S}\"/src)
+ speakup_dectlk(${PN}:\"${S}\"/src)
+ speakup_dtlk(${PN}:\"${S}\"/src)
+ speakup_dummy(${PN}:\"${S}\"/src)
+ speakup_keypc(${PN}:\"${S}\"/src)
+ speakup_ltlk(${PN}:\"${S}\"/src)
+ speakup_soft(${PN}:\"${S}\"/src)
+ speakup_spkout(${PN}:\"${S}\"/src)
+ speakup_txprt(${PN}:\"${S}\"/src)"
+BUILD_PARAMS="KERNELDIR=${KERNEL_DIR}"
+BUILD_TARGETS="clean all"
+
+src_prepare() {
+ use modules && cmd=die || cmd=ewarn
+ if kernel_is lt 2 6 26 -o kernel_is gt 2 6 35; then
+ $cmd "Speakup ${PV} requires linux 2.6.26 through 2.6.35"
+ fi
+}
+
+src_compile() {
+ use modules && linux-mod_src_compile
+}
+
+src_install() {
+ use modules && linux-mod_src_install
+ dobin tools/speakupconf
+ dosbin tools/talkwith
+ dodoc Bugs.txt README To-Do doc/DefaultKeyAssignments doc/spkguide.txt
+ newdoc tools/README README.tools
+}
+
+pkg_postinst() {
+ use modules && linux-mod_pkg_postinst
+
+ elog "You must set up the speech synthesizer driver to be loaded"
+ elog "automatically in order for your system to start speaking"
+ elog "when it is booted."
+ if has_version "<sys-apps/baselayout-2"; then
+ elog "this is done via /etc/modules.autoload.d/kernel-2.6"
+ else
+ elog "This is done via /etc/conf.d/modules."
+ fi
+}