summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-02-09 03:18:23 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-02-09 03:18:23 +0000
commit71b6ca6f16902255a4bacd7ad558e30beb768964 (patch)
tree72d23aee17eb7135607c6368b17c9f4f7bd5c39a /app-accessibility
parentAutomated update of use.local.desc (diff)
downloadgentoo-2-71b6ca6f16902255a4bacd7ad558e30beb768964.tar.gz
gentoo-2-71b6ca6f16902255a4bacd7ad558e30beb768964.tar.bz2
gentoo-2-71b6ca6f16902255a4bacd7ad558e30beb768964.zip
Add back the HTS voices, thanks to garlicbread@ntlworld.com for the patch.
Also add back the MultiSyn engine. This closes bug #211214. (Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/festival/ChangeLog13
-rw-r--r--app-accessibility/festival/festival-1.96_beta-r1.ebuild166
-rw-r--r--app-accessibility/festival/files/festival-1.96_beta-hts-voices.patch100
-rw-r--r--app-accessibility/festival/files/speech-tools-1.2.96_beta-gcc43-include.patch22
4 files changed, 299 insertions, 2 deletions
diff --git a/app-accessibility/festival/ChangeLog b/app-accessibility/festival/ChangeLog
index 9fc978b64d9c..3c20b11116e3 100644
--- a/app-accessibility/festival/ChangeLog
+++ b/app-accessibility/festival/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for app-accessibility/festival
-# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.81 2008/11/23 17:44:11 patrick Exp $
+# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/ChangeLog,v 1.82 2009/02/09 03:18:23 williamh Exp $
+
+*festival-1.96_beta-r1 (09 Feb 2009)
+
+ 09 Feb 2009; William Hubbs <williamh@gentoo.org>
+ +files/speech-tools-1.2.96_beta-gcc43-include.patch,
+ +files/festival-1.96_beta-hts-voices.patch, +festival-1.96_beta-r1.ebuild:
+ Add back the HTS voices, thanks to garlicbread@ntlworld.com for the patch.
+ Also add back the MultiSyn engine.
+ This closes bug #211214.
23 Nov 2008; Patrick Lauer <patrick@gentoo.org> festival-1.96_beta.ebuild:
Fixing homepage to point directly at the actual project page.
diff --git a/app-accessibility/festival/festival-1.96_beta-r1.ebuild b/app-accessibility/festival/festival-1.96_beta-r1.ebuild
new file mode 100644
index 000000000000..93e3fff36ace
--- /dev/null
+++ b/app-accessibility/festival/festival-1.96_beta-r1.ebuild
@@ -0,0 +1,166 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/festival/festival-1.96_beta-r1.ebuild,v 1.1 2009/02/09 03:18:23 williamh Exp $
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Festival Text to Speech engine"
+HOMEPAGE="http://www.cstr.ed.ac.uk/projects/festival/"
+SITE="http://www.festvox.org/packed/festival/latest"
+MY_P=${PN}-1.96-beta
+SRC_URI="${SITE}/${MY_P}.tar.gz
+ ${SITE}/festlex_CMU.tar.gz
+ ${SITE}/festlex_OALD.tar.gz
+ ${SITE}/festlex_POSLEX.tar.gz
+ ${SITE}/festvox_cmu_us_awb_arctic_hts.tar.gz
+ ${SITE}/festvox_cmu_us_bdl_arctic_hts.tar.gz
+ ${SITE}/festvox_cmu_us_jmk_arctic_hts.tar.gz
+ ${SITE}/festvox_cmu_us_slt_arctic_hts.tar.gz
+ ${SITE}/festvox_kallpc16k.tar.gz
+ ${SITE}/festvox_kedlpc16k.tar.gz
+ ${SITE}/speech_tools-1.2.96-beta.tar.gz
+ mbrola? (
+ ${SITE}/festvox_us1.tar.gz
+ ${SITE}/festvox_us2.tar.gz
+ ${SITE}/festvox_us3.tar.gz )"
+LICENSE="FESTIVAL BSD as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="alsa mbrola"
+
+SP_DEPEND=">=app-accessibility/speech-tools-1.2.96_beta"
+
+DEPEND="${SP_DEPEND}
+ alsa? ( media-sound/alsa-utils )"
+RDEPEND="${SP_DEPEND}
+ mbrola? ( >=app-accessibility/mbrola-3.0.1h-r2 )"
+
+S=${WORKDIR}/festival
+
+pkg_setup() {
+ enewuser festival -1 -1 -1 audio
+}
+
+src_unpack() {
+ unpack ${A}
+
+ # tell festival to use the speech-tools we have installed.
+ sed -i -e "s:\(EST=\).*:\1/usr/share/speech-tools:" "${S}"/config/config.in
+ sed -i -e "s:\$(EST)/lib:/usr/$(get_libdir):" "${S}"/config/project.mak
+
+ # copy what we need for MultiSyn from speech_tools.
+ cp -pr "${WORKDIR}"/speech_tools/base_class "${S}"/src/modules/MultiSyn
+
+ # fix the reference to /usr/lib/festival
+ sed -i -e "s:\(FTLIBDIR.*=.*\)\$.*:\1/usr/share/festival:" "${S}"/config/project.mak
+
+ # Fix path for examples in festival.scm
+ sed -i -e "s:\.\./examples/:/usr/share/doc/${PF}/examples/:" "${S}"/lib/festival.scm
+
+ # Fix the HTS voices.
+ epatch "${FILESDIR}"/${P}-hts-voices.patch
+
+ # patch init.scm to look for siteinit.scm and sitevars.scm in /etc/festival
+ epatch "${FILESDIR}"/${P}-init-scm.patch
+
+ # Apply patches for gcc4.3.
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ epatch "${FILESDIR}"/speech-tools-1.2.96_beta-gcc43-include.patch
+
+ if use alsa; then
+ echo "(Parameter.set 'Audio_Command \"aplay -q -c 1 -t raw -f s16 -r \$SR \$FILE\")" >> ${S}/lib/siteinit.scm
+ echo "(Parameter.set 'Audio_Method 'Audio_Command)" >> ${S}/lib/siteinit.scm
+ fi
+}
+
+src_compile() {
+ econf || die
+ emake -j1 PROJECT_LIBDEPS="" REQUIRED_LIBDEPS="" LOCAL_LIBDEPS="" OPTIMISE_CXXFLAGS="${CXXFLAGS}" OPTIMISE_CCFLAGS="${CFLAGS}" CC="$(tc-getCC)" CXX="$(tc-getCXX)" || die
+}
+
+src_install() {
+ # Install the binaries
+ dobin src/main/festival
+ dobin lib/etc/*Linux*/audsp
+ dolib.a src/lib/libFestival.a
+
+ # Install the main libraries
+ insinto /usr/share/festival
+ doins -r lib/*
+
+ # Install the examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+
+ # Need to fix saytime, etc. to look for festival in the correct spot
+ for ex in "${D}"/usr/share/doc/${PF}/examples/*.sh; do
+ exnoext=${ex%%.sh}
+ chmod a+x "${exnoext}"
+ dosed "s:${S}/bin/festival:/usr/bin/festival:" "${exnoext##$D}"
+ done
+
+ # Install the header files
+ insinto /usr/include/festival
+ doins src/include/*.h
+
+ insinto /etc/festival
+ # Sample server.scm configuration for the server
+ doins "${FILESDIR}"/server.scm
+ doins lib/site*
+
+ # Install the init script
+ newinitd "${FILESDIR}"/festival.rc festival
+
+ # Install the docs
+ dodoc "${S}"/{ACKNOWLEDGMENTS,NEWS,README}
+ doman "${S}"/doc/{festival.1,festival_client.1}
+
+ # create the directory where our log file will go.
+ diropts -m 0755 -o festival -g audio
+ keepdir /var/log/festival
+
+ use mbrola && mbrola_voices
+}
+
+pkg_postinst() {
+ elog
+ elog " Useful examples include saytime, text2wave. For example, try:"
+ elog " \"/usr/share/doc/${PF}/examples/saytime\""
+ elog
+ elog " Or for something more fun:"
+ elog ' "echo "Gentoo can speak" | festival --tts"'
+ elog
+ elog " To enable the festival server at boot, run"
+ elog " rc-update add festival default"
+ elog
+ elog " You must setup the server's port, access list, etc in this file:"
+ elog " /etc/festival/server.scm"
+ elog
+ elog "This version also allows configuration of site specific"
+ elog "initialization in /etc/festival/siteinit.scm and"
+ elog "variables in /etc/festival/sitevars.scm."
+ elog
+}
+
+# Fix mbrola databases: create symbolic links from festival voices
+# directories to MBROLA install dirs.
+mbrola_voices() {
+
+ # This is in case there is no mbrola voice for a particular language.
+ local shopts=$(shopt -p nullglob)
+ shopt -s nullglob
+
+ # This assumes all mbrola voices are named after the voices defined
+ # in MBROLA, i.e. if MBROLA contains a voice fr1, then the Festival
+ # counterpart should be named fr1_mbrola.
+ for language in "${S}"/lib/voices/*; do
+ for mvoice in ${language}/*_mbrola; do
+ voice=${mvoice##*/}
+ database=${voice%%_mbrola}
+ dosym /opt/mbrola/${database} /usr/share/festival/voices/${language##*/}/${voice}/${database}
+ done
+ done
+
+ # Restore shopts
+ ${shopts}
+}
diff --git a/app-accessibility/festival/files/festival-1.96_beta-hts-voices.patch b/app-accessibility/festival/files/festival-1.96_beta-hts-voices.patch
new file mode 100644
index 000000000000..9ed1ac38711d
--- /dev/null
+++ b/app-accessibility/festival/files/festival-1.96_beta-hts-voices.patch
@@ -0,0 +1,100 @@
+diff -Naur festival.orig/lib/voices/us/cmu_us_awb_arctic_hts/festvox/cmu_us_awb_arctic_f0model.scm festival/lib/voices/us/cmu_us_awb_arctic_hts/festvox/cmu_us_awb_arctic_f0model.scm
+--- festival.orig/lib/voices/us/cmu_us_awb_arctic_hts/festvox/cmu_us_awb_arctic_f0model.scm 2003-08-01 15:12:59.000000000 +0100
++++ festival/lib/voices/us/cmu_us_awb_arctic_hts/festvox/cmu_us_awb_arctic_f0model.scm 2009-01-28 21:34:30.000000000 +0000
+@@ -35,7 +35,7 @@
+ ;;;
+
+ ;;; Load any necessary files here
+-;(require 'f2bf0lr)
++(require 'f2bf0lr)
+ (require 'cmu_us_awb_arctic_f0clunits)
+
+ (set! cmu_us_awb_arctic_int_lr_params
+diff -Naur festival.orig/lib/voices/us/cmu_us_awb_arctic_hts/festvox/cmu_us_awb_arctic_hts.scm festival/lib/voices/us/cmu_us_awb_arctic_hts/festvox/cmu_us_awb_arctic_hts.scm
+--- festival.orig/lib/voices/us/cmu_us_awb_arctic_hts/festvox/cmu_us_awb_arctic_hts.scm 2004-06-07 08:50:56.000000000 +0100
++++ festival/lib/voices/us/cmu_us_awb_arctic_hts/festvox/cmu_us_awb_arctic_hts.scm 2009-01-28 21:33:58.000000000 +0000
+@@ -115,12 +115,12 @@
+ (list "-md" (path-append hts_data_dir "duration.pdf"))
+ (list "-mm" (path-append hts_data_dir "mcep.pdf"))
+ (list "-mf" (path-append hts_data_dir "lf0.pdf"))
+- '("-a" " 0.420000")
+- '("-r" " 0.000000")
+- '("-fs" "1.000000")
+- '("-fm" "0.000000")
+- '("-u" " 0.500000")
+- '("-l" " 0.000000")
++ '("-a" 0.420000)
++ '("-r" 0.000000)
++ '("-fs" 1.000000)
++ '("-fm" 0.000000)
++ '("-u" 0.500000)
++ '("-l" 0.000000)
+ ))
+
+ ;; This function is called to setup a voice. It will typically
+diff -Naur festival.orig/lib/voices/us/cmu_us_bdl_arctic_hts/festvox/cmu_us_bdl_arctic_hts.scm festival/lib/voices/us/cmu_us_bdl_arctic_hts/festvox/cmu_us_bdl_arctic_hts.scm
+--- festival.orig/lib/voices/us/cmu_us_bdl_arctic_hts/festvox/cmu_us_bdl_arctic_hts.scm 2004-06-07 07:29:03.000000000 +0100
++++ festival/lib/voices/us/cmu_us_bdl_arctic_hts/festvox/cmu_us_bdl_arctic_hts.scm 2009-01-28 21:33:58.000000000 +0000
+@@ -115,12 +115,12 @@
+ (list "-md" (path-append hts_data_dir "duration.pdf"))
+ (list "-mm" (path-append hts_data_dir "mcep.pdf"))
+ (list "-mf" (path-append hts_data_dir "lf0.pdf"))
+- '("-a" " 0.420000")
+- '("-r" " 0.000000")
+- '("-fs" "1.000000")
+- '("-fm" "0.000000")
+- '("-u" " 0.500000")
+- '("-l" " 0.000000")
++ '("-a" 0.420000)
++ '("-r" 0.000000)
++ '("-fs" 1.000000)
++ '("-fm" 0.000000)
++ '("-u" 0.500000)
++ '("-l" 0.000000)
+ ))
+
+ ;; This function is called to setup a voice. It will typically
+diff -Naur festival.orig/lib/voices/us/cmu_us_jmk_arctic_hts/festvox/cmu_us_jmk_arctic_hts.scm festival/lib/voices/us/cmu_us_jmk_arctic_hts/festvox/cmu_us_jmk_arctic_hts.scm
+--- festival.orig/lib/voices/us/cmu_us_jmk_arctic_hts/festvox/cmu_us_jmk_arctic_hts.scm 2004-06-07 06:59:22.000000000 +0100
++++ festival/lib/voices/us/cmu_us_jmk_arctic_hts/festvox/cmu_us_jmk_arctic_hts.scm 2009-01-28 21:33:58.000000000 +0000
+@@ -115,12 +115,12 @@
+ (list "-md" (path-append hts_data_dir "duration.pdf"))
+ (list "-mm" (path-append hts_data_dir "mcep.pdf"))
+ (list "-mf" (path-append hts_data_dir "lf0.pdf"))
+- '("-a" " 0.420000")
+- '("-r" " 0.000000")
+- '("-fs" "1.000000")
+- '("-fm" "0.000000")
+- '("-u" " 0.500000")
+- '("-l" " 0.000000")
++ '("-a" 0.420000)
++ '("-r" 0.000000)
++ '("-fs" 1.000000)
++ '("-fm" 0.000000)
++ '("-u" 0.500000)
++ '("-l" 0.000000)
+ ))
+
+ ;; This function is called to setup a voice. It will typically
+diff -Naur festival.orig/lib/voices/us/cmu_us_slt_arctic_hts/festvox/cmu_us_slt_arctic_hts.scm festival/lib/voices/us/cmu_us_slt_arctic_hts/festvox/cmu_us_slt_arctic_hts.scm
+--- festival.orig/lib/voices/us/cmu_us_slt_arctic_hts/festvox/cmu_us_slt_arctic_hts.scm 2004-06-07 04:54:46.000000000 +0100
++++ festival/lib/voices/us/cmu_us_slt_arctic_hts/festvox/cmu_us_slt_arctic_hts.scm 2009-01-28 21:33:58.000000000 +0000
+@@ -115,12 +115,12 @@
+ (list "-md" (path-append hts_data_dir "duration.pdf"))
+ (list "-mm" (path-append hts_data_dir "mcep.pdf"))
+ (list "-mf" (path-append hts_data_dir "lf0.pdf"))
+- '("-a" " 0.420000")
+- '("-r" " 0.000000")
+- '("-fs" "1.000000")
+- '("-fm" "0.000000")
+- '("-u" " 0.500000")
+- '("-l" " 0.000000")
++ '("-a" 0.420000)
++ '("-r" 0.000000)
++ '("-fs" 1.000000)
++ '("-fm" 0.000000)
++ '("-u" 0.500000)
++ '("-l" 0.000000)
+ ))
+
+ ;; This function is called to setup a voice. It will typically
diff --git a/app-accessibility/festival/files/speech-tools-1.2.96_beta-gcc43-include.patch b/app-accessibility/festival/files/speech-tools-1.2.96_beta-gcc43-include.patch
new file mode 100644
index 000000000000..6ab7ebf56614
--- /dev/null
+++ b/app-accessibility/festival/files/speech-tools-1.2.96_beta-gcc43-include.patch
@@ -0,0 +1,22 @@
+diff -Naur speech_tools-orig/base_class/EST_TSimpleMatrix.cc speech_tools/base_class/EST_TSimpleMatrix.cc
+--- speech_tools-orig/base_class/EST_TSimpleMatrix.cc 2004-09-30 06:53:35.000000000 -0600
++++ speech_tools/base_class/EST_TSimpleMatrix.cc 2008-01-05 11:00:07.000000000 -0600
+@@ -42,6 +42,7 @@
+
+ #include "EST_TSimpleMatrix.h"
+ #include "EST_TVector.h"
++#include <cstring>
+ #include <fstream>
+ #include <iostream>
+ #include "EST_cutils.h"
+diff -Naur speech_tools-orig/base_class/EST_TSimpleVector.cc speech_tools/base_class/EST_TSimpleVector.cc
+--- speech_tools-orig/base_class/EST_TSimpleVector.cc 2006-07-06 06:57:18.000000000 -0600
++++ speech_tools/base_class/EST_TSimpleVector.cc 2008-01-05 11:00:32.000000000 -0600
+@@ -42,6 +42,7 @@
+
+ #include "EST_TSimpleVector.h"
+ #include "EST_matrix_support.h"
++#include <cstring>
+ #include <fstream>
+ #include "EST_cutils.h"
+