summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Gryniewicz <dang@gentoo.org>2007-02-22 23:29:54 +0000
committerDaniel Gryniewicz <dang@gentoo.org>2007-02-22 23:29:54 +0000
commit3f2adef7d298aef692bc44546fd59fd84805fe93 (patch)
treefd6d621218af8b78a2867e733de7f5b2ea59482f /app-accessibility
parentVersion bump, removed 2.2. (diff)
downloadgentoo-2-3f2adef7d298aef692bc44546fd59fd84805fe93.tar.gz
gentoo-2-3f2adef7d298aef692bc44546fd59fd84805fe93.tar.bz2
gentoo-2-3f2adef7d298aef692bc44546fd59fd84805fe93.zip
Bump to 0.4.9
* Fix for bug 398916 to help select the Viavoice Chinese voices. Also fixed a memory leak with the driver. (Gilles Casse) * Fix for bug 399512 to handle config parameters better. (Leonardo Boshell) * Fix for bug 403763 to include math library when building driver for Swift. (Willie Walker) * Brand new driver for eSpeak (http://espeak.sourceforge.net). Many many thanks to Gilles Casse for his contribution here!!! * Fix for bug 321658 to allow ibmtts is unable to select/change voice of a different language. Many many thanks to Gilles Casse for his contribution here!!! (Portage version: 2.1.2-r10)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/gnome-speech/ChangeLog22
-rw-r--r--app-accessibility/gnome-speech/files/digest-gnome-speech-0.4.93
-rw-r--r--app-accessibility/gnome-speech/gnome-speech-0.4.9.ebuild81
3 files changed, 105 insertions, 1 deletions
diff --git a/app-accessibility/gnome-speech/ChangeLog b/app-accessibility/gnome-speech/ChangeLog
index edc81e7e8d62..bfa7ebe5aa3f 100644
--- a/app-accessibility/gnome-speech/ChangeLog
+++ b/app-accessibility/gnome-speech/ChangeLog
@@ -1,6 +1,26 @@
# ChangeLog for app-accessibility/gnome-speech
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-speech/ChangeLog,v 1.79 2007/01/23 14:47:40 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-speech/ChangeLog,v 1.80 2007/02/22 23:29:54 dang Exp $
+
+*gnome-speech-0.4.9 (22 Feb 2007)
+
+ 22 Feb 2007; Daniel Gryniewicz <dang@gentoo.org>
+ +gnome-speech-0.4.9.ebuild:
+ Bump to 0.4.9
+ * Fix for bug 398916 to help select the Viavoice Chinese voices. Also
+ fixed a memory leak with the driver. (Gilles Casse)
+
+ * Fix for bug 399512 to handle config parameters better. (Leonardo Boshell)
+
+ * Fix for bug 403763 to include math library when building driver
+ for Swift. (Willie Walker)
+
+ * Brand new driver for eSpeak (http://espeak.sourceforge.net).
+ Many many thanks to Gilles Casse for his contribution here!!!
+
+ * Fix for bug 321658 to allow ibmtts is unable to select/change voice
+ of a different language. Many many thanks to Gilles Casse for his
+ contribution here!!!
23 Jan 2007; Marius Mauch <genone@gentoo.org> gnome-speech-0.4.0.ebuild,
gnome-speech-0.4.4.ebuild, gnome-speech-0.4.6.ebuild:
diff --git a/app-accessibility/gnome-speech/files/digest-gnome-speech-0.4.9 b/app-accessibility/gnome-speech/files/digest-gnome-speech-0.4.9
new file mode 100644
index 000000000000..579c7c121de4
--- /dev/null
+++ b/app-accessibility/gnome-speech/files/digest-gnome-speech-0.4.9
@@ -0,0 +1,3 @@
+MD5 16d3dfa0275fc121029ab55149429907 gnome-speech-0.4.9.tar.bz2 313077
+RMD160 e01a6197ba49dfb5a9430cbd344633bba76939dd gnome-speech-0.4.9.tar.bz2 313077
+SHA256 37129e49fce3a6b954f2089cbe7e2b26885b0df5efdf6b8f1882077fefeca328 gnome-speech-0.4.9.tar.bz2 313077
diff --git a/app-accessibility/gnome-speech/gnome-speech-0.4.9.ebuild b/app-accessibility/gnome-speech/gnome-speech-0.4.9.ebuild
new file mode 100644
index 000000000000..e037e44d2a19
--- /dev/null
+++ b/app-accessibility/gnome-speech/gnome-speech-0.4.9.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/gnome-speech/gnome-speech-0.4.9.ebuild,v 1.1 2007/02/22 23:29:54 dang Exp $
+
+inherit java-pkg gnome2
+
+DESCRIPTION="Simple general API for producing text-to-speech output"
+HOMEPAGE="http://www.gnome.org/"
+
+LICENSE="LGPL-2"
+SLOT="1"
+KEYWORDS="alpha amd64 hppa ia64 ppc ppc64 sparc x86"
+# espeak not added; it needs tons of keywords
+IUSE="freetts"
+
+COMMON_DEPEND=">=gnome-base/orbit-2.3.94
+ >=gnome-base/libbonobo-1.97
+ >=dev-libs/glib-2
+ freetts? (
+ =app-accessibility/freetts-1.2*
+ >=app-accessibility/java-access-bridge-1.4.6 )"
+
+RDEPEND="$COMMON_DEPEND
+ freetts? ( >=virtual/jre-1.4 )
+ app-accessibility/festival"
+
+DEPEND="$COMMON_DEPEND
+ freetts? (
+ >=virtual/jdk-1.4
+ dev-java/java-config )
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+
+pkg_setup() {
+ G2CONF="--with-festival --with-speech-dispatcher"
+
+ if use freetts; then
+ java-pkg_pkg_setup
+
+ local JABDIR="${ROOT}usr/share/java-access-bridge/lib"
+
+ G2CONF="${G2CONF} --with-java-home=${JAVA_HOME} \
+ --with-jab-dir=${JABDIR} \
+ --with-freetts-dir=${ROOT}usr/share/freetts/lib"
+ else
+ export JAVAC=no
+ fi
+}
+
+src_unpack() {
+ gnome2_src_unpack
+
+ if use freetts; then
+ sed -i -e \
+ 's/@GNOME_SPEECH_INSTALLED_CLASSPATH@/$(java-config -p gnome-speech-1,java-access-bridge)/' \
+ drivers/freetts/freetts-synthesis-driver.in || die "sed error"
+ fi
+
+ sed -i \
+ -e 's:\(GNOME_SPEECH_JAR_DIR=\).*:\1"/usr/share/java-access-bridge/lib/":' \
+ -e 's:\(FREETTS_DRIVER_JAR_DIR=\).*:\1"/usr/share/java-access-bridge/lib/":' \
+ ${S}/configure
+}
+
+src_install() {
+ gnome2_src_install
+
+ if use freetts; then
+ java-pkg_dojar ${D}/usr/share/jar/*.jar
+ rm -rf ${D}/usr/share/jar
+ fi
+}
+
+pkg_postinst() {
+ elog
+ elog "Gnome Speech has been successfully installed. You may now use the"
+ elog "speech interface using app-accessibility/gnopernicus."
+ elog
+}