summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2008-04-26 03:36:49 +0000
committerWilliam Hubbs <williamh@gentoo.org>2008-04-26 03:36:49 +0000
commit1f237b56328e0f332813efc9f0bfaf0b04eb471f (patch)
tree25009c73108821c26ad7efd699848e2e5fb9ed58 /app-accessibility
parentamd64 stable, bug #219136 (diff)
downloadgentoo-2-1f237b56328e0f332813efc9f0bfaf0b04eb471f.tar.gz
gentoo-2-1f237b56328e0f332813efc9f0bfaf0b04eb471f.tar.bz2
gentoo-2-1f237b56328e0f332813efc9f0bfaf0b04eb471f.zip
Fixed festival format strings for bug #218705.
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog10
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.6-festival-fix-formats.patch16
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.4.1.ebuild34
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6-r1.ebuild59
4 files changed, 84 insertions, 35 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index aed44e6e7f54..68f071e34a25 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.35 2008/04/15 16:33:29 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.36 2008/04/26 03:36:49 williamh Exp $
+
+*speech-dispatcher-0.6.6-r1 (26 Apr 2008)
+
+ 26 Apr 2008; William Hubbs <williamh@gentoo.org>
+ +files/speech-dispatcher-0.6.6-festival-fix-formats.patch,
+ -speech-dispatcher-0.4.1.ebuild, +speech-dispatcher-0.6.6-r1.ebuild:
+ Rev bump for #218705, thanks to esigra@gmail.com for the patch. Also, I
+ removed an old version.
15 Apr 2008; Jeroen Roovers <jer@gentoo.org>
speech-dispatcher-0.6.6.ebuild:
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.6-festival-fix-formats.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.6-festival-fix-formats.patch
new file mode 100644
index 000000000000..fa240fda8d86
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.6.6-festival-fix-formats.patch
@@ -0,0 +1,16 @@
+--- speech-dispatcher-0.6.6/src/modules/festival.c 2008-02-08 11:01:09.000000000 +0100
++++ speech-dispatcher-0.6.6.modified/src/modules/festival.c 2008-04-21 11:18:31.000000000 +0200
+@@ -691,5 +691,5 @@
+
+ if (fwave->num_samples != 0){
+- DBG("Sending message to audio: %ld bytes\n",
++ DBG("Sending message to audio: %u bytes\n",
+ (fwave->num_samples) * sizeof(short));
+
+@@ -899,5 +899,5 @@
+ TCounterEntry *centry;
+
+- DBG("Cache: cleaning, cache size %ld kbytes (>max %d).", FestivalCache.size/1024,
++ DBG("Cache: cleaning, cache size %zu kbytes (>max %d).", FestivalCache.size/1024,
+ FestivalCacheMaxKBytes);
+
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.4.1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.4.1.ebuild
deleted file mode 100644
index d47f9849419c..000000000000
--- a/app-accessibility/speech-dispatcher/speech-dispatcher-0.4.1.ebuild
+++ /dev/null
@@ -1,34 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.4.1.ebuild,v 1.10 2007/04/28 16:22:15 swegener Exp $
-
-DESCRIPTION="speech-dispatcher speech synthesis interface"
-HOMEPAGE="http://www.freebsoft.org/speechd"
-SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="x86 ppc amd64"
-IUSE=""
-
-RDEPEND="dev-libs/dotconf
- >=app-accessibility/flite-1.2
- >=dev-libs/glib-2
- media-libs/alsa-lib"
-DEPEND="${RDEPEND}
- dev-util/pkgconfig"
-
-src_install() {
- make DESTDIR=${D} install || die
-
- doinitd ${FILESDIR}/speech-dispatcher
-
- insinto /usr/include
- doins ${S}/src/c/api/libspeechd.h
-}
-
-pkg_postinst() {
- elog
- elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
- elog
-}
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6-r1.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6-r1.ebuild
new file mode 100644
index 000000000000..5c1351e3ee6d
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6-r1.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.6.6-r1.ebuild,v 1.1 2008/04/26 03:36:49 williamh Exp $
+
+inherit eutils
+
+DESCRIPTION="speech-dispatcher speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="alsa flite nas pulseaudio python"
+
+DEPEND="dev-libs/dotconf
+ >=dev-libs/glib-2
+ dev-util/pkgconfig
+ alsa? ( media-libs/alsa-lib )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )
+ python? ( dev-lang/python )
+ app-accessibility/espeak"
+
+src_unpack() {
+ unpack ${A}
+ sed -i -e 's/\(SUBDIRS.*\)python/\1/' "${S}"/src/Makefile.in
+ epatch "${FILESDIR}"/${P}-festival-fix-formats.patch
+}
+
+src_compile() {
+ econf \
+ $(use_with alsa) \
+ $(use_with flite) \
+ $(use_with pulseaudio pulse) \
+ $(use_with nas) || die "configure failed"
+ make all || die "make failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+
+ if use python; then
+ cd "${S}"/src/python
+ ./setup.py install --root="${D}" --no-compile
+ cd "${S}"
+ fi
+
+ insinto /usr/include
+ doins "${S}"/src/c/api/libspeechd.h
+
+ dodoc AUTHORS ChangeLog NEWS TODO
+ newinitd "${FILESDIR}"/speech-dispatcher speech-dispatcher
+}
+
+pkg_postinst() {
+ elog "To enable Festival support, you must install app-accessibility/festival-freebsoft-utils."
+}