summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-17 12:15:09 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-17 12:15:09 +0000
commit19809bea3472d014ef198093c308ae216be2ab96 (patch)
tree7ad9f69ea7aaf3c23f04a150fa991ecaf566699d /app-accessibility
parentvanilla-3.8.2 + genpatches-3.8-3 + grsecurity-2.9.1-3.8.3-201303142235 (diff)
downloadgentoo-2-19809bea3472d014ef198093c308ae216be2ab96.tar.gz
gentoo-2-19809bea3472d014ef198093c308ae216be2ab96.tar.bz2
gentoo-2-19809bea3472d014ef198093c308ae216be2ab96.zip
app-accessibility/speech-dispatcher: Fix linking with gold, #442332; move to new python eclasses, #456978
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 8009D6F070EB7916)
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/speech-dispatcher/ChangeLog10
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-doc.patch10
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-gold.patch29
-rw-r--r--app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-pthread.patch13
-rw-r--r--app-accessibility/speech-dispatcher/metadata.xml18
-rw-r--r--app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r2.ebuild122
6 files changed, 192 insertions, 10 deletions
diff --git a/app-accessibility/speech-dispatcher/ChangeLog b/app-accessibility/speech-dispatcher/ChangeLog
index 993915368316..1d8c9297423a 100644
--- a/app-accessibility/speech-dispatcher/ChangeLog
+++ b/app-accessibility/speech-dispatcher/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for app-accessibility/speech-dispatcher
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.81 2013/01/01 11:33:28 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/ChangeLog,v 1.82 2013/03/17 12:15:09 jlec Exp $
+
+*speech-dispatcher-0.7.1-r2 (17 Mar 2013)
+
+ 17 Mar 2013; Justin Lecher <jlec@gentoo.org>
+ +speech-dispatcher-0.7.1-r2.ebuild, +files/speech-dispatcher-0.7.1-doc.patch,
+ +files/speech-dispatcher-0.7.1-gold.patch,
+ +files/speech-dispatcher-0.7.1-pthread.patch, metadata.xml:
+ Fix linking with gold, #442332; move to new python eclasses, #456978
01 Jan 2013; Agostino Sarubbo <ago@gentoo.org>
speech-dispatcher-0.7.1-r1.ebuild:
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-doc.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-doc.patch
new file mode 100644
index 000000000000..af9b0896c261
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-doc.patch
@@ -0,0 +1,10 @@
+Index: speech-dispatcher/doc/Makefile.am
+===================================================================
+--- speech-dispatcher.orig/doc/Makefile.am 2010-09-13 17:50:28.000000000 +0200
++++ speech-dispatcher/doc/Makefile.am 2010-09-13 17:50:36.000000000 +0200
+@@ -1,3 +1,3 @@
+
+-info_TEXINFOS = ssip.texi speech-dispatcher.texi spd-say.texi
+-EXTRA_DIST = figures gpl.texi fdl.texi speech-dispatcher-cs.texi speech-dispatcher-cs.texi
++info_TEXINFOS = ssip.texi speech-dispatcher.texi spd-say.texi speech-dispatcher-cs.texi
++EXTRA_DIST = figures gpl.texi fdl.texi
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-gold.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-gold.patch
new file mode 100644
index 000000000000..54f87d290c07
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-gold.patch
@@ -0,0 +1,29 @@
+ src/audio/Makefile.am | 3 ++-
+ 1 file changed, 2 insertions(+), 1 deletion(-)
+
+diff --git a/src/audio/Makefile.am b/src/audio/Makefile.am
+index 3b596f6..ec23c9f 100644
+--- a/src/audio/Makefile.am
++++ b/src/audio/Makefile.am
+@@ -11,7 +11,7 @@ endif
+
+ if pulse_support
+ PULSE_FLAGS = -DWITH_PULSE
+-PULSE_LIBS = -lpulse-simple
++PULSE_LIBS = -lpulse-simple -lpulse
+ endif
+
+ if alsa_support
+@@ -31,7 +31,8 @@ endif
+ EXTRA_DIST = alsa.c libao.c oss.c nas.c pulse.c
+
+ AM_CFLAGS = $(am_cflags) $(NAS_FLAGS) $(PULSE_FLAGS) $(ALSA_FLAGS) $(LIBAO_FLAGS) $(LIBOSS_FLAGS)
+-libsdaudio_la_LDFLAGS = -version-info @LIB_SDAUDIO_CURRENT@:@LIB_SDAUDIO_REVISION@:@LIB_SDAUDIO_AGE@ -lpthread $(NAS_LIBS) $(PULSE_LIBS) $(ALSA_LIBS) $(LIBAO_LIBS)
++libsdaudio_la_LDFLAGS = -version-info @LIB_SDAUDIO_CURRENT@:@LIB_SDAUDIO_REVISION@:@LIB_SDAUDIO_AGE@
++libsdaudio_la_LIBADD = -lpthread $(NAS_LIBS) $(PULSE_LIBS) $(ALSA_LIBS) $(LIBAO_LIBS)
+
+ spdlib_LTLIBRARIES = libsdaudio.la
+
+ src/audio/Makefile.am | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
diff --git a/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-pthread.patch b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-pthread.patch
new file mode 100644
index 000000000000..8b9577144482
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/files/speech-dispatcher-0.7.1-pthread.patch
@@ -0,0 +1,13 @@
+Index: speech-dispatcher/src/c/api/Makefile.am
+===================================================================
+--- speech-dispatcher.orig/src/c/api/Makefile.am 2010-10-01 20:17:24.000000000 +0200
++++ speech-dispatcher/src/c/api/Makefile.am 2010-10-01 20:17:26.000000000 +0200
+@@ -8,6 +8,6 @@
+ libspeechd_la_SOURCES = libspeechd.c
+ libspeechd_la_HEADERS = libspeechd.h
+ libspeechd_ladir = $(includedir)
+-libspeechd_la_LDFLAGS = -version-info @LIB_SPD_CURRENT@:@LIB_SPD_REVISION@:@LIB_SPD_AGE@ -lpthread
+-libspeechd_la_LIBADD = @glib_libs@
++libspeechd_la_LDFLAGS = -version-info @LIB_SPD_CURRENT@:@LIB_SPD_REVISION@:@LIB_SPD_AGE@
++libspeechd_la_LIBADD = @glib_libs@ -lpthread
+
diff --git a/app-accessibility/speech-dispatcher/metadata.xml b/app-accessibility/speech-dispatcher/metadata.xml
index 64fdbe0bae0d..9c608d4058b8 100644
--- a/app-accessibility/speech-dispatcher/metadata.xml
+++ b/app-accessibility/speech-dispatcher/metadata.xml
@@ -1,13 +1,13 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>accessibility</herd>
-<herd>sound</herd>
-<maintainer>
- <email>williamh@gentoo.org</email>
-</maintainer>
-<use>
- <flag name='espeak'>Adds support for espeak speech engine</flag>
- <flag name='flite'>Adds support for flite speech engine</flag>
-</use>
+ <herd>accessibility</herd>
+ <herd>sound</herd>
+ <maintainer>
+ <email>williamh@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="espeak">Adds support for espeak speech engine</flag>
+ <flag name="flite">Adds support for flite speech engine</flag>
+ </use>
</pkgmetadata>
diff --git a/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r2.ebuild b/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r2.ebuild
new file mode 100644
index 000000000000..53fd040d31e1
--- /dev/null
+++ b/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r2.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/speech-dispatcher/speech-dispatcher-0.7.1-r2.ebuild,v 1.1 2013/03/17 12:15:09 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
+
+AUTOTOOLS_AUTORECONF=true
+
+inherit autotools-utils python-r1
+
+DESCRIPTION="Speech synthesis interface"
+HOMEPAGE="http://www.freebsoft.org/speechd"
+SRC_URI="http://www.freebsoft.org/pub/projects/speechd/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="alsa ao +espeak flite nas pulseaudio python static-libs"
+
+RDEPEND="
+ dev-libs/dotconf
+ >=dev-libs/glib-2
+ alsa? ( media-libs/alsa-lib )
+ ao? ( media-libs/libao )
+ espeak? ( app-accessibility/espeak )
+ flite? ( app-accessibility/flite )
+ nas? ( media-libs/nas )
+ pulseaudio? ( media-sound/pulseaudio )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-pthread.patch
+ "${FILESDIR}"/${P}-doc.patch
+ "${FILESDIR}"/${P}-gold.patch
+ )
+
+src_prepare() {
+ # Python bindings are built/installed manually.
+ sed -e "/SUBDIRS += python/d" -i src/Makefile.am || die
+
+ autotools-utils_src_prepare
+}
+
+src_configure() {
+ local myeconfargs=(
+ $(use_enable python)
+ $(use_with alsa)
+ $(use_with ao libao)
+ $(use_with espeak)
+ $(use_with flite)
+ $(use_with pulseaudio pulse)
+ $(use_with nas)
+ )
+ autotools-utils_src_configure
+}
+
+src_compile() {
+ use python && python_copy_sources
+
+ autotools-utils_src_compile all
+
+ if use python; then
+ building() {
+ cd src/python || die
+ emake \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)"
+ }
+ python_foreach_impl run_in_build_dir building
+ fi
+}
+
+src_install() {
+ autotools-utils_src_install
+
+ if use python; then
+ installation() {
+ cd src/python || die
+ emake \
+ DESTDIR="${D}" \
+ pyexecdir="$(python_get_sitedir)" \
+ pythondir="$(python_get_sitedir)" \
+ install
+ }
+ python_foreach_impl run_in_build_dir installation
+ python_replicate_script "${ED}"/usr/bin/spd-conf
+ fi
+
+ local f
+ for f in clibrary clibrary2 connection_recovery long_message run_test; do
+ rm "${ED}"/usr/bin/${f} || die
+ done
+}
+
+pkg_postinst() {
+ local editconfig="n"
+ if ! use espeak; then
+ ewarn "You have disabled espeak, which is speech-dispatcher's"
+ ewarn "default speech synthesizer."
+ ewarn
+ editconfig="y"
+ fi
+ if ! use pulseaudio; then
+ ewarn "You have disabled pulseaudio support."
+ ewarn "pulseaudio is speech-dispatcher's default audio subsystem."
+ ewarn
+ editconfig="y"
+ fi
+ if [[ "${editconfig}" == "y" ]]; then
+ ewarn "You must edit ${EROOT}etc/speech-dispatcher/speechd.conf"
+ ewarn "and make sure the settings there match your system."
+ ewarn
+ fi
+ ewarn "This version does not include a system wide startup script"
+ ewarn "since it is not intended to be run in system-wide mode."
+ ewarn
+ elog "For festival support, you need to"
+ elog "install app-accessibility/festival-freebsoft-utils."
+}