summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorWilliam Hubbs <williamh@gentoo.org>2009-05-31 16:44:33 +0000
committerWilliam Hubbs <williamh@gentoo.org>2009-05-31 16:44:33 +0000
commite23f325bfd5e0199393c3fc88a71c1584160d66e (patch)
treecabb29fb874e272a42968da86b5e65459e55e40a /app-accessibility/espeakup/espeakup-0.71.ebuild
parentamd64/x86 stable, bug #271910 (diff)
downloadgentoo-2-e23f325bfd5e0199393c3fc88a71c1584160d66e.tar.gz
gentoo-2-e23f325bfd5e0199393c3fc88a71c1584160d66e.tar.bz2
gentoo-2-e23f325bfd5e0199393c3fc88a71c1584160d66e.zip
Version bump.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'app-accessibility/espeakup/espeakup-0.71.ebuild')
-rw-r--r--app-accessibility/espeakup/espeakup-0.71.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/app-accessibility/espeakup/espeakup-0.71.ebuild b/app-accessibility/espeakup/espeakup-0.71.ebuild
new file mode 100644
index 000000000000..b06a1151864e
--- /dev/null
+++ b/app-accessibility/espeakup/espeakup-0.71.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/app-accessibility/espeakup/espeakup-0.71.ebuild,v 1.1 2009/05/31 16:44:33 williamh Exp $
+
+DESCRIPTION="espeakup is a small lightweight connector for espeak and speakup"
+HOMEPAGE="http://www.linux-speakup.org"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="app-accessibility/espeak"
+RDEPEND="${DEPEND}
+ app-accessibility/speakup"
+
+src_compile() {
+ emake || die "Compile failed."
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "Install failed."
+ dodoc ChangeLog README ToDo
+ newconfd "${FILESDIR}"/espeakup.confd espeakup
+ newinitd "${FILESDIR}"/espeakup.rc espeakup
+}
+
+pkg_postinst() {
+ elog "To get espeakup to start automatically, it is currently recommended"
+ echo "that you add it to the default run level, by giving the following"
+ elog "command as root."
+ elog
+ elog "rc-update add espeakup default"
+ elog
+ elog "You can also set a default voice now for espeakup."
+ elog "See /etc/conf.d/espeakup for how to do this."
+}