summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-02-02 22:23:45 +0000
committerJustin Lecher <jlec@gentoo.org>2010-02-02 22:23:45 +0000
commitf9e8bd72c6e339f5b520e57ce9b22d7366f30fd6 (patch)
tree77256e3c89dd77204c4d7851422c6917e0df2aa1
parentMissed a commit to the eclass. (diff)
downloadgentoo-2-f9e8bd72c6e339f5b520e57ce9b22d7366f30fd6.tar.gz
gentoo-2-f9e8bd72c6e339f5b520e57ce9b22d7366f30fd6.tar.bz2
gentoo-2-f9e8bd72c6e339f5b520e57ce9b22d7366f30fd6.zip
Automated crystallographic structure solution for MIR, SAD, and MAD
(Portage version: 2.2_rc62/cvs/Linux x86_64)
-rw-r--r--sci-chemistry/solve-resolve-bin/ChangeLog10
-rw-r--r--sci-chemistry/solve-resolve-bin/metadata.xml7
-rw-r--r--sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild60
3 files changed, 77 insertions, 0 deletions
diff --git a/sci-chemistry/solve-resolve-bin/ChangeLog b/sci-chemistry/solve-resolve-bin/ChangeLog
new file mode 100644
index 000000000000..199f8c023277
--- /dev/null
+++ b/sci-chemistry/solve-resolve-bin/ChangeLog
@@ -0,0 +1,10 @@
+# ChangeLog for sci-chemistry/solve-resolve-bin
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/solve-resolve-bin/ChangeLog,v 1.1 2010/02/02 22:23:45 jlec Exp $
+
+*solve-resolve-bin-2.13 (02 Feb 2010)
+
+ 02 Feb 2010; Justin Lecher (jlec) <jlec@gentoo.org>
+ +solve-resolve-bin-2.13.ebuild, +metadata.xml:
+ Automated crystallographic structure solution for MIR, SAD, and MAD
+
diff --git a/sci-chemistry/solve-resolve-bin/metadata.xml b/sci-chemistry/solve-resolve-bin/metadata.xml
new file mode 100644
index 000000000000..d691b2482707
--- /dev/null
+++ b/sci-chemistry/solve-resolve-bin/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<pkgmetadata>
+<herd>sci-chemistry</herd>
+<maintainer>
+ <email>jlec@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild b/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild
new file mode 100644
index 000000000000..f84233650680
--- /dev/null
+++ b/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sci-chemistry/solve-resolve-bin/solve-resolve-bin-2.13.ebuild,v 1.1 2010/02/02 22:23:45 jlec Exp $
+
+EAPI="3"
+
+inherit eutils
+
+DESCRIPTION="Automated crystallographic structure solution for MIR, SAD, and MAD"
+HOMEPAGE="http://www.solve.lanl.gov/index.html"
+SRC_URI="x86? ( http://solve.lanl.gov/pub/solve/${PV}/solve-${PV}-linux.tar.gz )
+ amd64? ( http://solve.lanl.gov/pub/solve/${PV}/solve-${PV}-linux-64.tar.gz )"
+
+SLOT="0"
+LICENSE="solve"
+KEYWORDS="-* ~x86 ~amd64"
+IUSE="examples"
+
+RDEPEND="sci-libs/ccp4-libs"
+DEPEND=""
+
+RESTRICT="mirror"
+S="${WORKDIR}"/solve-${PV}
+
+IN_PATH="/opt/solve-resolve/"
+
+src_install(){
+ exeinto ${IN_PATH}bin/
+ doexe bin/*
+
+ insinto ${IN_PATH}lib/
+ doins -r lib/{*sym,sym*,hist*,*dat,segments,patterns} || die
+
+ dohtml -r lib/html/* || die
+ sed -i 's:/usr/local/lib/solve/:${EPREFIX}/opt/solve-resolve/lib/:' \
+ lib/examples_solve/p9/solve*
+ if use examples; then
+ sed -i 's:/usr/local/lib/resolve/:${EPREFIX}/opt/solve-resolve/lib/:' \
+ lib/examples_resolve/{resolve.csh,prime_and_switch.csh}
+ insinto /usr/share/${PF}/
+ doins -r lib/examples_*solve || die
+ fi
+
+ cat >> "${T}"/20solve-resolve <<- EOF
+ CCP4_OPEN="UNKNOWN"
+ SYMOP="${EPREFIX}/usr/share/ccp4/data/symop.lib"
+ SYMINFO="${EPREFIX}/usr/share/ccp4/data/syminfo.lib"
+ SOLVEDIR="${EPREFIX}/${IN_PATH}lib/"
+ PATH="${EPREFIX}/${IN_PATH}bin"
+ EOF
+
+ doenvd "${T}"/20solve-resolve
+}
+
+pkg_postinst(){
+ einfo "Get a valid license key from"
+ einfo "http://solve.lanl.gov/license.html"
+ einfo "and place it in"
+ einfo "${EPREFIX}/${IN_PATH}lib/"
+}